]> git.pld-linux.org Git - packages/distcc.git/blob - distcc.spec
- BuildRequires: libgnomeui-devel
[packages/distcc.git] / distcc.spec
1 #
2 # Conditional build:
3 %bcond_without  gnome   # build without gnome(monitor) support
4 #
5 Summary:        Program to distribute compilation of C or C++
6 Summary(pl):    Program do rozdzielania kompilacji programów w C lub C++
7 Name:           distcc
8 Group:          Development/Languages
9 Version:        2.14
10 Release:        0.1
11 License:        GPL
12 Source0:        http://distcc.samba.org/ftp/distcc/%{name}-%{version}.tar.bz2
13 # Source0-md5:  612ee81b3e04fc6000dfbc4078ec9d8b
14 Source1:        %{name}.inetd
15 Source2:        %{name}.init
16 Source3:        %{name}.sh
17 Source4:        %{name}.csh
18 Source5:        %{name}.config
19 Source6:        %{name}.logrotate
20 Patch0:         %{name}-user.patch
21 Patch1:         %{name}-waal.patch
22 URL:            http://distcc.samba.org/
23 BuildRequires:  autoconf >= 2.53
24 %{?with_gnome:BuildRequires:    libgnome-devel >= 2.0}
25 %{?with_gnome:BuildRequires:    libgnomeui-devel}
26 BuildRequires:  pkgconfig
27 BuildRequires:  popt-devel
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 distcc is a program to distribute compilation of C or C++ code across
32 several machines on a network. distcc should always generate the same
33 results as a local compile, is simple to install and use, and is often
34 two or more times faster than a local compile.
35
36 %description -l pl
37 distcc jest programem pozwalaj±cym na dystrybucjê kompilacji C lub C++
38 na kilka maszyn w sieci. distcc powinien zawsze generowaæ takie same
39 rezultaty jak lokalna kompilacja, jest prosty w instalacji i u¿yciu
40 oraz bardzo czêsto dwa lub wiêcej razy szybszy ni¿ lokalna kompilacja.
41
42 %package common
43 Summary:        Common files for inetd and standalone versions of distcc
44 Summary(pl):    Pliki wspólne dla wersji inetd i standalone distcc
45 Group:          Daemons
46 Requires:       gcc
47 Requires:       gcc-c++
48 Obsoletes:      %{name} < %{name}-2.1-2
49
50 %description common
51 distcc is a program to distribute compilation of C or C++ code across
52 several machines on a network. distcc should always generate the same
53 results as a local compile, is simple to install and use, and is often
54 two or more times faster than a local compile.
55
56 %description common -l pl
57 distcc jest programem pozwalaj±cym na dystrybucjê kompilacji C lub C++
58 na kilka maszyn w sieci. distcc powinien zawsze generowaæ takie same
59 rezultaty jak lokalna kompilacja, jest prosty w instalacji i u¿yciu
60 oraz bardzo czêsto dwa lub wiêcej razy szybszy ni¿ lokalna kompilacja.
61
62 %package inetd
63 Summary:        inetd configs for distcc
64 Summary(pl):    Pliki konfiguracyjne do u¿ycia distcc poprzez inetd
65 Group:          Daemons
66 PreReq:         %{name}-common = %{version}
67 PreReq:         rc-inetd
68 Obsoletes:      %{name} < %{name}-2.1-2
69
70 %description inetd
71 distcc configs for running from inetd.
72
73 %description inetd -l pl
74 Pliki konfiguracyjna distcc do startowania demona poprzez inetd.
75
76 %package standalone
77 Summary:        Standalone daemon configs for distcc
78 Summary(pl):    Pliki konfiguracyjne do startowania distcc w trybie standalone
79 Group:          Daemons
80 PreReq:         %{name}-common = %{version}
81 PreReq:         rc-scripts
82 Requires(post,preun):   /sbin/chkconfig
83 Obsoletes:      %{name} < %{name}-2.1-2
84
85 %description standalone
86 distcc configs for running as a standalone daemon.
87
88 %description standalone -l pl
89 Pliki konfiguracyjne distcc do startowania demona w trybie
90 standalone.
91
92 %package monitor
93 Summary:        Monitor for distcc
94 Summary(pl):    Monitor dla distcc
95 Group:          Applications
96
97 %description monitor
98 Monitor for distcc.
99
100 %description monitor -l pl
101 Monitor dla distcc.
102
103 %package monitor-gnome
104 Summary:        gtk monitor for distcc
105 Summary(pl):    Monitor gtk dla distcc
106 Group:          X11/Applications
107
108 %description monitor-gnome
109 gtk monitor for distcc.
110
111 %description monitor-gnome -l pl
112 Monitor gtk dla distcc.
113
114 %prep
115 %setup -q
116 %patch0 -p1
117 #%patch1 -p1
118
119 %build
120 %{__autoconf}
121 %{__autoheader}
122 %configure \
123         --enable-rfc2553 \
124         %{?with_gnome:--with-gnome} 
125
126 %{__make}
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d,profile.d,logrotate.d} \
131         $RPM_BUILD_ROOT%{_applnkdir}/Network/Misc $RPM_BUILD_ROOT%{_pixmapsdir} \
132         $RPM_BUILD_ROOT%{_var}/log
133
134 %{__make} install \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/distccd
138 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/distcc
139 install %{SOURCE3} %{SOURCE4} $RPM_BUILD_ROOT/etc/profile.d
140 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/distccd
141 install %{SOURCE6} $RPM_BUILD_ROOT/etc/logrotate.d/distccd
142
143 %if %{with gnome}
144 mv $RPM_BUILD_ROOT%{_datadir}/%{name}/distccmon-gnome.desktop \
145         $RPM_BUILD_ROOT%{_applnkdir}/Network/Misc
146 mv $RPM_BUILD_ROOT%{_datadir}/%{name}/distccmon-gnome-icon.png \
147         $RPM_BUILD_ROOT%{_pixmapsdir}
148 %endif
149
150 touch $RPM_BUILD_ROOT%{_var}/log/distcc
151
152 %clean
153 rm -rf $RPM_BUILD_ROOT
154
155 %post inetd
156 if [ -f /var/lock/subsys/rc-inetd ]; then
157         /etc/rc.d/init.d/rc-inetd reload 1>&2
158 else
159         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server" 1>&2
160 fi
161
162 %postun inetd
163 if [ -f /var/lock/subsys/rc-inetd ]; then
164         /etc/rc.d/init.d/rc-inetd reload
165 fi
166
167 %post standalone
168 /sbin/chkconfig --add distcc
169 if [ -f /var/lock/subsys/distccd ]; then
170         /etc/rc.d/init.d/distcc restart 1>&2
171 else
172         echo "Run \"/etc/rc.d/init.d/distcc start\" to start distcc daemon."
173 fi
174
175 %preun standalone
176 if [ "$1" = "0" ]; then
177         if [ -f /var/lock/subsys/distccd ]; then
178                 /etc/rc.d/init.d/distcc stop 1>&2
179         fi
180         /sbin/chkconfig --del distcc
181 fi
182
183 %files
184 %defattr(644,root,root,755)
185 %doc AUTHORS NEWS README *.txt
186 %attr(755,root,root) %{_bindir}/%{name}
187 %{_mandir}/man?/%{name}.*
188 /etc/profile.d/*sh
189
190 %files common
191 %defattr(644,root,root,755)
192 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/distccd
193 %attr(640,root,root) %ghost %{_var}/log/distcc
194 %attr(640,root,root) /etc/logrotate.d/distccd
195 %attr(755,root,root) %{_bindir}/%{name}d
196 %{_mandir}/man?/%{name}d.*
197 %attr(640,nobody,root) %ghost %{_var}/log/distcc
198
199 %files inetd
200 %defattr(644,root,root,755)
201 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/rc-inetd/distccd
202
203 %files standalone
204 %defattr(644,root,root,755)
205 %attr(754,root,root) /etc/rc.d/init.d/distcc
206
207 %files monitor
208 %defattr(644,root,root,755)
209 %attr(755,root,root) %{_bindir}/distccmon-text
210 %{_mandir}/man1/distccmon-text.*
211 %if %{with gnome}
212 %attr(755,root,root) %{_bindir}/distccmon-gnome
213 %{_applnkdir}/Network/Misc/*.desktop
214 %{_pixmapsdir}/*
215 %endif
This page took 0.051757 seconds and 3 git commands to generate.