]> git.pld-linux.org Git - packages/distcc.git/blob - distcc.spec
- rel 2
[packages/distcc.git] / distcc.spec
1 #
2 # Conditional build:
3 # _without_gtk  build without gtk2(monitor) support
4 #
5 Summary:        Program to distribute compilation of C or C++
6 Summary(pl):    Program do rozdzielania kompilacji programów w C lub C++
7 Name:           distcc
8 Group:          Development/Languages
9 Version:        2.9
10 Release:        2
11 License:        GPL
12 URL:            http://distcc.samba.org/
13 Source0:        http://distcc.samba.org/ftp/distcc/%{name}-%{version}.tar.bz2
14 # Source0-md5:  fa4cbb8dbebb0d87b0d1da7d2d34bf57
15 Source1:        %{name}.inetd
16 Source2:        %{name}.init
17 Source3:        %{name}.sh
18 Source4:        %{name}.csh
19 Source5:        %{name}.config
20 Patch0:         %{name}-user.patch
21 %{!?_without_gtk:BuildRequires: gtk+2-devel >= 2.0}
22 BuildRequires:  popt-devel
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 distcc is a program to distribute compilation of C or C++ code across
27 several machines on a network. distcc should always generate the same
28 results as a local compile, is simple to install and use, and is often
29 two or more times faster than a local compile.
30
31 %description -l pl
32 distcc jest programem pozwalaj±cym na dystrybucjê kompilacji C lub C++
33 na kilka maszyn w sieci. distcc powinien zawsze generowaæ takie same
34 rezultaty jak lokalna kompilacja, jest prosty w instalacji i u¿yciu
35 oraz bardzo czêsto dwa lub wiêcej razy szybszy ni¿ lokalna kompilacja.
36
37 %package common
38 Summary:        Common files for inetd and standalone versions of distcc
39 Summary(pl):    Pliki wspólne dla wersji inetd i standalone distcc
40 Group:          Daemons
41 Requires:       gcc
42 Requires:       gcc-c++
43 Obsoletes:      %{name} < %{name}-2.1-2
44
45 %description common
46 distcc is a program to distribute compilation of C or C++ code across
47 several machines on a network. distcc should always generate the same
48 results as a local compile, is simple to install and use, and is often
49 two or more times faster than a local compile.
50
51 %description -l pl common
52 distcc jest programem pozwalaj±cym na dystrybucjê kompilacji C lub C++
53 na kilka maszyn w sieci. distcc powinien zawsze generowaæ takie same
54 rezultaty jak lokalna kompilacja, jest prosty w instalacji i u¿yciu
55 oraz bardzo czêsto dwa lub wiêcej razy szybszy ni¿ lokalna kompilacja.
56
57
58 %package inetd
59 Summary:        inetd configs for distcc
60 Summary(pl):    Pliki konfiguracyjne do u¿ycia distcc poprzez inetd
61 Group:          Daemons
62 PreReq:         %{name}-common = %{version}
63 PreReq:         rc-inetd
64 Obsoletes:      %{name} < %{name}-2.1-2
65
66 %description inetd
67 distcc configs for running from inetd.
68
69 %description inetd -l pl
70 Pliki konfiguracyjna distcc do startowania demona poprzez inetd.
71
72 %package standalone
73 Summary:        standalone daemon configs for distcc
74 Summary(pl):    Pliki konfiguracyjne do startowania distcc w trybie standalone
75 Group:          Daemons
76 PreReq:         %{name}-common = %{version}
77 PreReq:         rc-scripts
78 Requires(post,preun):   /sbin/chkconfig
79 Obsoletes:      %{name} < %{name}-2.1-2
80
81 %description standalone
82 distcc configs for running as a standalone daemon.
83
84 %description standalone -l pl
85 Pliki konfiguracyjne distcc do startowania demona w trybie
86 standalone.
87
88 %prep
89 %setup -q
90 %patch -p1
91
92 %build
93 %configure \
94         %{!?_without_gtk: --enable-gnome}
95
96 %{__make}
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100 install -d $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd \
101            $RPM_BUILD_ROOT/etc/rc.d/init.d \
102            $RPM_BUILD_ROOT/etc/profile.d
103
104 %{__make} install \
105         DESTDIR=$RPM_BUILD_ROOT
106
107 install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/distccd
108 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/distcc
109 install %{SOURCE3} %{SOURCE4} $RPM_BUILD_ROOT/etc/profile.d
110 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/distccd
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post inetd
116 if [ -f /var/lock/subsys/rc-inetd ]; then
117         /etc/rc.d/init.d/rc-inetd reload 1>&2
118 else
119         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server" 1>&2
120 fi
121
122 %postun inetd
123 if [ -f /var/lock/subsys/rc-inetd ]; then
124         /etc/rc.d/init.d/rc-inetd reload
125 fi
126
127 %post standalone
128 /sbin/chkconfig --add distcc
129 if [ -f /var/lock/subsys/distccd ]; then
130         /etc/rc.d/init.d/distcc restart 1>&2
131 else
132         echo "Run \"/etc/rc.d/init.d/distcc start\" to start distcc daemon."
133 fi
134
135 %preun standalone
136 if [ "$1" = "0" ]; then
137         if [ -f /var/lock/subsys/distccd ]; then
138                 /etc/rc.d/init.d/distcc stop 1>&2
139         fi
140         /sbin/chkconfig --del distcc
141 fi
142
143 %files common
144 %defattr(644,root,root,755)
145 %doc AUTHORS NEWS README *.txt
146 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/distccd
147 %attr(755,root,root) %{_bindir}/*
148 %attr(644,root,root) %{_mandir}/man?/*
149 %attr(644,root,root) /etc/profile.d/*sh
150
151 %files inetd
152 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/rc-inetd/distccd
153
154 %files standalone
155 %attr(755,root,root) /etc/rc.d/init.d/distcc
This page took 0.06022 seconds and 3 git commands to generate.