]> git.pld-linux.org Git - packages/distcc.git/blob - distcc.spec
- gnome by default; TODO: fix log owner
[packages/distcc.git] / distcc.spec
1 #
2 # Conditional build:
3 %bcond_without  gnome   # build without gnome(monitor) support
4 #
5 Summary:        Program to distribute compilation of C or C++
6 Summary(pl):    Program do rozdzielania kompilacji programów w C lub C++
7 Name:           distcc
8 Group:          Development/Languages
9 Version:        2.14
10 Release:        0.1
11 License:        GPL
12 Source0:        http://distcc.samba.org/ftp/distcc/%{name}-%{version}.tar.bz2
13 # Source0-md5:  612ee81b3e04fc6000dfbc4078ec9d8b
14 Source1:        %{name}.inetd
15 Source2:        %{name}.init
16 Source3:        %{name}.sh
17 Source4:        %{name}.csh
18 Source5:        %{name}.config
19 Source6:        %{name}.logrotate
20 Patch0:         %{name}-user.patch
21 Patch1:         %{name}-waal.patch
22 URL:            http://distcc.samba.org/
23 BuildRequires:  autoconf >= 2.53
24 %{?with_gnome:BuildRequires:    libgnome-devel >= 2.0}
25 BuildRequires:  pkgconfig
26 BuildRequires:  popt-devel
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 distcc is a program to distribute compilation of C or C++ code across
31 several machines on a network. distcc should always generate the same
32 results as a local compile, is simple to install and use, and is often
33 two or more times faster than a local compile.
34
35 %description -l pl
36 distcc jest programem pozwalaj±cym na dystrybucjê kompilacji C lub C++
37 na kilka maszyn w sieci. distcc powinien zawsze generowaæ takie same
38 rezultaty jak lokalna kompilacja, jest prosty w instalacji i u¿yciu
39 oraz bardzo czêsto dwa lub wiêcej razy szybszy ni¿ lokalna kompilacja.
40
41 %package common
42 Summary:        Common files for inetd and standalone versions of distcc
43 Summary(pl):    Pliki wspólne dla wersji inetd i standalone distcc
44 Group:          Daemons
45 Requires:       gcc
46 Requires:       gcc-c++
47 Obsoletes:      %{name} < %{name}-2.1-2
48
49 %description common
50 distcc is a program to distribute compilation of C or C++ code across
51 several machines on a network. distcc should always generate the same
52 results as a local compile, is simple to install and use, and is often
53 two or more times faster than a local compile.
54
55 %description common -l pl
56 distcc jest programem pozwalaj±cym na dystrybucjê kompilacji C lub C++
57 na kilka maszyn w sieci. distcc powinien zawsze generowaæ takie same
58 rezultaty jak lokalna kompilacja, jest prosty w instalacji i u¿yciu
59 oraz bardzo czêsto dwa lub wiêcej razy szybszy ni¿ lokalna kompilacja.
60
61 %package inetd
62 Summary:        inetd configs for distcc
63 Summary(pl):    Pliki konfiguracyjne do u¿ycia distcc poprzez inetd
64 Group:          Daemons
65 PreReq:         %{name}-common = %{version}
66 PreReq:         rc-inetd
67 Obsoletes:      %{name} < %{name}-2.1-2
68
69 %description inetd
70 distcc configs for running from inetd.
71
72 %description inetd -l pl
73 Pliki konfiguracyjna distcc do startowania demona poprzez inetd.
74
75 %package standalone
76 Summary:        Standalone daemon configs for distcc
77 Summary(pl):    Pliki konfiguracyjne do startowania distcc w trybie standalone
78 Group:          Daemons
79 PreReq:         %{name}-common = %{version}
80 PreReq:         rc-scripts
81 Requires(post,preun):   /sbin/chkconfig
82 Obsoletes:      %{name} < %{name}-2.1-2
83
84 %description standalone
85 distcc configs for running as a standalone daemon.
86
87 %description standalone -l pl
88 Pliki konfiguracyjne distcc do startowania demona w trybie
89 standalone.
90
91 %package monitor
92 Summary:        Monitor for distcc
93 Summary(pl):    Monitor dla distcc
94 Group:          Applications
95
96 %description monitor
97 Monitor for distcc.
98
99 %description monitor -l pl
100 Monitor dla distcc.
101
102 %package monitor-gnome
103 Summary:        gtk monitor for distcc
104 Summary(pl):    Monitor gtk dla distcc
105 Group:          X11/Applications
106
107 %description monitor-gnome
108 gtk monitor for distcc.
109
110 %description monitor-gnome -l pl
111 Monitor gtk dla distcc.
112
113 %prep
114 %setup -q
115 %patch0 -p1
116 #%patch1 -p1
117
118 %build
119 %{__autoconf}
120 %{__autoheader}
121 %configure \
122         --enable-rfc2553 \
123         %{?with_gnome:--with-gnome} 
124
125 %{__make}
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d,profile.d,logrotate.d} \
130         $RPM_BUILD_ROOT%{_applnkdir}/Network/Misc $RPM_BUILD_ROOT%{_pixmapsdir} \
131         $RPM_BUILD_ROOT%{_var}/log
132
133 %{__make} install \
134         DESTDIR=$RPM_BUILD_ROOT
135
136 install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/distccd
137 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/distcc
138 install %{SOURCE3} %{SOURCE4} $RPM_BUILD_ROOT/etc/profile.d
139 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/distccd
140 install %{SOURCE6} $RPM_BUILD_ROOT/etc/logrotate.d/distccd
141
142 %if %{with gnome}
143 mv $RPM_BUILD_ROOT%{_datadir}/%{name}/distccmon-gnome.desktop \
144         $RPM_BUILD_ROOT%{_applnkdir}/Network/Misc
145 mv $RPM_BUILD_ROOT%{_datadir}/%{name}/distccmon-gnome-icon.png \
146         $RPM_BUILD_ROOT%{_pixmapsdir}
147 %endif
148
149 touch $RPM_BUILD_ROOT%{_var}/log/distcc
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %post inetd
155 if [ -f /var/lock/subsys/rc-inetd ]; then
156         /etc/rc.d/init.d/rc-inetd reload 1>&2
157 else
158         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server" 1>&2
159 fi
160
161 %postun inetd
162 if [ -f /var/lock/subsys/rc-inetd ]; then
163         /etc/rc.d/init.d/rc-inetd reload
164 fi
165
166 %post standalone
167 /sbin/chkconfig --add distcc
168 if [ -f /var/lock/subsys/distccd ]; then
169         /etc/rc.d/init.d/distcc restart 1>&2
170 else
171         echo "Run \"/etc/rc.d/init.d/distcc start\" to start distcc daemon."
172 fi
173
174 %preun standalone
175 if [ "$1" = "0" ]; then
176         if [ -f /var/lock/subsys/distccd ]; then
177                 /etc/rc.d/init.d/distcc stop 1>&2
178         fi
179         /sbin/chkconfig --del distcc
180 fi
181
182 %files
183 %defattr(644,root,root,755)
184 %doc AUTHORS NEWS README *.txt
185 %attr(755,root,root) %{_bindir}/%{name}
186 %{_mandir}/man?/%{name}.*
187 /etc/profile.d/*sh
188
189 %files common
190 %defattr(644,root,root,755)
191 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/distccd
192 %attr(640,root,root) %ghost %{_var}/log/distcc
193 %attr(640,root,root) /etc/logrotate.d/distccd
194 %attr(755,root,root) %{_bindir}/%{name}d
195 %{_mandir}/man?/%{name}d.*
196 %attr(640,nobody,root) %ghost %{_var}/log/distcc
197
198 %files inetd
199 %defattr(644,root,root,755)
200 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/rc-inetd/distccd
201
202 %files standalone
203 %defattr(644,root,root,755)
204 %attr(754,root,root) /etc/rc.d/init.d/distcc
205
206 %files monitor
207 %defattr(644,root,root,755)
208 %attr(755,root,root) %{_bindir}/distccmon-text
209 %{_mandir}/man1/distccmon-text.*
210 %if %{with gnome}
211 %attr(755,root,root) %{_bindir}/distccmon-gnome
212 %{_applnkdir}/Network/Misc/*.desktop
213 %{_pixmapsdir}/*
214 %endif
This page took 0.086564 seconds and 3 git commands to generate.