]> git.pld-linux.org Git - packages/distcc.git/blob - distcc.spec
- updated to 2.9
[packages/distcc.git] / distcc.spec
1 Summary:        Program to distribute compilation of C or C++
2 Summary(pl):    Program do rozdzielania kompilacji programów w C lub C++
3 Name:           distcc
4 Group:          Development/Languages
5 Version:        2.9
6 Release:        1
7 License:        GPL
8 URL:            http://distcc.samba.org/
9 Source0:        http://distcc.samba.org/ftp/distcc/%{name}-%{version}.tar.bz2
10 # Source0-md5:  fa4cbb8dbebb0d87b0d1da7d2d34bf57
11 Source1:        %{name}.inetd
12 Source2:        %{name}.init
13 Source3:        %{name}.sh
14 Source4:        %{name}.csh
15 Source5:        %{name}.config
16 Patch0:         %{name}-user.patch
17 BuildRequires:  popt-devel
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 distcc is a program to distribute compilation of C or C++ code across
22 several machines on a network. distcc should always generate the same
23 results as a local compile, is simple to install and use, and is often
24 two or more times faster than a local compile.
25
26 %description -l pl
27 distcc jest programem pozwalaj±cym na dystrybucjê kompilacji C lub C++
28 na kilka maszyn w sieci. distcc powinien zawsze generowaæ takie same
29 rezultaty jak lokalna kompilacja, jest prosty w instalacji i u¿yciu
30 oraz bardzo czêsto dwa lub wiêcej razy szybszy ni¿ lokalna kompilacja.
31
32 %package common
33 Summary:        Common files for inetd and standalone versions of distcc
34 Summary(pl):    Pliki wspólne dla wersji inetd i standalone distcc
35 Group:          Daemons
36 Requires:       gcc
37 Requires:       gcc-c++
38 Obsoletes:      %{name} < %{name}-2.1-2
39
40 %description common
41 distcc is a program to distribute compilation of C or C++ code across
42 several machines on a network. distcc should always generate the same
43 results as a local compile, is simple to install and use, and is often
44 two or more times faster than a local compile.
45
46 %description -l pl common
47 distcc jest programem pozwalaj±cym na dystrybucjê kompilacji C lub C++
48 na kilka maszyn w sieci. distcc powinien zawsze generowaæ takie same
49 rezultaty jak lokalna kompilacja, jest prosty w instalacji i u¿yciu
50 oraz bardzo czêsto dwa lub wiêcej razy szybszy ni¿ lokalna kompilacja.
51
52
53 %package inetd
54 Summary:        inetd configs for distcc
55 Summary(pl):    Pliki konfiguracyjne do u¿ycia distcc poprzez inetd
56 Group:          Daemons
57 PreReq:         %{name}-common = %{version}
58 PreReq:         rc-inetd
59 Obsoletes:      %{name} < %{name}-2.1-2
60
61 %description inetd
62 distcc configs for running from inetd.
63
64 %description inetd -l pl
65 Pliki konfiguracyjna distcc do startowania demona poprzez inetd.
66
67 %package standalone
68 Summary:        standalone daemon configs for distcc
69 Summary(pl):    Pliki konfiguracyjne do startowania distcc w trybie standalone
70 Group:          Daemons
71 PreReq:         %{name}-common = %{version}
72 PreReq:         rc-scripts
73 Requires(post,preun):   /sbin/chkconfig
74 Obsoletes:      %{name} < %{name}-2.1-2
75
76 %description standalone
77 distcc configs for running as a standalone daemon.
78
79 %description standalone -l pl
80 Pliki konfiguracyjne distcc do startowania demona w trybie
81 standalone.
82
83 %prep
84 %setup -q
85 %patch -p1
86
87 %build
88 %configure
89 %{__make}
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93 install -d $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd \
94            $RPM_BUILD_ROOT/etc/rc.d/init.d \
95            $RPM_BUILD_ROOT/etc/profile.d
96
97 %{__make} install \
98         DESTDIR=$RPM_BUILD_ROOT
99
100 install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/distccd
101 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/distcc
102 install %{SOURCE3} %{SOURCE4} $RPM_BUILD_ROOT/etc/profile.d
103 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/distccd
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %post inetd
109 if [ -f /var/lock/subsys/rc-inetd ]; then
110         /etc/rc.d/init.d/rc-inetd reload 1>&2
111 else
112         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server" 1>&2
113 fi
114
115 %postun inetd
116 if [ -f /var/lock/subsys/rc-inetd ]; then
117         /etc/rc.d/init.d/rc-inetd reload
118 fi
119
120 %post standalone
121 /sbin/chkconfig --add distcc
122 if [ -f /var/lock/subsys/distccd ]; then
123         /etc/rc.d/init.d/distcc restart 1>&2
124 else
125         echo "Run \"/etc/rc.d/init.d/distcc start\" to start distcc daemon."
126 fi
127
128 %preun standalone
129 if [ "$1" = "0" ]; then
130         if [ -f /var/lock/subsys/distccd ]; then
131                 /etc/rc.d/init.d/distcc stop 1>&2
132         fi
133         /sbin/chkconfig --del distcc
134 fi
135
136 %files common
137 %defattr(644,root,root,755)
138 %doc AUTHORS NEWS README *.txt
139 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/distccd
140 %attr(755,root,root) %{_bindir}/*
141 %attr(644,root,root) %{_mandir}/man?/*
142 %attr(644,root,root) /etc/profile.d/*sh
143
144 %files inetd
145 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/rc-inetd/distccd
146
147 %files standalone
148 %attr(755,root,root) /etc/rc.d/init.d/distcc
This page took 0.066605 seconds and 3 git commands to generate.