]> git.pld-linux.org Git - packages/distcc.git/blob - distcc.spec
- eh typo
[packages/distcc.git] / distcc.spec
1 #
2 # Conditional build:
3 %bcond_with     gnome   # build without gnome(monitor) support
4
5 Summary:        Program to distribute compilation of C or C++
6 Summary(pl):    Program do rozdzielania kompilacji programów w C lub C++
7 Name:           distcc
8 Group:          Development/Languages
9 Version:        2.11
10 Release:        0.9
11 License:        GPL
12 Source0:        http://distcc.samba.org/ftp/distcc/%{name}-%{version}.tar.bz2
13 # Source0-md5:  f3458779c13255d88ee89ea7ccddda29
14 Source1:        %{name}.inetd
15 Source2:        %{name}.init
16 Source3:        %{name}.sh
17 Source4:        %{name}.csh
18 Source5:        %{name}.config
19 Patch0:         %{name}-user.patch
20 URL:            http://distcc.samba.org/
21 %{?with_gtk:BuildRequires:      libgnome-devel >= 2.0}
22 %{?with_gtk:BuildRequires:      pkg-config}
23 BuildRequires:  pkgconfig
24 BuildRequires:  popt-devel
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 distcc is a program to distribute compilation of C or C++ code across
29 several machines on a network. distcc should always generate the same
30 results as a local compile, is simple to install and use, and is often
31 two or more times faster than a local compile.
32
33 %description -l pl
34 distcc jest programem pozwalaj±cym na dystrybucjê kompilacji C lub C++
35 na kilka maszyn w sieci. distcc powinien zawsze generowaæ takie same
36 rezultaty jak lokalna kompilacja, jest prosty w instalacji i u¿yciu
37 oraz bardzo czêsto dwa lub wiêcej razy szybszy ni¿ lokalna kompilacja.
38
39 %package common
40 Summary:        Common files for inetd and standalone versions of distcc
41 Summary(pl):    Pliki wspólne dla wersji inetd i standalone distcc
42 Group:          Daemons
43 Requires:       gcc
44 Requires:       gcc-c++
45 Obsoletes:      %{name} < %{name}-2.1-2
46
47 %description common
48 distcc is a program to distribute compilation of C or C++ code across
49 several machines on a network. distcc should always generate the same
50 results as a local compile, is simple to install and use, and is often
51 two or more times faster than a local compile.
52
53 %description common -l pl
54 distcc jest programem pozwalaj±cym na dystrybucjê kompilacji C lub C++
55 na kilka maszyn w sieci. distcc powinien zawsze generowaæ takie same
56 rezultaty jak lokalna kompilacja, jest prosty w instalacji i u¿yciu
57 oraz bardzo czêsto dwa lub wiêcej razy szybszy ni¿ lokalna kompilacja.
58
59
60 %package inetd
61 Summary:        inetd configs for distcc
62 Summary(pl):    Pliki konfiguracyjne do u¿ycia distcc poprzez inetd
63 Group:          Daemons
64 PreReq:         %{name}-common = %{version}
65 PreReq:         rc-inetd
66 Obsoletes:      %{name} < %{name}-2.1-2
67
68 %description inetd
69 distcc configs for running from inetd.
70
71 %description inetd -l pl
72 Pliki konfiguracyjna distcc do startowania demona poprzez inetd.
73
74 %package standalone
75 Summary:        Standalone daemon configs for distcc
76 Summary(pl):    Pliki konfiguracyjne do startowania distcc w trybie standalone
77 Group:          Daemons
78 PreReq:         %{name}-common = %{version}
79 PreReq:         rc-scripts
80 Requires(post,preun):   /sbin/chkconfig
81 Obsoletes:      %{name} < %{name}-2.1-2
82
83 %description standalone
84 distcc configs for running as a standalone daemon.
85
86 %description standalone -l pl
87 Pliki konfiguracyjne distcc do startowania demona w trybie
88 standalone.
89
90 %package monitor
91 Summary:        Monitor for distcc
92 Summary(pl):    Monitor dla distcc
93 Group:          Applications
94
95 %description monitor
96 Monitor for distcc.
97
98 %description monitor -l pl
99 Monitor dla distcc.
100
101 %package monitor-gnome
102 Summary:        gtk monitor for distcc
103 Summary(pl):    Monitor gtk dla distcc
104 Group:          X11/Applications
105
106 %description monitor-gnome
107 gtk monitor for distcc.
108
109 %description monitor-gnome -l pl
110 Monitor gtk dla distcc.
111
112 %prep
113 %setup -q
114 %patch -p1
115
116 %build
117 %{__autoconf}
118 %{__autoheader}
119 %configure \
120         %{?with_gnome:--enable-gnome}
121
122 %{__make}
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d,profile.d} \
127         $RPM_BUILD_ROOT%{_applnkdir}/Network/Misc $RPM_BUILD_ROOT%{_pixmapsdir}
128
129 %{__make} install \
130         DESTDIR=$RPM_BUILD_ROOT
131
132 install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/distccd
133 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/distcc
134 install %{SOURCE3} %{SOURCE4} $RPM_BUILD_ROOT/etc/profile.d
135 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/distccd
136
137 %if 0%{with gnome}
138 mv $RPM_BUILD_ROOT%{_datadir}/distccmon-gnome.desktop \
139         $RPM_BUILD_ROOT%{_applnkdir}/Network/Misc
140 mv $RPM_BUILD_ROOT%{_datadir}/distccmon-gnome-icon.png \
141         $RPM_BUILD_ROOT%{_pixmapsdir}
142 %endif
143
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %post inetd
149 if [ -f /var/lock/subsys/rc-inetd ]; then
150         /etc/rc.d/init.d/rc-inetd reload 1>&2
151 else
152         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server" 1>&2
153 fi
154
155 %postun inetd
156 if [ -f /var/lock/subsys/rc-inetd ]; then
157         /etc/rc.d/init.d/rc-inetd reload
158 fi
159
160 %post standalone
161 /sbin/chkconfig --add distcc
162 if [ -f /var/lock/subsys/distccd ]; then
163         /etc/rc.d/init.d/distcc restart 1>&2
164 else
165         echo "Run \"/etc/rc.d/init.d/distcc start\" to start distcc daemon."
166 fi
167
168 %preun standalone
169 if [ "$1" = "0" ]; then
170         if [ -f /var/lock/subsys/distccd ]; then
171                 /etc/rc.d/init.d/distcc stop 1>&2
172         fi
173         /sbin/chkconfig --del distcc
174 fi
175
176 %files
177 %defattr(644,root,root,755)
178 %doc AUTHORS NEWS README *.txt
179 %attr(755,root,root) %{_bindir}/%{name}
180 %attr(644,root,root) %{_mandir}/man?/%{name}.*
181 %attr(644,root,root) /etc/profile.d/*sh
182
183 %files common
184 %defattr(644,root,root,755)
185 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/distccd
186 %attr(755,root,root) %{_bindir}/%{name}d
187 %attr(644,root,root) %{_mandir}/man?/%{name}d.*
188
189 %files inetd
190 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/rc-inetd/distccd
191
192 %files standalone
193 %attr(754,root,root) /etc/rc.d/init.d/distcc
194
195 %files monitor
196 %defattr(644,root,root,755)
197 %attr(755,root,root) %{_bindir}/distccmon-text
198
199 %if 0%{with gnome}
200 %attr(755,root,root) %{_bindir}/distccmon-gnome
201 %{_applnkdir}/Network/Misc/*.desktop
202 $RPM_BUILD_ROOT%{_pixmapsdir}/*
203 %endif
This page took 0.064815 seconds and 3 git commands to generate.