]> git.pld-linux.org Git - packages/distcc.git/blob - distcc.spec
- fixed new bconds, cleanups/unifications, BR: autoconf
[packages/distcc.git] / distcc.spec
1 #
2 # Conditional build:
3 %bcond_with     gnome   # build without gnome(monitor) support
4 #
5 Summary:        Program to distribute compilation of C or C++
6 Summary(pl):    Program do rozdzielania kompilacji programów w C lub C++
7 Name:           distcc
8 Group:          Development/Languages
9 Version:        2.11
10 Release:        2
11 License:        GPL
12 Source0:        http://distcc.samba.org/ftp/distcc/%{name}-%{version}.tar.bz2
13 # Source0-md5:  f3458779c13255d88ee89ea7ccddda29
14 Source1:        %{name}.inetd
15 Source2:        %{name}.init
16 Source3:        %{name}.sh
17 Source4:        %{name}.csh
18 Source5:        %{name}.config
19 Source6:        %{name}.logrotate
20 Patch0:         %{name}-user.patch
21 URL:            http://distcc.samba.org/
22 BuildRequires:  autoconf
23 %{?with_gtk:BuildRequires:      libgnome-devel >= 2.0}
24 BuildRequires:  pkgconfig
25 BuildRequires:  popt-devel
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 distcc is a program to distribute compilation of C or C++ code across
30 several machines on a network. distcc should always generate the same
31 results as a local compile, is simple to install and use, and is often
32 two or more times faster than a local compile.
33
34 %description -l pl
35 distcc jest programem pozwalaj±cym na dystrybucjê kompilacji C lub C++
36 na kilka maszyn w sieci. distcc powinien zawsze generowaæ takie same
37 rezultaty jak lokalna kompilacja, jest prosty w instalacji i u¿yciu
38 oraz bardzo czêsto dwa lub wiêcej razy szybszy ni¿ lokalna kompilacja.
39
40 %package common
41 Summary:        Common files for inetd and standalone versions of distcc
42 Summary(pl):    Pliki wspólne dla wersji inetd i standalone distcc
43 Group:          Daemons
44 Requires:       gcc
45 Requires:       gcc-c++
46 Obsoletes:      %{name} < %{name}-2.1-2
47
48 %description common
49 distcc is a program to distribute compilation of C or C++ code across
50 several machines on a network. distcc should always generate the same
51 results as a local compile, is simple to install and use, and is often
52 two or more times faster than a local compile.
53
54 %description common -l pl
55 distcc jest programem pozwalaj±cym na dystrybucjê kompilacji C lub C++
56 na kilka maszyn w sieci. distcc powinien zawsze generowaæ takie same
57 rezultaty jak lokalna kompilacja, jest prosty w instalacji i u¿yciu
58 oraz bardzo czêsto dwa lub wiêcej razy szybszy ni¿ lokalna kompilacja.
59
60 %package inetd
61 Summary:        inetd configs for distcc
62 Summary(pl):    Pliki konfiguracyjne do u¿ycia distcc poprzez inetd
63 Group:          Daemons
64 PreReq:         %{name}-common = %{version}
65 PreReq:         rc-inetd
66 Obsoletes:      %{name} < %{name}-2.1-2
67
68 %description inetd
69 distcc configs for running from inetd.
70
71 %description inetd -l pl
72 Pliki konfiguracyjna distcc do startowania demona poprzez inetd.
73
74 %package standalone
75 Summary:        Standalone daemon configs for distcc
76 Summary(pl):    Pliki konfiguracyjne do startowania distcc w trybie standalone
77 Group:          Daemons
78 PreReq:         %{name}-common = %{version}
79 PreReq:         rc-scripts
80 Requires(post,preun):   /sbin/chkconfig
81 Obsoletes:      %{name} < %{name}-2.1-2
82
83 %description standalone
84 distcc configs for running as a standalone daemon.
85
86 %description standalone -l pl
87 Pliki konfiguracyjne distcc do startowania demona w trybie
88 standalone.
89
90 %package monitor
91 Summary:        Monitor for distcc
92 Summary(pl):    Monitor dla distcc
93 Group:          Applications
94
95 %description monitor
96 Monitor for distcc.
97
98 %description monitor -l pl
99 Monitor dla distcc.
100
101 %package monitor-gnome
102 Summary:        gtk monitor for distcc
103 Summary(pl):    Monitor gtk dla distcc
104 Group:          X11/Applications
105
106 %description monitor-gnome
107 gtk monitor for distcc.
108
109 %description monitor-gnome -l pl
110 Monitor gtk dla distcc.
111
112 %prep
113 %setup -q
114 %patch -p1
115
116 %build
117 %{__autoconf}
118 %{__autoheader}
119 %configure \
120         %{?with_gnome:--with-gnome}
121
122 %{__make}
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d,profile.d,logrotate.d} \
127         $RPM_BUILD_ROOT%{_applnkdir}/Network/Misc $RPM_BUILD_ROOT%{_pixmapsdir} \
128         $RPM_BUILD_ROOT%{_var}/log
129
130 %{__make} install \
131         DESTDIR=$RPM_BUILD_ROOT
132
133 install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/distccd
134 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/distcc
135 install %{SOURCE3} %{SOURCE4} $RPM_BUILD_ROOT/etc/profile.d
136 install %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/distccd
137 install %{SOURCE6} $RPM_BUILD_ROOT/etc/logrotate.d/distccd
138
139 %if %{with gnome}
140 mv $RPM_BUILD_ROOT%{_datadir}/distccmon-gnome.desktop \
141         $RPM_BUILD_ROOT%{_applnkdir}/Network/Misc
142 mv $RPM_BUILD_ROOT%{_datadir}/distccmon-gnome-icon.png \
143         $RPM_BUILD_ROOT%{_pixmapsdir}
144 %endif
145
146 touch $RPM_BUILD_ROOT%{_var}/log/distcc
147
148 %clean
149 rm -rf $RPM_BUILD_ROOT
150
151 %post inetd
152 if [ -f /var/lock/subsys/rc-inetd ]; then
153         /etc/rc.d/init.d/rc-inetd reload 1>&2
154 else
155         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet server" 1>&2
156 fi
157
158 %postun inetd
159 if [ -f /var/lock/subsys/rc-inetd ]; then
160         /etc/rc.d/init.d/rc-inetd reload
161 fi
162
163 %post standalone
164 /sbin/chkconfig --add distcc
165 if [ -f /var/lock/subsys/distccd ]; then
166         /etc/rc.d/init.d/distcc restart 1>&2
167 else
168         echo "Run \"/etc/rc.d/init.d/distcc start\" to start distcc daemon."
169 fi
170
171 %preun standalone
172 if [ "$1" = "0" ]; then
173         if [ -f /var/lock/subsys/distccd ]; then
174                 /etc/rc.d/init.d/distcc stop 1>&2
175         fi
176         /sbin/chkconfig --del distcc
177 fi
178
179 %files
180 %defattr(644,root,root,755)
181 %doc AUTHORS NEWS README *.txt
182 %attr(755,root,root) %{_bindir}/%{name}
183 %{_mandir}/man?/%{name}.*
184 /etc/profile.d/*sh
185
186 %files common
187 %defattr(644,root,root,755)
188 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/distccd
189 %attr(640,root,root) %ghost %{_var}/log/distcc
190 %attr(640,root,root) /etc/logrotate.d/distccd
191 %attr(755,root,root) %{_bindir}/%{name}d
192 %{_mandir}/man?/%{name}d.*
193
194 %files inetd
195 %defattr(644,root,root,755)
196 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/rc-inetd/distccd
197
198 %files standalone
199 %defattr(644,root,root,755)
200 %attr(754,root,root) /etc/rc.d/init.d/distcc
201
202 %files monitor
203 %defattr(644,root,root,755)
204 %attr(755,root,root) %{_bindir}/distccmon-text
205 %if %{with gnome}
206 %attr(755,root,root) %{_bindir}/distccmon-gnome
207 %{_applnkdir}/Network/Misc/*.desktop
208 %{_pixmapsdir}/*
209 %endif
This page took 0.050813 seconds and 3 git commands to generate.