]> git.pld-linux.org Git - packages/discount.git/blame - discount.spec
- updated to 2.1.8a
[packages/discount.git] / discount.spec
CommitLineData
eba5ab10 1Summary: A command-line utility for converting Markdown files into HTML
46a2955d 2Summary(pl.UTF-8): Działające z linii poleceń narzędzie do konwersji plików Markdown do HTML-a
eba5ab10 3Name: discount
46a2955d 4Version: 2.1.8a
eba5ab10
ER
5Release: 1
6License: BSD
46a2955d
JB
7Group: Applications/Text
8Source0: http://www.pell.portland.or.us/~orc/Code/discount/%{name}-%{version}.tar.bz2
9# Source0-md5: edada8cc01accc2c0a634871991b4e08
eba5ab10 10Patch0: %{name}-ldconfig.patch
46a2955d 11URL: http://www.pell.portland.or.us/~orc/Code/discount
eba5ab10
ER
12Requires: libmarkdown = %{version}-%{release}
13BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15%description
16DISCOUNT is an implementation of John Gruber's Markdown language in C.
17It includes all of the original Markdown features, along with a few
18extensions, and passes the Markdown test suite.
19
46a2955d
JB
20%description -l pl.UTF-8
21DISCOUNT to implementacja języka Markdown Johna Grubera w C. Obejmuje
22wszystkie oryginalne cechy języka Markdown wraz z kilkoma
23rozszerzeniami, przechodzi zestaw testów Markdown.
24
eba5ab10
ER
25%package -n libmarkdown
26Summary: A fast implementation of the Markdown language in C
46a2955d 27Summary(pl.UTF-8): Szybka implementacja języka Markdown w C
eba5ab10
ER
28Group: Libraries
29
30%description -n libmarkdown
31libmarkdown is the library portion of discount, a fast Markdown
32language implementation, written in C.
33
46a2955d
JB
34%description -n libmarkdown -l pl.UTF-8
35libmarkdown to biblioteka z projektu discount, będąca szybką
36implementacją języka Markdown, napisaną w C.
37
eba5ab10
ER
38%package -n libmarkdown-devel
39Summary: Development headers for the libmarkdown library
46a2955d 40Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libmarkdown
eba5ab10
ER
41Group: Development/Libraries
42Requires: libmarkdown = %{version}-%{release}
43
44%description -n libmarkdown-devel
45This package contains development headers and developer-oriented man
46pages for libmarkdown.
47
46a2955d
JB
48%description -n libmarkdown-devel -l pl.UTF-8
49Ten pakiet zawiera pliki nagłówkowe oraz dokumentację programisty do
50biblioteki libmarkdown.
51
eba5ab10
ER
52%prep
53%setup -q
54%patch0
55
56%build
57# NOTE: not autoconf based configure
58CC="%{__cc}" \
59CFLAGS="%{rpmcflags}" \
60LDFLAGS="%{rpmldflags}" \
61./configure.sh \
62 --shared \
63 --prefix=%{_prefix} \
64 --execdir=%{_bindir} \
65 --libdir=%{_libdir} \
66 --mandir=%{_mandir} \
67 --enable-all-features \
68 --with-fenced-code
69
70%{__make}
71
72%if %{with tests}
73%{__make} test
74%endif
75
76%install
77rm -rf $RPM_BUILD_ROOT
78%{__make} install.everything \
79 DESTDIR=$RPM_BUILD_ROOT
80
81# Rename sample programs (names are too generic) and matching man1 pages
46a2955d
JB
82%{__mv} $RPM_BUILD_ROOT%{_bindir}/makepage $RPM_BUILD_ROOT%{_bindir}/discount-makepage
83%{__mv} $RPM_BUILD_ROOT%{_bindir}/mkd2html $RPM_BUILD_ROOT%{_bindir}/discount-mkd2html
84%{__mv} $RPM_BUILD_ROOT%{_bindir}/theme $RPM_BUILD_ROOT%{_bindir}/discount-theme
85%{__mv} $RPM_BUILD_ROOT%{_mandir}/man1/makepage.1 \
86 $RPM_BUILD_ROOT%{_mandir}/man1/discount-makepage.1
87%{__mv} $RPM_BUILD_ROOT%{_mandir}/man1/mkd2html.1 \
88 $RPM_BUILD_ROOT%{_mandir}/man1/discount-mkd2html.1
89%{__mv} $RPM_BUILD_ROOT%{_mandir}/man1/theme.1 \
90 $RPM_BUILD_ROOT%{_mandir}/man1/discount-theme.1
eba5ab10
ER
91
92%clean
93rm -rf $RPM_BUILD_ROOT
94
95%post -n libmarkdown -p /sbin/ldconfig
96%postun -n libmarkdown -p /sbin/ldconfig
97
98%files
99%defattr(644,root,root,755)
100%attr(755,root,root) %{_bindir}/markdown
101%attr(755,root,root) %{_bindir}/discount-makepage
102%attr(755,root,root) %{_bindir}/discount-mkd2html
103%attr(755,root,root) %{_bindir}/discount-theme
104%{_mandir}/man1/markdown.1*
105%{_mandir}/man7/markdown.7*
106%{_mandir}/man1/discount-*.1*
107%{_mandir}/man7/mkd-*.7*
108
109%files -n libmarkdown
110%defattr(644,root,root,755)
111%doc README COPYRIGHT CREDITS
112%attr(755,root,root) %{_libdir}/libmarkdown.so.*.*.*
46a2955d 113%attr(755,root,root) %ghost %{_libdir}/libmarkdown.so.2
eba5ab10
ER
114
115%files -n libmarkdown-devel
116%defattr(644,root,root,755)
46a2955d 117%attr(755,root,root) %{_libdir}/libmarkdown.so
eba5ab10
ER
118%{_includedir}/mkdio.h
119%{_mandir}/man3/markdown.3*
120%{_mandir}/man3/mkd_*.3*
121%{_mandir}/man3/mkd-*.3*
This page took 0.064546 seconds and 4 git commands to generate.