]> git.pld-linux.org Git - packages/diod.git/blame - diod.spec
new, version 1.0.14
[packages/diod.git] / diod.spec
CommitLineData
0289b90d
ER
1# TODO
2# - pldize initscript
3# - finish deps
4#
5# Conditional build:
6%bcond_with munge # For MUNGE authentication support.
7
8Summary: I/O forwarding server for 9P
9Name: diod
10Version: 1.0.14
11Release: 0.2
12License: GPL v2
13Group: Applications/System
14Source0: https://github.com/chaos/diod/archive/master.tar.gz?/%{name}-%{version}.tgz
15# Source0-md5: 1cbe87a0d9b1280f49695789c44a2d22
16URL: http://code.google.com/p/diod/
17#BuildRequires: gperftools-devel
18BuildRequires: libcap-devel
19BuildRequires: libibverbs-devel
20BuildRequires: librdmacm-devel
21BuildRequires: libwrap-devel
22BuildRequires: lua-devel
23%{?with_munge:BuildRequires: munge-devel}
24BuildRequires: ncurses-devel
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27%description
28diod is a 9P server used in combination with the kernel v9fs file
29system for I/O forwarding on Linux clusters.
30
31%prep
32%setup -qc
33mv %{name}-*/* .
34
35%build
36CPPFLAGS="-I/usr/include/ncurses"
37%configure \
38 --with-tcmalloc
39%{__make}
40
41%if %{with tests}
42%{__make} check \
43 CFLAGS="-Werror %{rpmcflags}"
44%endif
45
46%install
47rm -rf $RPM_BUILD_ROOT
48install -d $RPM_BUILD_ROOT
49%{__make} install \
50 DESTDIR=$RPM_BUILD_ROOT
51
52install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
53mv $RPM_BUILD_ROOT/etc/init.d/* $RPM_BUILD_ROOT/etc/rc.d/init.d
54
55# Kludge to install diodmount as a mount helper.
56install -d $RPM_BUILD_ROOT/sbin
57mv $RPM_BUILD_ROOT%{_sbindir}/diodmount \
58 $RPM_BUILD_ROOT/sbin/mount.diod
59mv $RPM_BUILD_ROOT%{_mandir}/man8/diodmount.8 \
60 $RPM_BUILD_ROOT%{_mandir}/man8/mount.diod.8
61
62%clean
63rm -rf ${RPM_BUILD_ROOT}
64
65%if 0
66%post
67/sbin/chkconfig --add diod
68
69%preun
70if [ "$1" = 0 ]; then
71 /sbin/chkconfig --del diod
72 %service diod stop
73fi
74%endif
75
76%files
77%defattr(644,root,root,755)
78%doc AUTHORS ChangeLog DISCLAIMER.LLNS META NEWS README
79%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/auto.diod
80%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/diod.conf
81%attr(754,root,root) /etc/rc.d/init.d/diod
82%attr(755,root,root) /sbin/mount.diod
83%attr(755,root,root) %{_sbindir}/diod
84%attr(755,root,root) %{_sbindir}/diodcat
85%attr(755,root,root) %{_sbindir}/diodload
86%attr(755,root,root) %{_sbindir}/diodls
87%attr(755,root,root) %{_sbindir}/diodshowmount
88%attr(755,root,root) %{_sbindir}/dtop
89%{_mandir}/man5/diod.conf.5*
90%{_mandir}/man8/diod.8*
91%{_mandir}/man8/diodcat.8*
92%{_mandir}/man8/diodload.8*
93%{_mandir}/man8/diodls.8*
94%{_mandir}/man8/diodshowmount.8*
95%{_mandir}/man8/dtop.8*
96%{_mandir}/man8/mount.diod.8*
This page took 0.065082 seconds and 4 git commands to generate.