]> git.pld-linux.org Git - packages/diod.git/blob - diod.spec
new, version 1.0.14
[packages/diod.git] / diod.spec
1 # TODO
2 # - pldize initscript
3 # - finish deps
4 #
5 # Conditional build:
6 %bcond_with     munge           # For MUNGE authentication support.
7
8 Summary:        I/O forwarding server for 9P
9 Name:           diod
10 Version:        1.0.14
11 Release:        0.2
12 License:        GPL v2
13 Group:          Applications/System
14 Source0:        https://github.com/chaos/diod/archive/master.tar.gz?/%{name}-%{version}.tgz
15 # Source0-md5:  1cbe87a0d9b1280f49695789c44a2d22
16 URL:            http://code.google.com/p/diod/
17 #BuildRequires: gperftools-devel
18 BuildRequires:  libcap-devel
19 BuildRequires:  libibverbs-devel
20 BuildRequires:  librdmacm-devel
21 BuildRequires:  libwrap-devel
22 BuildRequires:  lua-devel
23 %{?with_munge:BuildRequires:    munge-devel}
24 BuildRequires:  ncurses-devel
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 diod is a 9P server used in combination with the kernel v9fs file
29 system for I/O forwarding on Linux clusters.
30
31 %prep
32 %setup -qc
33 mv %{name}-*/* .
34
35 %build
36 CPPFLAGS="-I/usr/include/ncurses"
37 %configure \
38         --with-tcmalloc
39 %{__make}
40
41 %if %{with tests}
42 %{__make} check \
43         CFLAGS="-Werror %{rpmcflags}"
44 %endif
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
53 mv $RPM_BUILD_ROOT/etc/init.d/* $RPM_BUILD_ROOT/etc/rc.d/init.d
54
55 # Kludge to install diodmount as a mount helper.
56 install -d $RPM_BUILD_ROOT/sbin
57 mv $RPM_BUILD_ROOT%{_sbindir}/diodmount \
58    $RPM_BUILD_ROOT/sbin/mount.diod
59 mv $RPM_BUILD_ROOT%{_mandir}/man8/diodmount.8 \
60    $RPM_BUILD_ROOT%{_mandir}/man8/mount.diod.8
61
62 %clean
63 rm -rf ${RPM_BUILD_ROOT}
64
65 %if 0
66 %post
67 /sbin/chkconfig --add diod
68
69 %preun
70 if [ "$1" = 0 ]; then
71         /sbin/chkconfig --del diod
72         %service diod stop
73 fi
74 %endif
75
76 %files
77 %defattr(644,root,root,755)
78 %doc AUTHORS ChangeLog DISCLAIMER.LLNS META NEWS README
79 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/auto.diod
80 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/diod.conf
81 %attr(754,root,root) /etc/rc.d/init.d/diod
82 %attr(755,root,root) /sbin/mount.diod
83 %attr(755,root,root) %{_sbindir}/diod
84 %attr(755,root,root) %{_sbindir}/diodcat
85 %attr(755,root,root) %{_sbindir}/diodload
86 %attr(755,root,root) %{_sbindir}/diodls
87 %attr(755,root,root) %{_sbindir}/diodshowmount
88 %attr(755,root,root) %{_sbindir}/dtop
89 %{_mandir}/man5/diod.conf.5*
90 %{_mandir}/man8/diod.8*
91 %{_mandir}/man8/diodcat.8*
92 %{_mandir}/man8/diodload.8*
93 %{_mandir}/man8/diodls.8*
94 %{_mandir}/man8/diodshowmount.8*
95 %{_mandir}/man8/dtop.8*
96 %{_mandir}/man8/mount.diod.8*
This page took 0.052958 seconds and 3 git commands to generate.