]> git.pld-linux.org Git - packages/ding-libs.git/blame - ding-libs.spec
- dots
[packages/ding-libs.git] / ding-libs.spec
CommitLineData
e540dfd7
ER
1#
2# Conditional build:
3%bcond_without tests # build without tests
4
5%define collection_version 0.6.1
6%define dhash_version 0.4.3
7%define ini_config_version 0.6.2
8%define path_utils_version 0.2.1
9%define ref_array_version 0.1.2
301bff7b 10Summary: "Ding is not GLib" assorted utility libraries
11Name: ding-libs
12Version: 0.1.3
e540dfd7
ER
13# NOTE: do not decrease Release on Version change, unless ALL subpackage versions have been increased too
14Release: 1
15License: LGPL v3+
301bff7b 16Group: Development/Libraries
17URL: http://fedorahosted.org/sssd/
18Source0: http://fedorahosted.org/releases/d/i/ding-libs/%{name}-%{version}.tar.gz
19# Source0-md5: b4f5e03b0b1bd0ab765902a7a466f749
301bff7b 20BuildRequires: autoconf
21BuildRequires: automake
22BuildRequires: check-devel
23BuildRequires: doxygen
24BuildRequires: libtool
25BuildRequires: m4
e540dfd7 26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
301bff7b 27
28%description
29A set of helpful libraries used by projects such as SSSD.
30
e540dfd7
ER
31%package -n libcollection
32Summary: Collection data-type for C
33Version: %{collection_version}
34License: LGPL v3+
301bff7b 35Group: Development/Libraries
36
e540dfd7
ER
37%description -n libcollection
38A data-type to collect data in a hierarchical structure for easy
bd36927a 39iteration and serialization.
301bff7b 40
e540dfd7
ER
41%package -n libcollection-devel
42Summary: Development files for libcollection
43Version: %{collection_version}
44License: LGPL v3+
301bff7b 45Group: Development/Libraries
e540dfd7 46Requires: libcollection = %{collection_version}-%{release}
301bff7b 47
e540dfd7
ER
48%description -n libcollection-devel
49A data-type to collect data in a hierarchical structure for easy
bd36927a 50iteration and serialization.
301bff7b 51
52%package -n libdhash
53Summary: Dynamic hash table
54Version: %{dhash_version}
e540dfd7 55License: LGPL v3+
301bff7b 56Group: Development/Libraries
57
58%description -n libdhash
59A hash table which will dynamically resize to achieve optimal storage
bd36927a 60& access time properties.
301bff7b 61
62%package -n libdhash-devel
63Summary: Development files for libdhash
64Version: %{dhash_version}
e540dfd7 65License: LGPL v3+
301bff7b 66Group: Development/Libraries
67Requires: libdhash = %{dhash_version}-%{release}
68
69%description -n libdhash-devel
70A hash table which will dynamically resize to achieve optimal storage
bd36927a 71& access time properties.
301bff7b 72
e540dfd7
ER
73%package -n libini_config
74Summary: INI file parser for C
75Version: %{ini_config_version}
76License: LGPL v3+
301bff7b 77Group: Development/Libraries
78
e540dfd7
ER
79%description -n libini_config
80Library to process config files in INI format into a libcollection
bd36927a 81data structure.
301bff7b 82
e540dfd7
ER
83%package -n libini_config-devel
84Summary: Development files for libini_config
85Version: %{ini_config_version}
86License: LGPL v3+
301bff7b 87Group: Development/Libraries
e540dfd7 88Requires: libini_config = %{ini_config_version}-%{release}
301bff7b 89
e540dfd7
ER
90%description -n libini_config-devel
91Library to process config files in INI format into a libcollection
bd36927a 92data structure.
301bff7b 93
e540dfd7
ER
94%package -n libpath_utils
95Summary: Filesystem Path Utilities
96Version: %{path_utils_version}
97License: LGPL v3+
98Group: Development/Libraries
301bff7b 99
e540dfd7 100%description -n libpath_utils
bd36927a 101Utility functions to manipulate filesystem pathnames.
301bff7b 102
e540dfd7
ER
103%package -n libpath_utils-devel
104Summary: Development files for libpath_utils
105Version: %{path_utils_version}
106License: LGPL v3+
107Group: Development/Libraries
108Requires: libpath_utils = %{path_utils_version}-%{release}
301bff7b 109
e540dfd7 110%description -n libpath_utils-devel
bd36927a 111Utility functions to manipulate filesystem pathnames.
301bff7b 112
113%package -n libref_array
114Summary: A refcounted array for C
115Version: %{ref_array_version}
e540dfd7 116License: LGPL v3+
301bff7b 117Group: Development/Libraries
118
119%description -n libref_array
bd36927a 120A dynamically-growing, reference-counted array.
301bff7b 121
122%package -n libref_array-devel
123Summary: Development files for libref_array
124Version: %{ref_array_version}
e540dfd7 125License: LGPL v3+
301bff7b 126Group: Development/Libraries
127Requires: libref_array = %{ref_array_version}-%{release}
128
129%description -n libref_array-devel
bd36927a 130A dynamically-growing, reference-counted array.
301bff7b 131
301bff7b 132%prep
133%setup -q
134
135%build
136%configure \
137 --disable-static
138
e540dfd7 139%{__make} all docs
301bff7b 140
e540dfd7
ER
141%if %{with tests}
142%{__make} check
143%endif
301bff7b 144
145%install
146rm -rf $RPM_BUILD_ROOT
e540dfd7
ER
147%{__make} install \
148 DESTDIR=$RPM_BUILD_ROOT
301bff7b 149
150# Remove .la files created by libtool
e540dfd7 151%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
301bff7b 152
153# Remove the example files from the output directory
154# We will copy them directly from the source directory
155# for packaging
e540dfd7 156%{__rm} \
301bff7b 157 $RPM_BUILD_ROOT%{_docdir}/ding-libs/README.* \
158 $RPM_BUILD_ROOT%{_docdir}/ding-libs/examples/dhash_example.c \
159 $RPM_BUILD_ROOT%{_docdir}/ding-libs/examples/dhash_test.c
160
161# Remove document install script. RPM is handling this
e540dfd7 162%{__rm} -f */doc/html/installdox
301bff7b 163
164%clean
165rm -rf $RPM_BUILD_ROOT
e540dfd7
ER
166
167%post -n libcollection -p /sbin/ldconfig
168%postun -n libcollection -p /sbin/ldconfig
169
170%post -n libdhash -p /sbin/ldconfig
171%postun -n libdhash -p /sbin/ldconfig
172
173%post -n libini_config -p /sbin/ldconfig
174%postun -n libini_config -p /sbin/ldconfig
175
176%post -n libpath_utils -p /sbin/ldconfig
177%postun -n libpath_utils -p /sbin/ldconfig
178
179%post -n libref_array -p /sbin/ldconfig
180%postun -n libref_array -p /sbin/ldconfig
181
182%files -n libcollection
183%defattr(644,root,root,755)
184%attr(755,root,root) %{_libdir}/libcollection.so.*.*.*
185%ghost %{_libdir}/libcollection.so.2
186
187%files -n libcollection-devel
188%defattr(644,root,root,755)
189%doc collection/doc/html
190%{_includedir}/collection.h
191%{_includedir}/collection_tools.h
192%{_includedir}/collection_queue.h
193%{_includedir}/collection_stack.h
194%{_libdir}/libcollection.so
195%{_pkgconfigdir}/collection.pc
196
197%files -n libdhash
198%defattr(644,root,root,755)
199%attr(755,root,root) %{_libdir}/libdhash.so.*.*.*
200%{_libdir}/libdhash.so.1
201
202%files -n libdhash-devel
203%defattr(644,root,root,755)
204%doc dhash/README.dhash
205%doc dhash/examples
206%{_includedir}/dhash.h
207%{_libdir}/libdhash.so
208%{_pkgconfigdir}/dhash.pc
209
210%files -n libini_config
211%defattr(644,root,root,755)
212%attr(755,root,root) %{_libdir}/libini_config.so.*.*.*
213%ghost %{_libdir}/libini_config.so.2
214
215%files -n libini_config-devel
216%defattr(644,root,root,755)
217%doc ini/doc/html/
218%{_includedir}/ini_config.h
219%{_libdir}/libini_config.so
220%{_pkgconfigdir}/ini_config.pc
221
222%files -n libpath_utils
223%defattr(644,root,root,755)
224%attr(755,root,root) %{_libdir}/libpath_utils.so.*.*.*
225%ghost %{_libdir}/libpath_utils.so.1
226
227%files -n libpath_utils-devel
228%defattr(644,root,root,755)
229%doc path_utils/README.path_utils
230%doc path_utils/doc/html
231%{_includedir}/path_utils.h
232%{_libdir}/libpath_utils.so
233%{_pkgconfigdir}/path_utils.pc
234
235%files -n libref_array
236%defattr(644,root,root,755)
237%attr(755,root,root) %{_libdir}/libref_array.so.*.*.*
238%ghost %{_libdir}/libref_array.so.1
239
240%files -n libref_array-devel
241%defattr(644,root,root,755)
242%doc refarray/README.ref_array
243%doc refarray/doc/html
244%{_includedir}/ref_array.h
245%{_libdir}/libref_array.so
246%{_pkgconfigdir}/ref_array.pc
This page took 0.114049 seconds and 4 git commands to generate.