]> git.pld-linux.org Git - packages/dime.git/blob - dime.spec
- added c++,doc patches to build with recent g++ and latex
[packages/dime.git] / dime.spec
1 Summary:        DIME - DXF Import, manipulation and Export library
2 Summary(pl.UTF-8):      DIME - biblioteka do manipulacji plikami w formacie DXF
3 Name:           dime
4 Version:        0.9.1
5 Release:        4
6 License:        GPL v2
7 Group:          Libraries
8 # original source (no lonver available): ftp://ftp.sim.no/pub/dime/
9 # new snapshot: ftp://ftp.sim.no/pub/snapshots/dime-latest.tar.gz
10 Source0:        %{name}-%{version}-src.tar.bz2
11 # Source0-md5:  142af240cd35508d606917a38164c759
12 Source1:        %{name}-%{version}-doc.tar.bz2
13 # Source1-md5:  994706320ce7d222a1597913ba0cbee0
14 Patch0:         %{name}-c++.patch
15 Patch1:         %{name}-shared.patch
16 Patch2:         %{name}-doc.patch
17 URL:            http://www.coin3d.org/lib/dime
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  libtool
20 BuildRequires:  tetex-dvips
21 BuildRequires:  tetex-fonts-ams
22 BuildRequires:  tetex-format-latex
23 BuildRequires:  tetex-makeindex
24 BuildRequires:  tetex-metafont
25 BuildRequires:  tetex-tex-misc
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Dime is a C++ class library for reading, constructing, manipulating,
30 and writing DXF file data. The name is an acronym for DXF Import,
31 Manipulation, and Export library. The DXF file format originates from
32 AutoCAD, but is now in widespread use.
33
34 The focus of the library is primarily on the following items:
35
36 - loading DXF files into a dime object hierarchy containing the DXF
37   data
38 - building dime object hierarchies from scratch
39 - extracting geometry data from dime object hierarchies
40 - manipulating dime object hierarchies
41 - traversing the dime object hierarchies while performing various
42   tasks
43 - saving dime object hierarchies as files conforming to the DXF file
44   format
45
46 The intended purpose of dime was on importing and exporting DXF files.
47 For this kind of usage, special memory management techniques has been
48 implemented, that can be used to boost the performance significantly.
49
50 %description -l pl.UTF-8
51 Dime jest biblioteką klas C++ służącą odczytywaniu, tworzeniu,
52 modyfikacji i zachowywaniu danych w plikach DXF. Nazwa jest skrótem od
53 pierwszych liter: słów DXF Import, Manipulation, and Export library.
54 Format pliku DXF pochodzi z AutoCAD-a, obecnie jest jednak bardzo
55 popularny.
56
57 Bibliotek obsługuje głównie następujące funkcje:
58 - ładowanie plików DXF do hierarchii obiektu dime zawierającej dane
59   DXF
60 - budowanie hierarchii obiektów dime od zera
61 - ekstrakcja danych geometrycznych z hierarchii obiektów dime
62 - manipulacja hierarchią obiektów dime
63 - przegląd hierarchii obiektów dime podczas wykonywania różnych zadań
64 - zachowywanie obiektów hierarchii dime w postaci plików zgodnych z
65   formatem DXF
66
67 Pierwotnym celem dime było importowanie i eksportowanie plików DXF.
68 Dlatego zaimplementowano specjalne techniki zarządzania pamięcią,
69 dzięki którym można znacznie zwiększyć wydajność.
70
71 %package devel
72 Summary:        Header files for DIME
73 Summary(pl.UTF-8):      Pliki nagłówkowe DIME
74 Group:          Development/Libraries
75 Requires:       %{name} = %{version}-%{release}
76
77 %description devel
78 Header files for DIME.
79
80 %description devel -l pl.UTF-8
81 Pliki nagłówkowe DIME.
82
83 %package static
84 Summary:        Static DIME library
85 Summary(pl.UTF-8):      Statyczna biblioteka DIME
86 Group:          Development/Libraries
87 Requires:       %{name}-devel = %{version}-%{release}
88
89 %description static
90 Static DIME library.
91
92 %description static -l pl.UTF-8
93 Statyczna biblioteka DIME.
94
95 %package documentation
96 Summary:        DIME documentation
97 Summary(pl.UTF-8):      DIME - dokumentacja
98 Group:          Documentation
99
100 %description documentation
101 DIME documentation.
102
103 %description documentation -l pl.UTF-8
104 Dokumentacja do DIME.
105
106 %prep
107 %setup -q -b1
108 %patch0 -p1
109 %patch1 -p1
110 %patch2 -p1
111
112 %build
113 %{__make} -C build libdime.la \
114         CC="%{__cxx}" \
115         OPT="%{rpmcxxflags} %{rpmcppflags}" \
116         LDFLAGS="%{rpmldflags}" \
117         LIBDIR=%{_libdir}
118
119 %{__make} -C docs/latex refman.ps
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}} \
124         $RPM_BUILD_ROOT%{_docdir}/%{name}-documentation-%{version}/{latex,html}
125
126 cp -pr include/* $RPM_BUILD_ROOT%{_includedir}
127 libtool --mode=install install build/libdime.la $RPM_BUILD_ROOT%{_libdir}
128
129 cp -pr docs/latex/*.tex $RPM_BUILD_ROOT%{_docdir}/%{name}-documentation-%{version}/latex
130 cp -pr docs/latex/*.sty $RPM_BUILD_ROOT%{_docdir}/%{name}-documentation-%{version}/latex
131 cp -pr docs/html/* $RPM_BUILD_ROOT%{_docdir}/%{name}-documentation-%{version}/html
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %files
137 %defattr(644,root,root,755)
138 %doc ChangeLog README TODO
139 %attr(755,root,root) %{_libdir}/libdime.so.*.*.*
140 %attr(755,root,root) %ghost %{_libdir}/libdime.so.0
141
142 %files devel
143 %defattr(644,root,root,755)
144 %doc docs/latex/refman.ps
145 %attr(755,root,root) %{_libdir}/libdime.so
146 %{_libdir}/libdime.la
147 %{_includedir}/dime
148
149 %files static
150 %defattr(644,root,root,755)
151 %{_libdir}/libdime.a
152
153 %files documentation
154 %defattr(644,root,root,755)
155 %dir %{_docdir}/%{name}-documentation-%{version}
156 %{_docdir}/%{name}-documentation-%{version}/latex
157 %{_docdir}/%{name}-documentation-%{version}/html
This page took 0.087607 seconds and 3 git commands to generate.