]> git.pld-linux.org Git - packages/digikam.git/commitdiff
- up to 2.5.0 auto/th/digikam-2_5_0-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 21 Jan 2012 23:39:28 +0000 (23:39 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    digikam-2.5.0-libkipi-1.4.0.patch -> 1.1
    digikam.spec -> 1.150

digikam-2.5.0-libkipi-1.4.0.patch [new file with mode: 0644]
digikam.spec

diff --git a/digikam-2.5.0-libkipi-1.4.0.patch b/digikam-2.5.0-libkipi-1.4.0.patch
new file mode 100644 (file)
index 0000000..0f4e771
--- /dev/null
@@ -0,0 +1,68 @@
+commit 25cc9c9876a5233bd630105d0110319892d4e18c
+Author: Gilles Caulier <caulier.gilles@gmail.com>
+Date:   Tue Jan 3 15:16:37 2012 +0100
+
+    enable checkall and clearall buttons only with libkipi version 1.4.0
+    BUGS: 290496
+
+diff --git a/utilities/setup/setupplugins.cpp b/utilities/setup/setupplugins.cpp
+index 0f4030a..b8efb35 100644
+--- a/utilities/setup/setupplugins.cpp
++++ b/utilities/setup/setupplugins.cpp
+@@ -6,8 +6,8 @@
+  * Date        : 2004-01-02
+  * Description : setup Kipi plugins tab.
+  *
+- * Copyright (C) 2004-2011 by Gilles Caulier <caulier dot gilles at gmail dot com>
+- * Copyright (C) 2011 by Andi Clemens <andi dot clemens at googlemail dot com>
++ * Copyright (C) 2004-2012 by Gilles Caulier <caulier dot gilles at gmail dot com>
++ * Copyright (C) 2011-2012 by Andi Clemens <andi dot clemens at googlemail dot com>
+  *
+  * This program is free software; you can redistribute it
+  * and/or modify it under the terms of the GNU General
+@@ -100,6 +100,11 @@ SetupPlugins::SetupPlugins(QWidget* parent)
+     panel->setLayout(mainLayout);
++#if KIPI_VERSION < 0x010400
++    d->checkAllBtn->setVisible(false);
++    d->clearBtn->setVisible(false);
++#endif
++
+     initPlugins();
+     // --------------------------------------------------------
+@@ -158,14 +163,18 @@ void SetupPlugins::applyPlugins()
+ void SetupPlugins::slotCheckAll()
+ {
+     QApplication::setOverrideCursor(Qt::WaitCursor);
++#if KIPI_VERSION >= 0x010400
+     d->kipiConfig->slotCheckAll();
++#endif
+     QApplication::restoreOverrideCursor();
+ }
+ void SetupPlugins::slotClear()
+ {
+     QApplication::setOverrideCursor(Qt::WaitCursor);
++#if KIPI_VERSION >= 0x010400
+     d->kipiConfig->slotClear();
++#endif
+     QApplication::restoreOverrideCursor();
+ }
+ }  // namespace Digikam
+diff --git a/utilities/setup/setupplugins.h b/utilities/setup/setupplugins.h
+index 271a569..114e0fa 100644
+--- a/utilities/setup/setupplugins.h
++++ b/utilities/setup/setupplugins.h
+@@ -6,8 +6,8 @@
+  * Date        : 2004-01-02
+  * Description : setup Kipi plugins tab.
+  *
+- * Copyright (C) 2004-2011 by Gilles Caulier <caulier dot gilles at gmail dot com>
+- * Copyright (C) 2011 by Andi Clemens <andi dot clemens at googlemail dot com>
++ * Copyright (C) 2004-2012 by Gilles Caulier <caulier dot gilles at gmail dot com>
++ * Copyright (C) 2011-2012 by Andi Clemens <andi dot clemens at googlemail dot com>
+  *
+  * This program is free software; you can redistribute it
+  * and/or modify it under the terms of the GNU General
index 1a146d62397307d8e9019c2342ce8d96d4ffcd7b..4ec2ec53388f8688251781ec54e6b34ab263a1cf 100644 (file)
@@ -1,22 +1,24 @@
 #
-%define                qtver   4.7.4
-%define                kdever  4.7.4
+%define                qtver   4.8.0
+%define                kdever  4.8.0
 
 Summary:       A KDE frontend for gphoto2
 Summary(pl.UTF-8):     Interfejs KDE do gphoto2
 Name:          digikam
-Version:       2.4.1
-Release:       4
+Version:       2.5.0
+Release:       1
 License:       GPL
 Group:         X11/Applications/Graphics
 Source0:       http://downloads.sourceforge.net/digikam/%{name}-%{version}.tar.bz2
-# Source0-md5: 4e36b8cc33f5ac589e4b45b22c902fdd
+# Source0-md5: 770355060d2033a044c21b0f155be00c
+Patch0:                digikam-2.5.0-libkipi-1.4.0.patch
 URL:           http://www.digikam.org/
 BuildRequires: Qt3Support-devel >= %{qtver}
 BuildRequires: QtCore-devel >= %{qtver}
 BuildRequires: QtDesigner-devel >= %{qtver}
 BuildRequires: QtSql-devel >= %{qtver}
 BuildRequires: QtSvg-devel >= %{qtver}
+BuildRequires: QtXmlPatterns-devel >= %{qtver}
 BuildRequires: automoc4
 BuildRequires: clapack-devel
 BuildRequires: cmake >= 2.8.0
@@ -28,15 +30,15 @@ BuildRequires:      lcms-devel
 BuildRequires: lensfun-devel
 BuildRequires: libf2c-devel
 BuildRequires: libgphoto2-devel
-BuildRequires: libkdcraw-devel >= %{kdever}
-BuildRequires: libkdeedu-devel >= %{kdever}
-BuildRequires: libkexiv2-devel >= %{kdever}
-BuildRequires: libkipi-devel >= %{kdever}
-BuildRequires: libksane-devel >= %{kdever}
+BuildRequires: kde4-libkdcraw-devel >= %{kdever}
+BuildRequires: kde4-libkdeedu-devel >= %{kdever}
+BuildRequires: kde4-libkexiv2-devel >= %{kdever}
+BuildRequires: kde4-libkipi-devel >= %{kdever}
+BuildRequires: kde4-libksane-devel >= %{kdever}
 BuildRequires: liblqr-devel >= 0.4.0
 BuildRequires: libpgf-devel
 BuildRequires: libtiff-devel
-BuildRequires: marble-devel >= %{kdever}
+BuildRequires: kde4-marble-devel >= %{kdever}
 # fixed mysql_install_db in this version
 BuildRequires: mysql-extras >= 5.5.9-2
 BuildRequires: opencv-devel
@@ -74,6 +76,9 @@ Interfejs KDE do gphoto2 - pliki nagłówkowe.
 
 %prep
 %setup -q
+cd core
+%patch0 -p1
+cd ..
 
 %build
 install -d build
@@ -116,6 +121,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/dnginfo
 %attr(755,root,root) %{_bindir}/expoblending
 %attr(755,root,root) %{_bindir}/libkgeomap_demo
+%attr(755,root,root) %{_bindir}/multithread
 %attr(755,root,root) %{_bindir}/panoramagui
 %attr(755,root,root) %{_bindir}/photolayoutseditor
 %attr(755,root,root) %{_bindir}/scangui
This page took 0.185191 seconds and 4 git commands to generate.