]> git.pld-linux.org Git - packages/dietlibc.git/commitdiff
- more dynamic fixes (x86_64 builds now)
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 28 Jan 2014 20:07:24 +0000 (21:07 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Tue, 28 Jan 2014 20:07:24 +0000 (21:07 +0100)
dietlibc-dynamic.patch
dietlibc.spec

index d4a9f39650198b021bfe912dfb9bdee9c389b0e3..2bf946cd5a97aa280d8a66a9d9cb9f51f124addd 100644 (file)
  #include "../syscalls.s/open.S"
  #include "../syscalls.s/pause.S"
  #include "../syscalls.s/personality.S"
+--- dietlibc-0.33/x86_64/clock_gettime.S.orig  2012-01-26 07:19:31.000000000 +0100
++++ dietlibc-0.33/x86_64/clock_gettime.S       2014-01-28 20:34:23.670685222 +0100
+@@ -11,9 +11,16 @@
+ .L1:
+       push %rsi
+       push %rdi
++#ifdef __PIC__
++      movq __vdso@GOTPCREL(%rip), %rax
++      movq (%rax),%rdi
++      movq funcname@GOTPCREL(%rip), %rsi
++      call vdso_dlsym@PLT
++#else
+       movq __vdso(%rip),%rdi
+       movq $funcname, %rsi
+       call vdso_dlsym
++#endif
+       pop %rdi
+       pop %rsi
+       jmp .L2
+--- dietlibc-0.33/x86_64/gettimeofday.S.orig   2012-01-24 19:24:30.000000000 +0100
++++ dietlibc-0.33/x86_64/gettimeofday.S        2014-01-28 20:35:10.746157117 +0100
+@@ -11,9 +11,16 @@
+ .L1:
+       push %rsi
+       push %rdi
++#ifdef __PIC__
++      movq __vdso@GOTPCREL(%rip), %rax
++      movq (%rax),%rdi
++      movq funcname@GOTPCREL(%rip), %rsi
++      call vdso_dlsym@PLT
++#else
+       movq __vdso(%rip),%rdi
+       movq $funcname, %rsi
+       call vdso_dlsym
++#endif
+       pop %rdi
+       pop %rsi
+       jmp .L2
+--- dietlibc-0.33/arm/dyn_syscalls.S.orig      2012-01-24 19:24:24.000000000 +0100
++++ dietlibc-0.33/arm/dyn_syscalls.S   2014-01-28 20:58:27.842943864 +0100
+@@ -104,7 +104,6 @@
+ #include "../syscalls.s/n_sigprocmask.S"
+ #include "../syscalls.s/n_sigsuspend.S"
+ #include "../syscalls.s/nanosleep.S"
+-#include "../syscalls.s/nice.S"
+ #include "../syscalls.s/open.S"
+ #include "../syscalls.s/pause.S"
+ #include "../syscalls.s/personality.S"
index 9c5406fa99569588b5a212e1293b330775227518..cee5767d8fab7e858eaaadfed24084ba43949336 100644 (file)
@@ -130,6 +130,9 @@ statyczne.
 %{__sed} -i -e '/CFLAGS/ s/-Wextra//' Makefile
 %endif
 
+# there is unconditional nice.c already; __nice.c breaks x86_64 build
+%{__rm} lib/__nice.c
+
 %build
 export OPTFLAGS="%{rpmcflags}%{?with_ssp: -fno-stack-protector} -fno-strict-aliasing -Wa,--noexecstack"
 CC="%{__cc}"
This page took 0.076786 seconds and 4 git commands to generate.