]> git.pld-linux.org Git - packages/dietlibc.git/commitdiff
- updated WRT CVS from 2009-03-17
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 18 Mar 2009 13:26:20 +0000 (13:26 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    dietlibc-noexecstacks.patch -> 1.3
    dietlibc-opt.patch -> 1.7
    dietlibc-stackgap-instead-of-ssp.patch -> 1.2

dietlibc-noexecstacks.patch
dietlibc-opt.patch
dietlibc-stackgap-instead-of-ssp.patch

index e3bd099ab7f9a8d33413218405dda7c16036d9e7..7fa71eef6f36d52d760875951ece75a2a42bf93b 100644 (file)
@@ -571,9 +571,9 @@ diff -NurpP dietlibc-0.30/arm/clone.S dietlibc-0.30-execstack/arm/clone.S
 --- dietlibc-0.30/arm/clone.S  2002-02-28 17:27:02.000000000 +0100
 +++ dietlibc-0.30-execstack/arm/clone.S        2006-09-07 12:24:13.115173500 +0200
 @@ -32,3 +32,7 @@ __clone:
  1:    b       _exit                   @ branch to _exit (PIC safe)
  
+ #endif
 +
 +#ifdef __ELF__
 +.section .note.GNU-stack,"",%progbits
@@ -582,9 +582,9 @@ diff -NurpP dietlibc-0.30/arm/dyn_syscalls.S dietlibc-0.30-execstack/arm/dyn_sys
 --- dietlibc-0.30/arm/dyn_syscalls.S   2005-10-08 23:22:09.000000000 +0200
 +++ dietlibc-0.30-execstack/arm/dyn_syscalls.S 2006-09-07 12:24:13.115173500 +0200
 @@ -289,3 +289,7 @@ __exit:
  #include "__longjmp.S"
  #include "setjmp.S"
+ #include "__guard.S"
 +
 +#ifdef __ELF__
 +.section .note.GNU-stack,"",%progbits
@@ -625,10 +625,10 @@ diff -NurpP dietlibc-0.30/arm/mcount.S dietlibc-0.30-execstack/arm/mcount.S
 diff -NurpP dietlibc-0.30/arm/md5asm.S dietlibc-0.30-execstack/arm/md5asm.S
 --- dietlibc-0.30/arm/md5asm.S 2002-03-08 11:56:15.000000000 +0100
 +++ dietlibc-0.30-execstack/arm/md5asm.S       2006-09-07 12:24:13.115173500 +0200
-@@ -394,3 +394,7 @@ __UnalignedMD5Transform:\r
- #endif   /* __BYTE_ORDER == __LITTLE_ENDIAN */\r
\r
\r
+@@ -394,3 +394,7 @@ __UnalignedMD5Transform:
+ #endif   /* __BYTE_ORDER == __LITTLE_ENDIAN */
 +
 +#ifdef __ELF__
 +.section .note.GNU-stack,"",%progbits
@@ -637,9 +637,9 @@ diff -NurpP dietlibc-0.30/arm/mmap.S dietlibc-0.30-execstack/arm/mmap.S
 --- dietlibc-0.30/arm/mmap.S   2002-02-18 20:57:39.000000000 +0100
 +++ dietlibc-0.30-execstack/arm/mmap.S 2006-09-07 12:24:13.115173500 +0200
 @@ -22,3 +22,7 @@ mmap:
-       add     sp, sp, #16
        b       __unified_syscall
  
+ #endif
 +
 +#ifdef __ELF__
 +.section .note.GNU-stack,"",%progbits
@@ -672,7 +672,7 @@ diff -NurpP dietlibc-0.30/arm/start.S dietlibc-0.30-execstack/arm/start.S
 @@ -73,3 +73,7 @@ _exit:
  
  
+ #endif
 +
 +#ifdef __ELF__
 +.section .note.GNU-stack,"",%progbits
@@ -6828,3 +6828,355 @@ diff -NurpP dietlibc-0.30/x86_64/waitpid.S dietlibc-0.30-execstack/x86_64/waitpi
 +#ifdef __ELF__
 +.section .note.GNU-stack,"",%progbits
 +#endif
+diff -ur dietlibc-0.31/arm/accept.S dietlibc-0.31-x/arm/accept.S
+--- dietlibc-0.31/arm/accept.S 2009-03-17 22:54:20.000000000 +0100
++++ dietlibc-0.31-x/arm/accept.S       2009-03-17 22:54:05.000000000 +0100
+@@ -5,3 +5,7 @@
+ syscall(accept,accept)
+ #endif
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+diff -ur dietlibc-0.31/arm/__aeabi_unwind_cpp.S dietlibc-0.31-x/arm/__aeabi_unwind_cpp.S
+--- dietlibc-0.31/arm/__aeabi_unwind_cpp.S     2009-03-17 22:54:20.000000000 +0100
++++ dietlibc-0.31-x/arm/__aeabi_unwind_cpp.S   2009-03-17 22:54:01.000000000 +0100
+@@ -19,3 +19,7 @@
+ .size __aeabi_unwind_cpp_pr0,.-__aeabi_unwind_cpp_pr0
+ .size __aeabi_unwind_cpp_pr1,.-__aeabi_unwind_cpp_pr1
+ .size __aeabi_unwind_cpp_pr2,.-__aeabi_unwind_cpp_pr2
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+diff -ur dietlibc-0.31/arm/bind.S dietlibc-0.31-x/arm/bind.S
+--- dietlibc-0.31/arm/bind.S   2009-03-17 22:54:20.000000000 +0100
++++ dietlibc-0.31-x/arm/bind.S 2009-03-17 22:54:04.000000000 +0100
+@@ -5,3 +5,7 @@
+ syscall(bind,bind)
+ #endif
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+diff -ur dietlibc-0.31/arm/connect.S dietlibc-0.31-x/arm/connect.S
+--- dietlibc-0.31/arm/connect.S        2009-03-17 22:54:20.000000000 +0100
++++ dietlibc-0.31-x/arm/connect.S      2009-03-17 22:53:52.000000000 +0100
+@@ -5,3 +5,7 @@
+ syscall(connect,connect)
+ #endif
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+diff -ur dietlibc-0.31/arm/getpeername.S dietlibc-0.31-x/arm/getpeername.S
+--- dietlibc-0.31/arm/getpeername.S    2009-03-17 22:54:20.000000000 +0100
++++ dietlibc-0.31-x/arm/getpeername.S  2009-03-17 22:53:57.000000000 +0100
+@@ -5,3 +5,7 @@
+ syscall(getpeername,getpeername)
+ #endif
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+diff -ur dietlibc-0.31/arm/getsockname.S dietlibc-0.31-x/arm/getsockname.S
+--- dietlibc-0.31/arm/getsockname.S    2009-03-17 22:54:20.000000000 +0100
++++ dietlibc-0.31-x/arm/getsockname.S  2009-03-17 22:53:53.000000000 +0100
+@@ -5,3 +5,7 @@
+ syscall(getsockname,getsockname)
+ #endif
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+diff -ur dietlibc-0.31/arm/listen.S dietlibc-0.31-x/arm/listen.S
+--- dietlibc-0.31/arm/listen.S 2009-03-17 22:54:20.000000000 +0100
++++ dietlibc-0.31-x/arm/listen.S       2009-03-17 22:53:56.000000000 +0100
+@@ -5,3 +5,7 @@
+ syscall(listen,listen)
+ #endif
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+diff -ur dietlibc-0.31/arm/recvfrom.S dietlibc-0.31-x/arm/recvfrom.S
+--- dietlibc-0.31/arm/recvfrom.S       2009-03-17 22:54:20.000000000 +0100
++++ dietlibc-0.31-x/arm/recvfrom.S     2009-03-17 22:53:50.000000000 +0100
+@@ -5,3 +5,7 @@
+ syscall(recvfrom,recvfrom)
+ #endif
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+diff -ur dietlibc-0.31/arm/recvmsg.S dietlibc-0.31-x/arm/recvmsg.S
+--- dietlibc-0.31/arm/recvmsg.S        2009-03-17 22:54:20.000000000 +0100
++++ dietlibc-0.31-x/arm/recvmsg.S      2009-03-17 22:53:46.000000000 +0100
+@@ -5,3 +5,7 @@
+ syscall(recvmsg,recvmsg)
+ #endif
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+diff -ur dietlibc-0.31/arm/recv.S dietlibc-0.31-x/arm/recv.S
+--- dietlibc-0.31/arm/recv.S   2009-03-17 22:54:20.000000000 +0100
++++ dietlibc-0.31-x/arm/recv.S 2009-03-17 22:53:41.000000000 +0100
+@@ -5,3 +5,7 @@
+ syscall(recv,recv)
+ #endif
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+diff -ur dietlibc-0.31/arm/sendmsg.S dietlibc-0.31-x/arm/sendmsg.S
+--- dietlibc-0.31/arm/sendmsg.S        2009-03-17 22:54:20.000000000 +0100
++++ dietlibc-0.31-x/arm/sendmsg.S      2009-03-17 22:53:44.000000000 +0100
+@@ -5,3 +5,7 @@
+ syscall(sendmsg,sendmsg)
+ #endif
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+diff -ur dietlibc-0.31/arm/send.S dietlibc-0.31-x/arm/send.S
+--- dietlibc-0.31/arm/send.S   2009-03-17 22:54:20.000000000 +0100
++++ dietlibc-0.31-x/arm/send.S 2009-03-17 22:53:37.000000000 +0100
+@@ -5,3 +5,7 @@
+ syscall(send,send)
+ #endif
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+diff -ur dietlibc-0.31/arm/sendto.S dietlibc-0.31-x/arm/sendto.S
+--- dietlibc-0.31/arm/sendto.S 2009-03-17 22:54:20.000000000 +0100
++++ dietlibc-0.31-x/arm/sendto.S       2009-03-17 22:53:49.000000000 +0100
+@@ -5,3 +5,7 @@
+ syscall(sendto,sendto)
+ #endif
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+diff -ur dietlibc-0.31/arm/setsockopt.S dietlibc-0.31-x/arm/setsockopt.S
+--- dietlibc-0.31/arm/setsockopt.S     2009-03-17 22:54:20.000000000 +0100
++++ dietlibc-0.31-x/arm/setsockopt.S   2009-03-17 22:53:55.000000000 +0100
+@@ -5,3 +5,7 @@
+ syscall(setsockopt,setsockopt)
+ #endif
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+diff -ur dietlibc-0.31/arm/shutdown.S dietlibc-0.31-x/arm/shutdown.S
+--- dietlibc-0.31/arm/shutdown.S       2009-03-17 22:54:20.000000000 +0100
++++ dietlibc-0.31-x/arm/shutdown.S     2009-03-17 22:53:47.000000000 +0100
+@@ -5,3 +5,7 @@
+ syscall(shutdown,shutdown)
+ #endif
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+diff -ur dietlibc-0.31/arm/socketpair.S dietlibc-0.31-x/arm/socketpair.S
+--- dietlibc-0.31/arm/socketpair.S     2009-03-17 22:54:20.000000000 +0100
++++ dietlibc-0.31-x/arm/socketpair.S   2009-03-17 22:54:02.000000000 +0100
+@@ -5,3 +5,7 @@
+ syscall(socketpair,socketpair)
+ #endif
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+diff -ur dietlibc-0.31/arm/socket.S dietlibc-0.31-x/arm/socket.S
+--- dietlibc-0.31/arm/socket.S 2009-03-17 22:54:20.000000000 +0100
++++ dietlibc-0.31-x/arm/socket.S       2009-03-17 22:53:43.000000000 +0100
+@@ -5,3 +5,7 @@
+ syscall(socket,socket)
+ #endif
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+diff -ur dietlibc-0.31/i386/dyn_syscalls.S dietlibc-0.31-x/i386/dyn_syscalls.S
+--- dietlibc-0.31/i386/dyn_syscalls.S  2009-03-17 22:54:20.000000000 +0100
++++ dietlibc-0.31-x/i386/dyn_syscalls.S        2009-03-17 22:53:34.000000000 +0100
+@@ -397,3 +397,7 @@
+ #include "setjmp.S"
+ #include "syscalls.s/__guard.S"
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+diff -ur dietlibc-0.31/parisc/mmap2.S dietlibc-0.31-x/parisc/mmap2.S
+--- dietlibc-0.31/parisc/mmap2.S       2009-03-17 22:54:20.000000000 +0100
++++ dietlibc-0.31-x/parisc/mmap2.S     2009-03-17 22:53:36.000000000 +0100
+@@ -4,3 +4,7 @@
+ syscall6(mmap2,__mmap2)
+ #endif
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+diff -ur dietlibc-0.31/ppc/mmap.S dietlibc-0.31-x/ppc/mmap.S
+--- dietlibc-0.31/ppc/mmap.S   2009-03-17 22:54:20.000000000 +0100
++++ dietlibc-0.31-x/ppc/mmap.S 2009-03-17 22:54:07.000000000 +0100
+@@ -25,3 +25,7 @@
+         blr
+ .Lfe1:
+         .size    mmap,.Lfe1-mmap
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+diff -ur dietlibc-0.31/syscalls.s/__signalfd.S dietlibc-0.31-x/syscalls.s/__signalfd.S
+--- dietlibc-0.31/syscalls.s/__signalfd.S      2009-03-17 22:54:20.000000000 +0100
++++ dietlibc-0.31-x/syscalls.s/__signalfd.S    2009-03-17 22:53:13.000000000 +0100
+@@ -3,3 +3,7 @@
+ #ifdef __NR_signalfd
+ syscall(signalfd,__signalfd)
+ #endif
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+diff -ur dietlibc-0.31/syscalls.s/splice.S dietlibc-0.31-x/syscalls.s/splice.S
+--- dietlibc-0.31/syscalls.s/splice.S  2009-03-17 22:54:20.000000000 +0100
++++ dietlibc-0.31-x/syscalls.s/splice.S        2009-03-17 22:53:11.000000000 +0100
+@@ -3,3 +3,7 @@
+ #ifdef __NR_splice
+ syscall(splice,splice)
+ #endif
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+diff -ur dietlibc-0.31/syscalls.s/tee.S dietlibc-0.31-x/syscalls.s/tee.S
+--- dietlibc-0.31/syscalls.s/tee.S     2009-03-17 22:54:20.000000000 +0100
++++ dietlibc-0.31-x/syscalls.s/tee.S   2009-03-17 22:52:34.000000000 +0100
+@@ -3,3 +3,7 @@
+ #ifdef __NR_tee
+ syscall(tee,tee)
+ #endif
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+diff -ur dietlibc-0.31/syscalls.s/timerfd.S dietlibc-0.31-x/syscalls.s/timerfd.S
+--- dietlibc-0.31/syscalls.s/timerfd.S 2009-03-17 22:54:20.000000000 +0100
++++ dietlibc-0.31-x/syscalls.s/timerfd.S       2009-03-17 22:53:09.000000000 +0100
+@@ -3,3 +3,7 @@
+ #ifdef __NR_timerfd
+ syscall(timerfd,__timerfd)
+ #endif
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+diff -ur dietlibc-0.31/syscalls.s/vmsplice.S dietlibc-0.31-x/syscalls.s/vmsplice.S
+--- dietlibc-0.31/syscalls.s/vmsplice.S        2009-03-17 22:54:20.000000000 +0100
++++ dietlibc-0.31-x/syscalls.s/vmsplice.S      2009-03-17 22:53:15.000000000 +0100
+@@ -3,3 +3,7 @@
+ #ifdef __NR_vmsplice
+ syscall(vmsplice,vmsplice)
+ #endif
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+diff -ur dietlibc-0.31/x86_64/arch_prctl.S dietlibc-0.31-x/x86_64/arch_prctl.S
+--- dietlibc-0.31/x86_64/arch_prctl.S  2006-10-14 01:59:50.000000000 +0200
++++ dietlibc-0.31-x/x86_64/arch_prctl.S        2009-03-17 22:53:19.000000000 +0100
+@@ -1,3 +1,7 @@
+ #include "syscalls.h"
+ syscall(arch_prctl,arch_prctl)
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+diff -ur dietlibc-0.31/x86_64/dyn_syscalls.S dietlibc-0.31-x/x86_64/dyn_syscalls.S
+--- dietlibc-0.31/x86_64/dyn_syscalls.S        2009-03-17 22:54:20.000000000 +0100
++++ dietlibc-0.31-x/x86_64/dyn_syscalls.S      2009-03-17 22:53:22.000000000 +0100
+@@ -302,3 +302,7 @@
+ #include "x86_64/gettimeofday.S"
+ #include "syscalls.s/__guard.S"
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+diff -ur dietlibc-0.31/x86_64/getpriority.S dietlibc-0.31-x/x86_64/getpriority.S
+--- dietlibc-0.31/x86_64/getpriority.S 2007-03-26 05:06:59.000000000 +0200
++++ dietlibc-0.31-x/x86_64/getpriority.S       2009-03-17 22:53:25.000000000 +0100
+@@ -10,3 +10,7 @@
+      neg     %rax    /* the value is bios by 20 to avoid negative values */
+      add     $20,%rax
+      ret
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+diff -ur dietlibc-0.31/x86_64/strchr.S dietlibc-0.31-x/x86_64/strchr.S
+--- dietlibc-0.31/x86_64/strchr.S      2009-03-17 22:54:20.000000000 +0100
++++ dietlibc-0.31-x/x86_64/strchr.S    2009-03-17 22:53:23.000000000 +0100
+@@ -18,3 +18,7 @@
+ .Lfound:
+       lea     -1(%rsi),%rax
+       ret
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+diff -ur dietlibc-0.31/x86_64/strcmp.S dietlibc-0.31-x/x86_64/strcmp.S
+--- dietlibc-0.31/x86_64/strcmp.S      2009-03-17 22:54:20.000000000 +0100
++++ dietlibc-0.31-x/x86_64/strcmp.S    2009-03-17 22:53:32.000000000 +0100
+@@ -25,3 +25,7 @@
+       sbb %eax,%eax
+       or $1,%eax
+       ret
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+diff -ur dietlibc-0.31/x86_64/strcpy.S dietlibc-0.31-x/x86_64/strcpy.S
+--- dietlibc-0.31/x86_64/strcpy.S      2009-03-17 22:54:20.000000000 +0100
++++ dietlibc-0.31-x/x86_64/strcpy.S    2009-03-17 22:53:17.000000000 +0100
+@@ -13,3 +13,7 @@
+       mov %rdx,%rax
+       ret
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
+diff -ur dietlibc-0.31/x86_64/time.S dietlibc-0.31-x/x86_64/time.S
+--- dietlibc-0.31/x86_64/time.S        2009-03-17 22:54:20.000000000 +0100
++++ dietlibc-0.31-x/x86_64/time.S      2009-03-17 22:53:26.000000000 +0100
+@@ -19,3 +19,7 @@
+       ret
+ .Lhere:
+       .size    time,.Lhere-time
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",%progbits
++#endif
index eacb439909c98925b91e5888a3e6040ed90d0d2b..dbcbf5954182f418b6f50d47d735ce614c60cf3c 100644 (file)
@@ -38,6 +38,6 @@ diff -ur dietlibc-0.30.org/Makefile dietlibc-0.30/Makefile
 -CFLAGS = -g
 -COMMENT = :
 -endif
- CFLAGS += -Wall -W -Wchar-subscripts -Wmissing-prototypes -Wmissing-declarations -Wno-switch -Wno-unused -Wredundant-decls
+ CFLAGS += -W -Wall -Wextra -Wchar-subscripts -Wmissing-prototypes -Wmissing-declarations -Wno-switch -Wno-unused -Wredundant-decls
  
  PWD=$(shell pwd)
index 9508eddc9d9f51585482dd721a3c17b6f3236a2a..74d0824e34653474fc2581941ce9a85dc2b1d9a3 100644 (file)
@@ -2,7 +2,7 @@ Index: dietlibc-0.30/dietfeatures.h
 ===================================================================
 --- dietlibc-0.30.orig/dietfeatures.h
 +++ dietlibc-0.30/dietfeatures.h
-@@ -99,7 +99,7 @@
+@@ -99,14 +99,14 @@
  /* WARNING: this appears to break with some binutils versions.  Works
   * for me with binutils 2.15.  The symptom is an error message that
   * `main' can not be found. */
@@ -11,18 +11,11 @@ Index: dietlibc-0.30/dietfeatures.h
  
  /* Include support for ProPolice/SSP, calls guard_setup */
  /* ProPolice is part of gcc 4.1 and up, there were patches for earlier
-@@ -108,12 +108,12 @@
-  * WANT_SSP_URANDOM and then not using -fstack-protector enlarges a
-  * binary by 152 bytes. */
+  * versions.  To make use of this, compile your application with
+  * -fstack-protector. */
  #if (__GNUC__>4) || ((__GNUC__==4) && (__GNUC_MINOR__>=1))
 -#define WANT_SSP
 +//#define WANT_SSP
  #endif
- /* Choose which canary seeder you want you can choose
-  * both but it will check urandom first and use xor as
-  * a fallback. xor is lighter but weaker */
--#define WANT_SSP_URANDOM
-+//#define WANT_SSP_URANDOM
- /* The XOR seeder is completely predictable and should not be used
-  * unless you don't have a /dev/urandom, and even then it's a bad idea. */
- /* #define WANT_SSP_XOR */
This page took 0.071328 seconds and 4 git commands to generate.