]> git.pld-linux.org Git - packages/dictd.git/blob - dictd.spec
perl -pi -e "s/^automake -a -c -f --foreing/\%\{__automake\}/; \
[packages/dictd.git] / dictd.spec
1 Summary:        Dictionary database server
2 Summary(pl):    Serwer bazy s³owników
3 Name:           dictd
4 Version:        1.5.5
5 Release:        6
6 License:        GPL
7 Group:          Daemons
8 Source0:        ftp://ftp.dict.org/pub/dict/%{name}-%{version}.tar.gz
9 Source1:        %{name}.init
10 Source2:        %{name}.sysconfig
11 Patch0:         %{name}-no_libnsl.patch
12 Patch1:         %{name}-system-zlib.patch
13 Patch2:         %{name}-opt.patch
14 URL:            http://www.dict.org/
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  flex
18 BuildRequires:  bison
19 BuildRequires:  zlib-devel
20 Prereq:         /sbin/chkconfig
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Server for the Dictionary Server Protocol (DICT), a TCP transaction
25 based query/response protocol that allows a client to access
26 dictionary definitions from a set of natural language dictionary
27 databases.
28
29 %description -l pl
30 Serwer dla Dictionary Server Protocol(DICT), bazuj±cego na TCP
31 protoko³u zapytañ i odpowiedzi umo¿liwiaj±cego klientom na dostêp do
32 definicji s³ownikowych z zestawu baz danych.
33
34 %package -n dict
35 Summary:        DICT Protocol Client
36 Summary(pl):    Klient protoko³u DICT
37 Group:          Applications/Networking
38
39 %description -n dict
40 Client for the Dictionary Server Protocol (DICT), a TCP transaction
41 based query/response protocol that provides access to dictionary
42 definitions from a set of natural language dictionary databases.
43
44 %description -n dict -l pl
45 Klient dla Dictionary Server Protocol(DICT), bazuj±cego na TCP
46 protoko³u zapytañ i odpowiedzi umo¿liwiaj±cego klientom na dostêp do
47 definicji s³ownikowych z zestawu baz danych.
48
49 %package -n dictzip
50 Summary:        Compress (or expand) files, allowing random access
51 Summary(pl):    Kompresja (i dekompresja) plików pozwalaj±ca na swobodny dostêp
52 Group:          Applications/Archiving
53
54 %description -n dictzip
55 dictzip compresses files using the gzip(1) algorithm (LZ77) in a
56 manner which is completely compatible with the gzip file format. An
57 extension to the gzip file format (Extra Field, described in 2.3.1.1
58 of RFC 1952) allows extra data to be stored in the header of a
59 compressed file. Dictd, the DICT protocol dictionary server will make
60 use of this data to perform pseudo-random access on the file.
61
62 %description -n dictzip -l pl
63 dictzip kompresuje pliki korzystaj±c z zawartego w gzip(1) algorytmu
64 (LZ77) który jest ca³kowicie kompatybilny z formatem plików gzip.
65 Rozszerzenie do formatu plików gzip (pole dodatkowe, opisane w 2.3.1.1
66 RFC 1952) pozwalaj±cego na dodatkowe dane zapisane w nag³ówku
67 skompresowanego pliku. Dictd, serwer protoko³u DICT wykorzystuje te
68 dane do pseudo-swobodnego dostêpu do pliku.
69
70 %prep
71 %setup -q
72 %patch0 -p1
73 %patch1 -p1
74 %patch2 -p1
75
76 %build
77 aclocal
78 %{__autoconf}
79 (cd libmaa; aclocal; autoconf)
80 CFLAGS="%{rpmcflags} -DUID_NOBODY=99 -DGID_NOBODY=99"
81 %configure
82
83 %{__make}
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87 install -d $RPM_BUILD_ROOT{/etc/{rc.d/init.d,sysconfig,%{name}},%{_bindir},%{_sbindir}} \
88            $RPM_BUILD_ROOT{%{_datadir}/%{name},%{_mandir}/man{1,8}}
89
90 install dict dictzip $RPM_BUILD_ROOT%{_bindir}
91 install {dict,dictzip}.1 $RPM_BUILD_ROOT%{_mandir}/man1
92
93 install %{name} $RPM_BUILD_ROOT%{_sbindir}
94 install %{name}.8 $RPM_BUILD_ROOT%{_mandir}/man8
95
96 echo "server localhost" > dict.conf
97 echo -e "access {\n\tallow localhost\n\tdeny *\n}\n" > %{name}-main.conf
98
99 install dict.conf $RPM_BUILD_ROOT%{_sysconfdir}
100 install dictd-main.conf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
101 touch $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
102 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
103 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
104
105 mv -f doc/security.doc security.txt
106 gzip -9nf {ANNOUNCE,ChangeLog,README,TODO,%{name}.conf,example*.conf,example.site,security.txt}
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post
112 /sbin/chkconfig --add %{name}
113 if [ -f /var/lock/subsys/%{name} ]; then
114         /etc/rc.d/init.d/%{name} restart >&2
115 else
116         echo "Run \"/etc/rc.d/init.d/%{name} start\" to start %{name} daemon."
117 fi
118
119 %preun
120 if [ "$1" = "0" ]; then
121         if [ -f /var/lock/subsys/%{name} ]; then
122                 /etc/rc.d/init.d/%{name} stop >&2
123         fi
124         /sbin/chkconfig --del %{name}
125 fi
126
127 %files
128 %defattr(644,root,root,755)
129 %doc *.gz
130 %ghost %{_sysconfdir}/%{name}.conf
131 %attr(755,root,root) %{_sbindir}/%{name}
132 %attr(754,root,root) /etc/rc.d/init.d/%{name}
133 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/sysconfig/%{name}
134 %dir %{_datadir}/%{name}
135 %dir %{_sysconfdir}/%{name}
136 %{_sysconfdir}/%{name}/%{name}-main.conf
137 %{_mandir}/man8/%{name}*
138
139 %files -n dict
140 %defattr(644,root,root,755)
141 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/dict.conf
142 %attr(755,root,root) %{_bindir}/dict
143 %{_mandir}/man1/dict.1*
144
145 %files -n dictzip
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_bindir}/dictzip
148 %{_mandir}/man1/dictzip.1*
This page took 0.070309 seconds and 3 git commands to generate.