]> git.pld-linux.org Git - packages/dictd.git/blob - dictd.spec
- opt,system-zlib patches: use optflags and system zlib
[packages/dictd.git] / dictd.spec
1 Summary:        Dictionary database server
2 Summary(pl):    Serwer bazy s³owników
3 Name:           dictd
4 Version:        1.5.5
5 Release:        4
6 License:        GPL
7 Group:          Daemons
8 Group(de):      Server
9 Group(pl):      Serwery
10 Source0:        ftp://ftp.dict.org/pub/dict/%{name}-%{version}.tar.gz
11 Source1:        %{name}.init
12 Source2:        %{name}.sysconfig
13 Patch0:         %{name}-no_libnsl.patch
14 Patch1:         %{name}-system-zlib.patch
15 Patch2:         %{name}-opt.patch
16 URL:            http://www.dict.org/
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  flex
20 BuildRequires:  bison
21 BuildRequires:  zlib-devel
22 Prereq:         /sbin/chkconfig
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description 
26 Server for the Dictionary Server Protocol (DICT), a TCP transaction
27 based query/response protocol that allows a client to access
28 dictionary definitions from a set of natural language dictionary
29 databases.
30
31 %description -l pl
32 Serwer dla Dictionary Server Protocol(DICT), bazuj±cego na TCP
33 protoko³u zapytañ i odpowiedzi umo¿liwiaj±cego klientom na dostêp do
34 definicji s³ownikowych z zestawu baz danych.
35
36 %package -n dict
37 Summary:        DICT Protocol Client
38 Summary(pl):    Klient protoko³u DICT
39 Group:          Applications/Networking
40 Group(de):      Applikationen/Netzwerkwesen
41 Group(pl):      Aplikacje/Sieciowe
42
43 %description -n dict
44 Client for the Dictionary Server Protocol (DICT), a TCP transaction
45 based query/response protocol that provides access to dictionary
46 definitions from a set of natural language dictionary databases.
47
48 %description -n dict -l pl
49 Klient dla Dictionary Server Protocol(DICT), bazuj±cego na TCP
50 protoko³u zapytañ i odpowiedzi umo¿liwiaj±cego klientom na dostêp do
51 definicji s³ownikowych z zestawu baz danych.
52
53 %package -n dictzip
54 Summary:        Compress (or expand) files, allowing random access
55 Summary(pl):    Kompresja (i dekompresja) plików pozwalaj±ca na swobodny dostêp
56 Group:          Applications/Archiving
57 Group(de):      Applikationen/Archivierung
58 Group(pl):      Aplikacje/Archiwizacja
59
60 %description -n dictzip
61 dictzip compresses files using the gzip(1) algorithm (LZ77) in a
62 manner which is completely compatible with the gzip file format. An
63 extension to the gzip file format (Extra Field, described in 2.3.1.1
64 of RFC 1952) allows extra data to be stored in the header of a
65 compressed file. Dictd, the DICT protocol dictionary server will make
66 use of this data to perform pseudo-random access on the file.
67
68 %description -n dictzip -l pl
69 dictzip kompresuje pliki korzystaj±c z zawartego w gzip(1) algorytmu
70 (LZ77) który jest ca³kowicie kompatybilny z formatem plików gzip.
71 Rozszerzenie do formatu plików gzip (pole dodatkowe, opisane w 2.3.1.1
72 RFC 1952) pozwalaj±cego na dodatkowe dane zapisane w nag³ówku
73 skompresowanego pliku. Dictd, serwer protoko³u DICT wykorzystuje te
74 dane do pseudo-swobodnego dostêpu do pliku.
75
76 %prep
77 %setup -q
78 %patch0 -p1
79 %patch1 -p1
80 %patch2 -p1
81
82 %build
83 aclocal
84 autoconf
85 (cd libmaa; aclocal; autoconf)
86 %configure
87
88 %{__make}
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92 install -d $RPM_BUILD_ROOT{/etc/{rc.d/init.d,sysconfig,%{name}},%{_bindir},%{_sbindir}} \
93            $RPM_BUILD_ROOT{%{_datadir}/%{name},%{_mandir}/man{1,8}}
94
95 install dict dictzip $RPM_BUILD_ROOT%{_bindir}
96 install {dict,dictzip}.1 $RPM_BUILD_ROOT%{_mandir}/man1
97
98 install %{name} $RPM_BUILD_ROOT%{_sbindir}
99 install %{name}.8 $RPM_BUILD_ROOT%{_mandir}/man8
100
101 echo "server localhost" > dict.conf
102 echo -e "access {\n\tallow localhost\n\tdeny *\n}\n" > %{name}-main.conf 
103
104 install dict.conf $RPM_BUILD_ROOT%{_sysconfdir}
105 install dictd-main.conf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
106 touch $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
107 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
108 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
109
110 mv -f doc/security.doc security.txt
111 gzip -9nf {ANNOUNCE,ChangeLog,README,TODO,%{name}.conf,example*.conf,example.site,security.txt}
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %post
117 /sbin/chkconfig --add %{name}
118 if [ -f /var/lock/subsys/%{name} ]; then
119         /etc/rc.d/init.d/%{name} restart >&2
120 else
121         echo "Run \"/etc/rc.d/init.d/%{name} start\" to start %{name} daemon."
122 fi
123     
124 %preun
125 if [ "$1" = "0" ]; then
126         if [ -f /var/lock/subsys/%{name} ]; then
127                 /etc/rc.d/init.d/%{name} stop >&2
128         fi
129         /sbin/chkconfig --del %{name}
130 fi
131
132 %files
133 %defattr(644,root,root,755)
134 %doc *.gz
135 %ghost %{_sysconfdir}/%{name}.conf
136 %attr(755,root,root) %{_sbindir}/%{name}
137 %attr(754,root,root) /etc/rc.d/init.d/%{name}
138 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/sysconfig/%{name}
139 %dir %{_datadir}/%{name}
140 %dir %{_sysconfdir}/%{name}
141 %{_sysconfdir}/%{name}/%{name}-main.conf
142 %{_mandir}/man8/%{name}*
143
144 %files -n dict
145 %defattr(644,root,root,755)
146 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/dict.conf
147 %attr(755,root,root) %{_bindir}/dict
148 %{_mandir}/man1/dict.1*
149
150 %files -n dictzip
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_bindir}/dictzip
153 %{_mandir}/man1/dictzip.1*
This page took 0.270597 seconds and 3 git commands to generate.