]> git.pld-linux.org Git - packages/dictd.git/blob - dictd.spec
- update to 1.9.12
[packages/dictd.git] / dictd.spec
1 Summary:        Dictionary database server
2 Summary(pl):    Serwer bazy s³owników
3 Name:           dictd
4 Version:        1.9.12
5 Release:        1
6 License:        GPL
7 Group:          Networking/Daemons
8 Source0:        http://dl.sourceforge.net/dict/%{name}-%{version}.tar.gz
9 # Source0-md5:  08a7b2710f1a018a7f6cc26cbecbb5ac
10 Source1:        %{name}.init
11 Source2:        %{name}.sysconfig
12 Patch0:         %{name}-opt.patch
13 URL:            http://www.dict.org/
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  bison
17 BuildRequires:  flex
18 BuildRequires:  libltdl-devel
19 BuildRequires:  zlib-devel
20 Requires(post,preun):   /sbin/chkconfig
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         specflags_ia32  "-fomit-frame-pointer"
24
25 %description
26 Server for the Dictionary Server Protocol (DICT), a TCP transaction
27 based query/response protocol that allows a client to access
28 dictionary definitions from a set of natural language dictionary
29 databases.
30
31 %description -l pl
32 Serwer dla Dictionary Server Protocol (DICT), bazuj±cego na TCP
33 protoko³u zapytañ i odpowiedzi umo¿liwiaj±cego klientom na dostêp do
34 definicji s³ownikowych z zestawu baz danych.
35
36 %package -n dict
37 Summary:        DICT Protocol Client
38 Summary(pl):    Klient protoko³u DICT
39 Group:          Applications/Networking
40
41 %description -n dict
42 Client for the Dictionary Server Protocol (DICT), a TCP transaction
43 based query/response protocol that provides access to dictionary
44 definitions from a set of natural language dictionary databases.
45
46 %description -n dict -l pl
47 Klient dla Dictionary Server Protocol (DICT), bazuj±cego na TCP
48 protoko³u zapytañ i odpowiedzi umo¿liwiaj±cego klientom na dostêp do
49 definicji s³ownikowych z zestawu baz danych.
50
51 %package -n dictfmt
52 Summary:        dictfmt utility to convert databases in various formats into dict format
53 Summary(pl):    Narzêdzie dictfmt do konwersji baz w ró¿nych formatach na format dict
54 Group:          Applications/Text
55 Obsoletes:      dict-fmt
56
57 %description -n dictfmt
58 dictfmt utility is designed to convert databases in various formats
59 into working databases and indexes for the DICT server.
60 This package also includes other tools for formating databases:
61 dictfmt_{index2suffix,index2word,plugin,virtual} and dictunformat.
62
63 %description -n dictfmt -l pl
64 Narzêdzie dictfmt s³u¿y do konwertowania baz danych w ró¿nych
65 formatach na dzia³aj±ce bazy danych i indeksy dla serwera s³owników
66 DICT.
67 Ten pakiet zawiera tak¿e inne narzêdzia do formatowania baz:
68 dictfmt_{index2suffix,index2word,plugin,virtual} and dictunformat.
69
70 %package -n dictzip
71 Summary:        Compress (or expand) files, allowing random access
72 Summary(pl):    Kompresja (i dekompresja) plików pozwalaj±ca na swobodny dostêp
73 Group:          Applications/Archiving
74
75 %description -n dictzip
76 dictzip compresses files using the gzip(1) algorithm (LZ77) in a
77 manner which is completely compatible with the gzip file format. An
78 extension to the gzip file format (Extra Field, described in 2.3.1.1
79 of RFC 1952) allows extra data to be stored in the header of a
80 compressed file. Dictd, the DICT protocol dictionary server will make
81 use of this data to perform pseudo-random access on the file.
82
83 %description -n dictzip -l pl
84 dictzip kompresuje pliki korzystaj±c z zawartego w gzip(1) algorytmu
85 (LZ77) który jest ca³kowicie kompatybilny z formatem plików gzip.
86 Rozszerzenie do formatu plików gzip (pole dodatkowe, opisane w 2.3.1.1
87 RFC 1952) pozwalaj±cego na dodatkowe dane zapisane w nag³ówku
88 skompresowanego pliku. Dictd, serwer protoko³u DICT wykorzystuje te
89 dane do pseudo-swobodnego dostêpu do pliku.
90
91 %prep
92 %setup -q
93 %patch0 -p1
94
95 %build
96 cp -f %{_datadir}/automake/config.* .
97 %{__aclocal}
98 %{__autoconf}
99 cd libmaa
100 cp -f %{_datadir}/automake/config.* .
101 %{__aclocal}
102 %{__autoconf}
103 cd ..
104 CFLAGS="%{rpmcflags} -DUID_NOBODY=99 -DGID_NOBODY=99"
105 %configure
106
107 %{__make}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111 install -d $RPM_BUILD_ROOT{/etc/{rc.d/init.d,sysconfig,%{name}},%{_datadir}/%{name}}
112
113 %{__make} install \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 echo "server localhost" > dict.conf
117 echo -e "access {\n\tallow localhost\n\tdeny *\n}\n" > %{name}-main.conf
118
119 install dict.conf $RPM_BUILD_ROOT%{_sysconfdir}
120 install dictd-main.conf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
121 :> $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
122 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
123 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
124
125 mv -f doc/security.doc security.txt
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %post
131 /sbin/chkconfig --add %{name}
132 if [ -f /var/lock/subsys/%{name} ]; then
133         /etc/rc.d/init.d/%{name} restart >&2
134 else
135         echo "Run \"/etc/rc.d/init.d/%{name} start\" to start %{name} daemon."
136 fi
137
138 %preun
139 if [ "$1" = "0" ]; then
140         if [ -f /var/lock/subsys/%{name} ]; then
141                 /etc/rc.d/init.d/%{name} stop >&2
142         fi
143         /sbin/chkconfig --del %{name}
144 fi
145
146 %files
147 %defattr(644,root,root,755)
148 %doc ANNOUNCE NEWS README* TODO dictd.conf example* security.txt
149 %ghost %{_sysconfdir}/%{name}.conf
150 %dir %{_sysconfdir}/%{name}
151 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/%{name}/%{name}-main.conf
152 %config(noreplace) %verify(not md5 size mtime) /etc/sysconfig/%{name}
153 %attr(754,root,root) /etc/rc.d/init.d/%{name}
154 %attr(755,root,root) %{_sbindir}/%{name}
155 %dir %{_datadir}/%{name}
156 %{_mandir}/man8/%{name}*
157
158 # where?
159 %attr(755,root,root) %{_bindir}/dictdplugin-config
160 #%{_includedir}/dictdplugin.h
161
162 %files -n dict
163 %defattr(644,root,root,755)
164 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/dict.conf
165 %attr(755,root,root) %{_bindir}/colorit
166 %attr(755,root,root) %{_bindir}/dict
167 %attr(755,root,root) %{_bindir}/dictl
168 %{_mandir}/man1/colorit.1*
169 %{_mandir}/man1/dict.1*
170 %{_mandir}/man1/dictl.1*
171
172 %files -n dictfmt
173 %defattr(644,root,root,755)
174 %attr(755,root,root) %{_bindir}/dictfmt*
175 %attr(755,root,root) %{_bindir}/dictunformat
176 %{_mandir}/man1/dictfmt*.1*
177 %{_mandir}/man1/dictunformat.1*
178
179 %files -n dictzip
180 %defattr(644,root,root,755)
181 %attr(755,root,root) %{_bindir}/dictzip
182 %{_mandir}/man1/dictzip.1*
This page took 0.064404 seconds and 3 git commands to generate.