]> git.pld-linux.org Git - packages/dictd.git/blob - dictd.spec
5a18d7b3b76ef30d004bc8e2449aad17646f61a4
[packages/dictd.git] / dictd.spec
1 Summary:        Dictionary database server
2 Summary(pl):    Serwer bazy s³owników
3 Name:           dictd
4 Version:        1.5.5
5 Release:        1
6 License:        GPL
7 Group:          Daemons
8 Group(de):      Server
9 Group(pl):      Serwery
10 Source0:        ftp://ftp.dict.org/pub/dict/%{name}-%{version}.tar.gz
11 Source1:        %{name}.init
12 Source2:        %{name}.sysconfig
13 URL:            http://www.dict.org/
14 Requires:       /bin/cat
15 Requires:       /bin/ls
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description 
19 Server for the Dictionary Server Protocol (DICT), a TCP transaction
20 based query/response protocol that allows a client to access
21 dictionary definitions from a set of natural language dictionary
22 databases.
23
24 %description -l pl
25 Serwer dla Dictionary Server Protocol(DICT), bazuj±cego na TCP
26 protoko³u zapytañ i odpowiedzi umo¿liwiaj±cego klientom na dostêp do
27 definicji s³ownikowych z zestawu baz danych.
28
29 %package -n dict
30 Summary:        DICT Protocol Client
31 Summary(pl):    Klient protoko³u DICT
32 Group:          Applications/Networking
33 Group(de):      Applikationen/Netzwerkwesen
34 Group(pl):      Aplikacje/Sieciowe
35
36 %description -n dict
37 Client for the Dictionary Server Protocol (DICT), a TCP transaction
38 based query/response protocol that provides access to dictionary
39 definitions from a set of natural language dictionary databases.
40
41 %description -n dict -l pl
42 Klient dla Dictionary Server Protocol(DICT), bazuj±cego na TCP
43 protoko³u zapytañ i odpowiedzi umo¿liwiaj±cego klientom na dostêp do
44 definicji s³ownikowych z zestawu baz danych.
45
46 %package -n dictzip
47 Summary:        Compress (or expand) files, allowing random access
48 Group:          Applications/Archiving
49 Group(de):      Applikationen/Archivierung
50 Group(pl):      Aplikacje/Archiwizacja
51
52 %description -n dictzip
53 dictzip compresses files using the gzip(1) algorithm (LZ77) in a
54 manner which is completely compatible with the gzip file format. An
55 extension to the gzip file format (Extra Field, described in 2.3.1.1
56 of RFC 1952) allows extra data to be stored in the header of a
57 compressed file. Dictd, the DICT protocol dictionary server will make
58 use of this data to perform pseudo-random access on the file.
59
60 %description -n dictzip -l pl
61 dictzip kompresuje pliki ko¿ystaj±c z zawartego w gzip(1) algorytmu
62 (LZ77) który jest ca³kowicie kompatybilny z formatem plików gzip.
63 Rozszerzenie do formatu plików gzip(pole dodatkowe, opisane w 2.3.1.1
64 RFC 1952) pozwalaj±cego na dodatkowe dane zapisane w nag³ówku
65 skompresowanego pliku. Dictd, serwer protoko³u DICT wykorzystuje te
66 dane do pseudo-losowego dostêpu do pliku.
67
68 %prep
69 %setup -q
70
71 %build
72 # --without-local-zlib option gives no effect. Usage of zlib from dictd tarball 
73 # is hardcoded in configure. 
74
75 # TODO: 
76 # - patch needed instead of use -DUID_NOBODY=`id -u nobody`
77 #
78 CFLAGS="%{rpmcflags} -DUID_NOBODY=`id -u nobody`"
79 export CFLAGS
80 %configure \
81         --with-local-zlib=no
82 %{__make}
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/{rc.d/init.d,sysconfig,%{name}},%{_bindir},%{_sbindir}} \
87            $RPM_BUILD_ROOT{%{_datadir}/%{name},%{_mandir}/man{1,8}}
88
89 install dict dictzip $RPM_BUILD_ROOT/%{_bindir}
90 install {dict,dictzip}.1 $RPM_BUILD_ROOT/%{_mandir}/man1
91
92 install %{name} $RPM_BUILD_ROOT/%{_sbindir}
93 install %{name}.8 $RPM_BUILD_ROOT/%{_mandir}/man8
94
95 echo "server localhost" > dict.conf
96 echo -e "access {\n\tallow localhost\n\tdeny *\n}\n" > %{name}-main.conf 
97
98 install dict.conf $RPM_BUILD_ROOT%{_sysconfdir}/
99 install dictd-main.conf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/
100 touch %{buildroot}%{_sysconfdir}/%{name}.conf
101 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/%{name}
102 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
103
104 mv -f doc/security.doc security.txt
105 gzip -9nf {ANNOUNCE,ChangeLog,README,TODO,%{name}.conf,example*.conf,example.site,security.txt}
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %post
111 DESC="dictd daemon"; %chkconfig_add
112     
113 %preun
114 %chkconfig_del
115
116 %files
117 %defattr(644,root,root,755)
118 %ghost %{_sysconfdir}/%{name}.conf
119 %attr(755,root,root) %{_sbindir}/%{name}
120 %attr(754,root,root) /etc/rc.d/init.d/%{name}
121 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/sysconfig/%{name}
122 %dir %{_datadir}/%{name}
123 %dir %{_sysconfdir}/%{name}
124 %{_sysconfdir}/%{name}/%{name}-main.conf
125 %{_mandir}/man8/%{name}*
126 %doc {ANNOUNCE,ChangeLog,README,TODO,%{name}.conf,example*.conf,example.site,security.txt}.gz
127
128 %files -n dict
129 %defattr(644,root,root,755)
130 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/dict.conf
131 %attr(755,root,root) %{_bindir}/dict
132 %{_mandir}/man1/dict.1*
133
134 %files -n dictzip
135 %defattr(644,root,root,755)
136 %attr(755,root,root) %{_bindir}/dictzip
137 %{_mandir}/man1/dictzip.1*
This page took 0.175462 seconds and 2 git commands to generate.