]> git.pld-linux.org Git - packages/dict-web1913.git/blob - dict-web1913.spec
just groups
[packages/dict-web1913.git] / dict-web1913.spec
1 %define         dictname web1913
2 %define         dictversion 0.46-a
3 Summary:        Webster's Revised Unabridged Dictionary
4 Name:           dict-%{dictname}
5 Version:        1.4
6 Release:        1
7 License:        Free to use, but see http://www.cogsci.princeton.edu/~wn/
8 Group:          Applications/Dictionaries
9 Group(de):      Applikationen/Wörterbücher
10 Group(pl):      Aplikacje/S³owniki
11 URL:            http://www.dict.org/
12 Source0:        ftp://ftp.dict.org/pub/dict/%{name}-%{version}.tar.gz
13 Source1:        ftp://ftp.dict.org/pub/dict/%{dictname}-%{dictversion}.tar.gz
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15 BuildRequires:  dictzip
16 Requires:       dictd 
17 Requires:       %{_sysconfdir}/dictd
18 BuildArch:      noarch
19
20 %description 
21
22 %prep 
23 %setup -q
24
25 %build
26 %configure --with-local-libmaa --with-datapath=%{dictname}-%{dictversion}
27 %{__make}
28 tar xfz %{SOURCE1}
29 %{__make} db 
30
31 %install
32 rm -rf $RPM_BUILD_ROOT
33 install -d $RPM_BUILD_ROOT{%{_datadir}/dictd/,%{_sysconfdir}/dictd}
34 #make install dictdir="$RPM_BUILD_ROOT%{_datadir}/dictd/"
35 install %{dictname}.{dict.dz,index} $RPM_BUILD_ROOT%{_datadir}/dictd/
36
37 dictprefix=%{_datadir}/dictd/%{dictname}
38 echo "# Webster's Revised Unabridged Dictionary
39 database %{dictname} {
40     data  \"$dictprefix.dict.dz\"
41     index \"$dictprefix.index\" 
42 }" > $RPM_BUILD_ROOT%{_sysconfdir}/dictd/%{dictname}.dictconf
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %postun
48 if [ -f /var/lock/subsys/dictd ]; then
49         /etc/rc.d/init.d/dictd restart 1>&2 || true
50 fi
51
52 %post
53 if [ -f /var/lock/subsys/dictd ]; then
54         /etc/rc.d/init.d/dictd restart 1>&2
55 fi
56
57 %files
58 %defattr(644,root,root,755)
59 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/dictd/%{dictname}.dictconf
60 %{_datadir}/dictd/%{dictname}*
This page took 0.089242 seconds and 3 git commands to generate.