]> git.pld-linux.org Git - packages/dict-web1913.git/blob - dict-web1913.spec
96c2ce6e73abb313de6fc9a64880d0b525f6ba3d
[packages/dict-web1913.git] / dict-web1913.spec
1 %define         dictname web1913
2 %define         dictversion 0.46-a
3 Summary:        Webster's Revised Unabridged Dictionary
4 Summary(pl):    S³ownik Webster's Revised Unabridged Dictionary
5 Name:           dict-%{dictname}
6 Version:        1.4
7 Release:        2
8 License:        Free to use, but see http://www.cogsci.princeton.edu/~wn/
9 Group:          Applications/Dictionaries
10 URL:            http://www.dict.org/
11 Source0:        ftp://ftp.dict.org/pub/dict/%{name}-%{version}.tar.gz
12 Source1:        ftp://ftp.dict.org/pub/dict/%{dictname}-%{dictversion}.tar.gz
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14 BuildRequires:  dictzip
15 BuildRequires:  autoconf
16 BuildRequires:  flex
17 BuildRequires:  bison
18 Requires:       dictd
19 Requires:       %{_sysconfdir}/dictd
20
21 %description
22 Webster's Revised Unabridged Dictionary (1913).
23
24 %description -l pl
25 S³ownik Webstera (angielsko-angielski): Webster's Revised Unabridged
26 Dictionary (1913).
27
28 %prep
29 %setup -q
30
31 %build
32 %{__autoconf}
33 cd libmaa
34 %{__autoconf}
35 cd ..
36 %configure \
37         --with-local-libmaa \
38         --with-datapath=%{dictname}-%{dictversion}
39 %{__make}
40 tar xfz %{SOURCE1}
41 %{__make} db
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT{%{_datadir}/dictd,%{_sysconfdir}/dictd}
46 #make install dictdir="$RPM_BUILD_ROOT%{_datadir}/dictd/"
47 install %{dictname}.{dict.dz,index} $RPM_BUILD_ROOT%{_datadir}/dictd
48
49 dictprefix=%{_datadir}/dictd/%{dictname}
50 echo "# Webster's Revised Unabridged Dictionary
51 database %{dictname} {
52         data  \"$dictprefix.dict.dz\"
53         index \"$dictprefix.index\"
54 }" > $RPM_BUILD_ROOT%{_sysconfdir}/dictd/%{dictname}.dictconf
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %post
60 if [ -f /var/lock/subsys/dictd ]; then
61         /etc/rc.d/init.d/dictd restart 1>&2
62 fi
63
64 %postun
65 if [ "$1" = "0" -a -f /var/lock/subsys/dictd ]; then
66         /etc/rc.d/init.d/dictd restart 1>&2 || true
67 fi
68
69 %files
70 %defattr(644,root,root,755)
71 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/dictd/%{dictname}.dictconf
72 %{_datadir}/dictd/%{dictname}*
This page took 0.073625 seconds and 2 git commands to generate.