]> git.pld-linux.org Git - packages/dict-web1913.git/blob - dict-web1913.spec
6584c23e967cdacf650974c9f6ae135ce85602b7
[packages/dict-web1913.git] / dict-web1913.spec
1 %define         dictname web1913
2 %define         dictversion 0.46-a
3 Summary:        Webster's Revised Unabridged Dictionary
4 Summary(pl):    S³ownik Webster's Revised Unabridged Dictionary
5 Name:           dict-%{dictname}
6 Version:        1.4
7 Release:        3
8 License:        Free to use, but see http://www.cogsci.princeton.edu/~wn/
9 Group:          Applications/Dictionaries
10 Source0:        ftp://ftp.dict.org/pub/dict/%{name}-%{version}.tar.gz
11 Source1:        ftp://ftp.dict.org/pub/dict/%{dictname}-%{dictversion}.tar.gz
12 Patch0:         %{name}-ac.patch
13 URL:            http://www.dict.org/
14 BuildRequires:  autoconf
15 BuildRequires:  bison
16 BuildRequires:  dictzip
17 BuildRequires:  flex
18 Requires:       dictd
19 Requires:       %{_sysconfdir}/dictd
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Webster's Revised Unabridged Dictionary (1913).
24
25 %description -l pl
26 S³ownik Webstera (angielsko-angielski): Webster's Revised Unabridged
27 Dictionary (1913).
28
29 %prep
30 %setup -q
31 %patch0 -p1
32
33 %build
34 %{__autoconf}
35 cd libmaa
36 %{__autoconf}
37 cd ..
38 %configure \
39         --with-local-libmaa \
40         --with-datapath=%{dictname}-%{dictversion}
41 %{__make}
42 tar xfz %{SOURCE1}
43 %{__make} db
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT{%{_datadir}/dictd,%{_sysconfdir}/dictd}
48 #make install dictdir="$RPM_BUILD_ROOT%{_datadir}/dictd/"
49 install %{dictname}.{dict.dz,index} $RPM_BUILD_ROOT%{_datadir}/dictd
50
51 dictprefix=%{_datadir}/dictd/%{dictname}
52 echo "# Webster's Revised Unabridged Dictionary
53 database %{dictname} {
54         data  \"$dictprefix.dict.dz\"
55         index \"$dictprefix.index\"
56 }" > $RPM_BUILD_ROOT%{_sysconfdir}/dictd/%{dictname}.dictconf
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %post
62 if [ -f /var/lock/subsys/dictd ]; then
63         /etc/rc.d/init.d/dictd restart 1>&2
64 fi
65
66 %postun
67 if [ -f /var/lock/subsys/dictd ]; then
68         /etc/rc.d/init.d/dictd restart 1>&2 || true
69 fi
70
71 %files
72 %defattr(644,root,root,755)
73 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/dictd/%{dictname}.dictconf
74 %{_datadir}/dictd/%{dictname}.*
This page took 0.059184 seconds and 2 git commands to generate.