]> git.pld-linux.org Git - packages/dict-web1913.git/blame - dict-web1913.spec
- Initital version
[packages/dict-web1913.git] / dict-web1913.spec
CommitLineData
ca47bec4 1%define dictname web1913
2%define dictversion 0.46-a
3Summary: Webster's Revised Unabridged Dictionary
4Name: dict-%{dictname}
5Version: 1.4
6Release: 1
7License: Free to use, but see http://www.cogsci.princeton.edu/~wn/
8Group: Applications/Dictionary
9URL: http://www.dict.org/
10Source0: ftp://ftp.dict.org/pub/dict/%{name}-%{version}.tar.gz
11Source1: ftp://ftp.dict.org/pub/dict/%{dictname}-%{dictversion}.tar.gz
12BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13BuildRequires: dictzip
14Requires: dictd
15Requires: %{_sysconfdir}/dictd
16BuildArch: noarch
17
18%description
19
20%prep
21%setup -q
22
23%build
24%configure --with-local-libmaa --with-datapath=%{dictname}-%{dictversion}
25%{__make}
26tar xfz %{SOURCE1}
27%{__make} db
28
29%install
30rm -rf $RPM_BUILD_ROOT
31install -d $RPM_BUILD_ROOT{%{_datadir}/dictd/,%{_sysconfdir}/dictd}
32#make install dictdir="$RPM_BUILD_ROOT%{_datadir}/dictd/"
33install %{dictname}.{dict.dz,index} $RPM_BUILD_ROOT%{_datadir}/dictd/
34
35dictprefix=%{_datadir}/dictd/%{dictname}
36echo "# Webster's Revised Unabridged Dictionary
37database %{dictname} {
38 data \"$dictprefix.dict.dz\"
39 index \"$dictprefix.index\"
40}" > $RPM_BUILD_ROOT%{_sysconfdir}/dictd/%{dictname}.dictconf
41
42%clean
43rm -rf $RPM_BUILD_ROOT
44
45%postun
46if [ -f /var/lock/subsys/dictd ]; then
47 /etc/rc.d/init.d/dictd restart 1>&2 || true
48fi
49
50%post
51if [ -f /var/lock/subsys/dictd ]; then
52 /etc/rc.d/init.d/dictd restart 1>&2
53fi
54
55%files
56%defattr(644,root,root,755)
57%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/dictd/%{dictname}.dictconf
58%{_datadir}/dictd/%{dictname}*
This page took 0.085544 seconds and 4 git commands to generate.