]> git.pld-linux.org Git - packages/dict-sap.git/blob - dict-sap.spec
- ac stuff, removed noarch.
[packages/dict-sap.git] / dict-sap.spec
1 Summary:        sap - English-Polish and vice versa dictionary for dictd
2 Name:           dict-sap
3 Version:        0.1b_0.1
4 Release:        1
5 License:        GPL
6 Group:          Applications/Dictionaries
7 Group(pl):      Aplikacje/S³owniki
8 Source:         %{name}-%{version}.tar.gz
9 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
10 BuildRequires:  dictzip
11 BuildRequires:  perl
12 BuildRequires:  autoconf
13 Requires:       dictd
14 Requires:       %{_sysconfdir}/dictd
15
16 %description 
17 This package contains sap - English-Polish and Polish-English
18 dictionary version 0.1b, formatted for use by the DICT server.
19
20 %prep
21 %setup -q
22
23 %build
24 autoconf
25 %configure 
26 %{__make} db 
27
28 %install
29 rm -rf $RPM_BUILD_ROOT
30 install -d $RPM_BUILD_ROOT{%{_datadir}/dictd/,%{_bindir},%{_sysconfdir}/dictd}
31 %{__make} install DESTDIR=$RPM_BUILD_ROOT
32
33 for dictname in sap_en-pl sap_pl-en; do
34     dictprefix=%{_datadir}/dictd/$dictname
35     echo "# sap dictionary, part $dictname
36 database $dictname {
37     data  \"$dictprefix.dict.dz\"
38     index \"$dictprefix.index\"
39 }" > $RPM_BUILD_ROOT%{_sysconfdir}/dictd/$dictname.dictconf
40 done
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %postun
46 if [ -f /var/lock/subsys/dictd ]; then
47         /etc/rc.d/init.d/dictd restart 1>&2 || true
48 fi
49
50 %post
51 if [ -f /var/lock/subsys/dictd ]; then
52         /etc/rc.d/init.d/dictd restart 1>&2
53 fi
54
55 %files
56 %defattr(644,root,root,755)
57 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/dictd/*.dictconf
58 %attr(755,root,root) %{_bindir}/sapdict
59 %{_datadir}/dictd/sap_*
This page took 0.066984 seconds and 4 git commands to generate.