]> git.pld-linux.org Git - packages/dict-sap.git/blob - dict-sap.spec
- removed all Group fields translations (oure rpm now can handle translating
[packages/dict-sap.git] / dict-sap.spec
1 Summary:        sap - English-Polish and vice versa dictionary for dictd
2 Summary(pl):    sap - s³ownik angielsko-polski i odwrotnie dla dictd
3 Name:           dict-sap
4 Version:        0.1b_0.1
5 Release:        1
6 License:        GPL
7 Group:          Applications/Dictionaries
8 Source0:        %{name}-%{version}.tar.gz
9 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
10 BuildRequires:  dictzip
11 BuildRequires:  perl
12 BuildRequires:  autoconf
13 Requires:       dictd
14 Requires:       %{_sysconfdir}/dictd
15
16 %description 
17 This package contains sap - English-Polish and Polish-English
18 dictionary version 0.1b, formatted for use by the DICT server.
19
20 %description -l pl
21 Ten pakiet zawiera sap - s³ownik angielsko-polski i polsko-angielski
22 sformatowane do u¿ycia z serwerem s³ownika dictd.
23
24 %prep
25 %setup -q
26
27 %build
28 autoconf
29 %configure 
30 %{__make} db 
31
32 %install
33 rm -rf $RPM_BUILD_ROOT
34 install -d $RPM_BUILD_ROOT{%{_datadir}/dictd/,%{_bindir},%{_sysconfdir}/dictd}
35 %{__make} install DESTDIR=$RPM_BUILD_ROOT
36
37 for dictname in sap_en-pl sap_pl-en; do
38     dictprefix=%{_datadir}/dictd/$dictname
39     echo "# sap dictionary, part $dictname
40 database $dictname {
41     data  \"$dictprefix.dict.dz\"
42     index \"$dictprefix.index\"
43 }" > $RPM_BUILD_ROOT%{_sysconfdir}/dictd/$dictname.dictconf
44 done
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %postun
50 if [ -f /var/lock/subsys/dictd ]; then
51         /etc/rc.d/init.d/dictd restart 1>&2 || true
52 fi
53
54 %post
55 if [ -f /var/lock/subsys/dictd ]; then
56         /etc/rc.d/init.d/dictd restart 1>&2
57 fi
58
59 %files
60 %defattr(644,root,root,755)
61 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/dictd/*.dictconf
62 %attr(755,root,root) %{_bindir}/sapdict
63 %{_datadir}/dictd/sap_*
This page took 0.06784 seconds and 4 git commands to generate.