]> git.pld-linux.org Git - packages/dict-sap.git/blob - dict-sap.spec
- new from scratch
[packages/dict-sap.git] / dict-sap.spec
1 Summary:        sap - English-Polish and vice versa dictionary for dictd
2 Name:           dict-sap
3 Version:        0.1b_0.1
4 Release:        1
5 License:        GPL
6 Group:          Applications/Dictionaries
7 Group(pl):      Aplikacje/S³owniki
8 Source:         %{name}-%{version}.tar.gz
9 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
10 BuildRequires:  /usr/bin/dictzip
11 BuildRequires:  /usr/bin/perl
12 Requires:       dictd
13 Requires:       %{_sysconfdir}/dictd
14 BuildArch:      noarch
15
16 %description 
17 This package contains sap - English-Polish and Polish-English
18 dictionary version 0.1b, formatted for use by the DICT server.
19
20 %prep
21 %setup -q
22
23 %build
24 %configure 
25 %{__make} db 
26
27 %install
28 rm -rf $RPM_BUILD_ROOT
29 install -d $RPM_BUILD_ROOT{%{_datadir}/dictd/,%{_bindir},%{_sysconfdir}/dictd}
30 %{__make} install DESTDIR=$RPM_BUILD_ROOT
31
32 for dictname in sap_en-pl sap_pl-en; do
33     dictprefix=%{_datadir}/dictd/$dictname
34     echo "# sap dictionary, part $dictname
35 database $dictname {
36     data  \"$dictprefix.dict.dz\"
37     index \"$dictprefix.index\"
38 }" > $RPM_BUILD_ROOT%{_sysconfdir}/dictd/$dictname.dictconf
39 done
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %postun
45 if [ -f /var/lock/subsys/dictd ]; then
46         /etc/rc.d/init.d/dictd restart 1>&2 || true
47 fi
48
49 %post
50 if [ -f /var/lock/subsys/dictd ]; then
51         /etc/rc.d/init.d/dictd restart 1>&2
52 fi
53
54 %files
55 %defattr(644,root,root,755)
56 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/dictd/*.dictconf
57 %attr(755,root,root) %{_bindir}/sapdict
58 %{_datadir}/dictd/sap_*
This page took 0.037257 seconds and 4 git commands to generate.