]> git.pld-linux.org Git - packages/dibbler.git/blob - dibbler.spec
- separate cilent
[packages/dibbler.git] / dibbler.spec
1 Summary:        Dibbler - a portable DHCPv6
2 Summary(pl):    Dibbler - przeno¶ny DHCPv6
3 Name:           dibbler
4 Version:        0.3.1
5 Release:        0.2
6 License:        GPL v2
7 Group:          Networking/Daemons
8 Source0:        http://klub.com.pl/dhcpv6/%{name}-%{version}-src.tar.gz
9 # Source0-md5:  6bc2b0932f1000ad50624789873115d8
10 Patch0:         %{name}-Makefile.patch
11 URL:            http://klub.com.pl/dhcpv6/
12 #BuildRequires: bison++ >= 1.21.9
13 BuildRequires:  chkconfig
14 BuildRequires:  flex
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  libxml2-devel
17 BuildRequires:  pkgconfig
18 #Provides:      dhcpd?
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Dibbler is a portable DHCPv6 implementation. It supports stateful
23 (i.e. IPv6 address granting) as well as stateless (i.e. option
24 granting) autoconfiguration for IPv6. Currently Linux 2.4/2.6 and
25 Windows XP and Windows 2003 ports are available. It features easy to
26 use install packages (Clickable Windows installer and RPM and DEB
27 packages for Linux) and extensive documentation (both for users as
28 well as developers).
29
30 %description -l pl
31 Dibbler to przeno¶na implementacja DHCPv6. Obs³uguje stanow± (tzn. z
32 nadawaniem adresów IPv6), jak i bezstanow± (tzn. z nadawaniem opcji)
33 autokonfiguracjê IPv6. Aktualnie dostêpne s± porty dla Linuksa 2.4/2.6
34 i Windows XP oraz Windows 2003. Zalety to ³atwa instalacja (klikalny
35 instalator pod Windows i pakiety RPM/DEB pod Linuksa) i wyczerpuj±ca
36 dokumentacja (zarówno dla u¿ytkowników, jak i programistów).
37
38 #%package doc
39 #Summary:       Documentation for Dibbler - a portable DHCPv6
40 #Summary(pl):   Dokumentacja dla Dibblera - przeno¶nego DHCPv6
41 #Group:         Documentation
42
43 #%description doc
44 #Documentation for Dibbler - a portable DHCPv6
45
46 #%description doc -l pl
47 #Dokumentacja dla Dibblera - przeno¶nego DHCPv6
48
49 %package client
50 Summary:        Dibbler DHCPv6 client
51 Summary(pl):    Dibbler - klient DHCPv6
52 Group:          Networking/Daemons
53
54 %description client
55 DHCPv6 protocol client.
56
57 %description client -l pl
58 Klient protokolu DHCPv6
59
60 %prep
61 %setup -q -n %{name}
62 %patch0 -p0
63
64 %build
65 %{__make} \
66         ARCH=LINUX \
67         CFLAGS="%{rpmcflags}" \
68         CPP="%{__cpp}" \
69         CXX="%{__cxx}" \
70         CC="%{__cc}" \
71         server \
72         client
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man8} \
77         $RPM_BUILD_ROOT{%{_sharedstatedir}/%{name},%{_sysconfdir}/%{name}}
78
79 install dibbler-{client,server} $RPM_BUILD_ROOT%{_sbindir}
80 install *.conf $RPM_BUILD_ROOT%{_sharedstatedir}/%{name}
81 install doc/man/* $RPM_BUILD_ROOT%{_mandir}/man8
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post
87 ln -s %{_sharedstatedir}/%{name}/server.conf %{_sysconfdir}/%{name}/server.conf
88 /sbin/chkconfig -add dibbler
89
90 %preun
91 if [ "$1" = "0" ];then
92         if [ -f /var/lock/subsys/dhcpd ]; then
93                 /etc/rc.d/init.d/dhcpd stop >&2
94         fi
95         /sbin/chkconfig --del dhcpd
96 fi
97
98 %post client
99 if [ -d %{_sharedstatedir}/%{name} ]; then
100 install -d %{_sharedstatedir}/%{name}
101 ln -s %{_sharedstatedir}/%{name}/client.conf %{_sysconfdir}/%{name}/client.conf
102 fi
103
104 %files
105 %defattr(644,root,root,755)
106 %doc CHANGELOG FUN LICENSE GUIDELINES RELNOTES TODO VERSION WILD-IDEAS 
107 %doc server.conf server-stateless.conf doc/man/dibbler-server.8
108 %attr(755,root,root) 
109 %{_sbindir}/dibbler-server
110 %dir %{_sharedstatedir}/%{name}
111 %config(noreplace) %verify(not md5 mtime size) %{_sharedstatedir}/%{name}/server.conf
112 %{_mandir}/man8/*.8*
113
114 %files client
115 %defattr(644,root,root,755)
116 %doc CHANGELOG FUN LICENSE GUIDELINES RELNOTES TODO VERSION WILD-IDEAS
117 %doc client.conf client-stateless.conf doc/man/dibbler-client.8
118 %{_sbindir}/dibbler-client
119 %dir %{_sharedstatedir}/%{name}
120 %config(noreplace) %verify(not md5 mtime size) %{_sharedstatedir}/%{name}/client.conf
121 %{_mandir}/man8/*.8*
122
123 #%files doc
124 #%defattr(644,root,root,755)
125 #%doc doc/*.blah
This page took 0.092607 seconds and 4 git commands to generate.