]> git.pld-linux.org Git - packages/dialog.git/commitdiff
- outdated
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 19 Feb 2006 12:23:39 +0000 (12:23 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    dialog-gcc34.patch -> 1.2
    dialog-manpath.patch -> 1.2
    dialog-menuborder.patch -> 1.2
    dialog-menumouse.patch -> 1.2
    dialog-opt.patch -> 1.2
    dialog-segv.patch -> 1.4
    dialog-shared.patch -> 1.3

dialog-gcc34.patch [deleted file]
dialog-manpath.patch [deleted file]
dialog-menuborder.patch [deleted file]
dialog-menumouse.patch [deleted file]
dialog-opt.patch [deleted file]
dialog-segv.patch [deleted file]
dialog-shared.patch [deleted file]

diff --git a/dialog-gcc34.patch b/dialog-gcc34.patch
deleted file mode 100644 (file)
index 4fb2d18..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
---- dialog-0.69/dialog.c.orig  2004-03-01 12:31:55.000000000 +0100
-+++ dialog-0.69/dialog.c       2004-03-01 12:57:10.716175104 +0100
-@@ -234,6 +234,7 @@
-       case DIALOG_YESNO:
-       case DIALOG_MSG:
-       case DIALOG_INFO:
-+      case DIALOG_TEXT: /* nothing to do */
-       /* nothing special to do */
-       break; 
-@@ -288,7 +289,6 @@
-       }
-       break;
--      case DIALOG_TEXT: /* nothing to do */
-     }
-     /*
diff --git a/dialog-manpath.patch b/dialog-manpath.patch
deleted file mode 100644 (file)
index 986931a..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
---- dialog-0.69/Makefile.in    Thu Jun 10 14:17:39 1999
-+++ dialog-0.69.pld/Makefile.in        Thu Jun 10 14:16:35 1999
-@@ -16,8 +16,8 @@
- MAN1EXT = 1
- MAN3EXT = 3
--MAN1DIR = $(prefix)/man/man$(MAN1EXT)
--MAN3DIR = $(prefix)/man/man$(MAN3EXT)
-+MAN1DIR = $(prefix)/share/man/man$(MAN1EXT)
-+MAN3DIR = $(prefix)/share/man/man$(MAN3EXT)
- srcdir = @srcdir@
- VPATH = @srcdir@
diff --git a/dialog-menuborder.patch b/dialog-menuborder.patch
deleted file mode 100644 (file)
index 44b33b9..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
-diff -Nur dialog-0.69.orig/dialogInt.h dialog-0.69/dialogInt.h
---- dialog-0.69.orig/dialogInt.h       Tue Jan 16 13:07:37 1996
-+++ dialog-0.69/dialogInt.h    Wed Oct 31 16:20:43 2001
-@@ -174,7 +174,14 @@
-                   wmove((win),(y),(x));        \
-                   waddch((win),ACS_UARROW); waddstr((win),"(-)"); } while (0)
--#define DIALOG_NOARROW(win,y,x) do { \
-+#define DIALOG_NODOWNARROW(win,y,x) do { \
-+                int i; \
-+                wattrset((win),menubox_border_attr); \
-+                wmove((win),(y),(x));         \
-+                for (i=0; i<4; i++)           \
-+                  waddch((win),ACS_HLINE); } while(0) 
-+
-+#define DIALOG_NOUPARROW(win,y,x) do { \
-                 int i; \
-                 wattrset((win),menubox_attr); \
-                 wmove((win),(y),(x));         \
-diff -Nur dialog-0.69.orig/list.c dialog-0.69/list.c
---- dialog-0.69.orig/list.c    Wed Oct 31 15:54:25 2001
-+++ dialog-0.69/list.c Wed Oct 31 16:20:57 2001
-@@ -337,11 +337,11 @@
-           if (first->prev)
-             DIALOG_UPARROW(dialog, box_y, box_x+check_x+3);
-           else
--            DIALOG_NOARROW(dialog, box_y, box_x+check_x+3);
-+            DIALOG_NOUPARROW(dialog, box_y, box_x+check_x+3);
-           if (last->next)
-             DIALOG_DOWNARROW(dialog, box_y+list_height+1, box_x+check_x+3);
-           else
--            DIALOG_NOARROW(dialog, box_y+list_height+1, box_x+check_x+3);
-+            DIALOG_NODOWNARROW(dialog, box_y+list_height+1, box_x+check_x+3);
-           
-       }
diff --git a/dialog-menumouse.patch b/dialog-menumouse.patch
deleted file mode 100644 (file)
index efa60e6..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Nur dialog-0.69.orig/list.c dialog-0.69/list.c
---- dialog-0.69.orig/list.c    Tue Jan 16 11:34:36 1996
-+++ dialog-0.69/list.c Wed Oct 31 15:54:25 2001
-@@ -235,7 +235,7 @@
-       if (!new) {
-           if ( (key>='1' && key<='9')
-               || (key>=DIALOG_M_EVENT && key-DIALOG_M_EVENT<' ') ) {
--              key -= (key>DIALOG_M_EVENT ? DIALOG_M_EVENT : '1');
-+              key -= (key>=DIALOG_M_EVENT ? DIALOG_M_EVENT : '1');
-               key=min(key,max_choice);
-               for (new=first; key && new->next; new=new->next)
-                 key--;
diff --git a/dialog-opt.patch b/dialog-opt.patch
deleted file mode 100644 (file)
index 0ddd52f..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
---- dialog-0.69/configure.in~  Wed Dec 20 20:47:11 2000
-+++ dialog-0.69/configure.in   Wed Dec 20 20:47:35 2000
-@@ -12,15 +12,6 @@
- LDFLAGS="-s"
- LIBS=""
--if test x$GCC = xyes
--  then
--   CFLAGS="-Wall -Wstrict-prototypes -fomit-frame-pointer -fno-strength-reduce"
--   OPTFLAGS="-O2"
--  else
--   CFLAGS=""
--   OPTFLAGS="-O" 
--fi
--
- DEBFLAGS="-g -DDEBUG_DIALOG"
- dnl ################################################################ GPM
diff --git a/dialog-segv.patch b/dialog-segv.patch
deleted file mode 100644 (file)
index 159e841..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
---- dialog-0.69.orig/dialog.c  Tue Jan 16 13:03:40 1996
-+++ dialog-0.69/dialog.c       Mon May 20 23:02:03 2002
-@@ -150,7 +150,7 @@
-           break; /* not found */
-     }
--    if (argc<3) {
-+    if (argc<3 || !optPtr) {
-         Usage (prgname);
-       exit(DIALOG_ERROR);
-     }
---- dialog-0.69.orig/text.c    Tue Jan 16 11:34:35 1996
-+++ dialog-0.69/text.c Mon May 20 23:03:23 2002
-@@ -35,10 +35,10 @@
- static char *buf, *page;
- /* Silly function, to remove duplicates */
--static int fatal(char *msg, int errno)
-+static int fatal(char *msg, int error)
- {
-   endwin();
--  fprintf(stderr,"dialog_textbox(): %s: %s\n",msg,strerror(errno));
-+  fprintf(stderr,"dialog_textbox(): %s: %s\n",msg,strerror(error));
-   exit(DIALOG_ERROR);
- }
---- dialog-0.69.orig/util.c    Tue Jan 16 11:34:35 1996
-+++ dialog-0.69/util.c Mon May 20 23:02:03 2002
-@@ -239,8 +239,8 @@
-       /*
-        * Ok, now fix width and height. Default to a margin of 3 on each side.
-        */
--      if (desc->c_wid==0) desc->c_wid=-3;
--      if (desc->c_hei==0) desc->c_hei=-3;
-+      if (desc->c_wid <= 0 || desc->c_wid > ws.ws_col) desc->c_wid=-3;
-+      if (desc->c_hei <= 0 || desc->c_hei > ws.ws_row) desc->c_hei=-3;
-       
-       desc->wid=desc->c_wid; desc->hei=desc->c_hei;
-       
diff --git a/dialog-shared.patch b/dialog-shared.patch
deleted file mode 100644 (file)
index b641163..0000000
+++ /dev/null
@@ -1,85 +0,0 @@
-diff -ur dialog-0.69.old/Makefile.in dialog-0.69/Makefile.in
---- dialog-0.69.old/Makefile.in        Tue Jan 16 13:32:48 1996
-+++ dialog-0.69/Makefile.in    Wed Apr 28 03:02:38 1999
-@@ -38,6 +38,7 @@
- INSTINC = $(INSTALL) -m 644
- INSTMAN = $(INSTALL) -m 644
-+LN_S = @LN_S@
- HDRS = $(TARGET).h colors.h
-@@ -46,14 +47,14 @@
- SRCS = $(OBJS:.o=.c)
--all: configure Makefile $(LIBRARY) $(TARGET) $(TARGET).1 demo
-+all: configure Makefile depend $(SHLIB) $(TARGET) $(LIBRARY) $(TARGET).1 demo
- # Use ranlib instead of "ar rcs" for portability
- $(LIBRARY): $(OBJS)
-       ar rc $@ $(OBJS)
-       ranlib $@
--$(TARGET): $(TARGET).o $(LIBRARY)
-+$(TARGET): $(TARGET).o $(SHLIB)
-       $(CC) $(CFLAGS) $(TARGET).o $(LDFLAGS) $(LIBS) -o $@ 
- $(TARGET).1: doc/doc.$(TARGET)
-@@ -69,7 +70,7 @@
- distclean: clean
-       rm config.* Makefile
--install: $(LIBRARY) $(TARGET)
-+install: $(SHLIB) $(TARGET) $(LIBRARY) 
-       -for n in $(BINDIR) $(LIBDIR) $(INCDIR) $(MAN1DIR) \
-                       $(MAN3DIR) $(INFDIR); do\
-               if [ -d $$n ]; then true; else \
-@@ -89,12 +90,9 @@
-       #install the shlib too, if any
-       if [ -f "$(SHLIB)" ]; then \
-               $(INSTALL) $(INSTBINFLAGS) $(SHLIB) $(LIBDIR); \
-+              $(LN_S) $(SHLIB_SO) $(LIBDIR)/lib$(TARGET).so; \
-               sync;\
-       fi
--      @-if [ -f "$(SHLIB)" ]; then \
--              echo "Running ldconfig"; \
--              ldconfig; \
--      fi
- #########################
-@@ -122,6 +120,7 @@
- $(SHLIB): $(SHLOBJS)
--      $(LDSHARED) -o $@ $(SHLOBJS)
-+      $(LDSHARED) -o $@ $(SHLOBJS) $(LIBS)
-+      $(LN_S) -f $(SHLIB_SO) lib$(TARGET).so 
- ######################### Generic targets and tasks
-@@ -171,3 +170,5 @@
- test:
-       $(MAKE) -C samples test DIALOG=`pwd`/dialog
-+
-+.PHONY:       configure Makefile depend $(SHLIB) $(TARGET) $(LIBRARY) mpage info $(TARGET).1 demo install clean distclean
-diff -ur dialog-0.69.old/configure.in dialog-0.69/configure.in
---- dialog-0.69.old/configure.in       Tue Jan 16 11:51:35 1996
-+++ dialog-0.69/configure.in   Wed Apr 28 03:02:24 1999
-@@ -4,6 +4,7 @@
- dnl      (1.x will complain)
- AC_INIT(dialog.c)
-+AC_PROG_LN_S
- AC_PROG_CC
- AC_PROG_CPP
- AC_PROG_INSTALL
-@@ -117,6 +118,7 @@
- AC_SUBST(CCSHARED)
- AC_SUBST(LDSHARED)
- AC_SUBST(SHLIB)
-+AC_SUBST(LN_S)
- if test "$SHLIB" = ""
-   then
This page took 0.093622 seconds and 4 git commands to generate.