]> git.pld-linux.org Git - packages/dialog.git/blob - dialog.spec
s/%{_target}/%{_target_platform}/
[packages/dialog.git] / dialog.spec
1 Summary:        A program to build tty dialog boxes
2 Summary(de):    Ein Programm zum Erstellen von tty-Dialogfeldern  
3 Summary(fr):    Programme pour construire des boîtes de dialogue en mode texte
4 Summary(pl):    Dialog tworzy okienkowy interfejs u¿ytkownika na terminalu tekstowym.
5 Summary(tr):    tty diyalog kutularý oluþturan bir program
6 Name:           dialog
7 Version:        0.69
8 Release:        1
9 Copyright:      GPL
10 Group:          Utilities/Terminal
11 Group(pl):      Narzêdzia/Terminal
12 Source:         ftp://iride.unipv.it/pub/linux/dialog/%{name}-%{version}.tar.gz
13 Patch0:         dialog-shared.patch
14 BuildPrereq:    ncurses-devel
15 BuildPrereq:    gpm-devel
16 Requires:       %{name}-libs = %{version}
17 Buildroot:      /tmp/%{name}-%{version}-root
18
19 %description
20 Dialog is a utility that allows you to build user interfaces in
21 a TTY (text mode only).  You can call dialog from within a shell
22 script to ask the user questions or present with choices in a more
23 user friendly manner.  See /usr/doc/dialog-*/samples for some
24 examples.
25
26 %description -l de
27 Dialog ist ein Dienstprogramm, das das Erstellen einer Benutzeroberfläche
28 in einem TTY ermöglicht (nur Textmodus). Sie können dialog mit einem
29 Shell-Script aufrufen, um dem Benutzer auf benutzerfreundliche Weise
30 Fragen zu stellen oder eine Auswahl anzubieten. Unter
31 /usr/src/examples/dialog-%{version} finden Sie einige Beispiele.
32
33 %description -l fr
34 dialog est un utilitaire permettant de construire des interfaces
35 utilisateur en mode texte. On peut appeler dialog à partir d'un
36 script shell pour poser des questions à l'utilisateur ou lui
37 proposer des choix de façon conviviale. 
38 Voir /usr/src/examples/dialog-%{version} pour quelques exemples.
39
40 %description -l pl
41 Dialog jest narzêdziem umo¿liwiaj±cym stworzenie przyjaznego interfejsu
42 u¿ytkownika na terminalu pracuj±cym w trybie tekstowym. Do programu
43 do³±czone s± przyk³adowe skrypty, u³atwiaj±ce rozpoczêcie pracy.
44
45 %description -l tr
46 Dialog, metin ekran için kullanýcý arayüzleri oluþturmayý saðlayan bir
47 araçtýr. Kullanýcýya seçenekleri göstermek veya sorular sormak için, dialog
48 programýný bir kabuk programcýðý içinden çaðýrabilirsiniz. Örnekler için
49 /usr/src/examples/dialog-%{version} dizinine bakýnýz.
50
51 %package libs
52 Summary:        Dialog library
53 Summary(pl):    Biblioteka dialog
54 Group:          Libraries
55 Group(pl):      Biblioteki
56
57 %description libs
58 Dialog library.
59
60 %description libs -l pl
61 Biblioteka dialog pozwala na stworzenie przyjaznego interfejsu
62 u¿ytkownika na terminalu pracuj±cym w trybie tekstowym.
63
64 %package devel
65 Summary:        Libraries and headers files for dialog
66 Summary(pl):    Biblioteki i pliki nagó³wkowe dla dialog
67 Group:          Development/Libraries
68 Group(pl):      Programowanie/Biblioteki
69 Requires:       %{name}-libs = %{version}
70
71 %description devel
72 Libraries and headers files for dialog.
73
74 %description devel -l pl
75 Biblioteki i pliki nagó³wkowe dla dialog.
76
77 %package static
78 Summary:        Static dialog library
79 Summary(pl):    Statyczna biblioteka dialog
80 Group:          Development/Libraries
81 Group(pl):      Programowanie/Biblioteki
82 Requires:       %{name}-devel = %{version}
83
84 %description static
85 Static dialog library.
86
87 %description static -l pl
88 Statyczna biblioteka dialog.
89
90 %prep
91 %setup  -q
92 %patch0 -p1 
93
94 %build
95 autoconf
96
97 CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
98 ./configure %{_target_platform} \
99         --prefix=/usr
100
101 make depend shared all
102
103 %install
104 rm -rf $RPM_BUILD_ROOT 
105 install -d $RPM_BUILD_ROOT/usr/{bin,man/man1,src/examples/%{name}-%{version}}
106
107 make prefix=$RPM_BUILD_ROOT/usr install
108
109 cp -a samples/* dialog.pl $RPM_BUILD_ROOT/usr/src/examples/%{name}-%{version}
110
111 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
112
113 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man*/* \
114         dialog.lsm README CMDLINE
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %files
120 %defattr(644,root,root,755)
121 %doc {dialog.lsm,README,CMDLINE}.gz
122 %attr(755,root,root) %{_bindir}/dialog
123 %{_mandir}/man1/*
124
125 %files libs
126 %defattr(644,root,root,755)
127 %attr(755,root,root) %{_libdir}/lib*.so.*.*
128
129 %files devel
130 %defattr(644,root,root,755)
131 %doc /usr/src/examples/%{name}-%{version}/checklist
132 %doc /usr/src/examples/%{name}-%{version}/gauge-sh
133 %doc /usr/src/examples/%{name}-%{version}/gauge.c
134 %doc /usr/src/examples/%{name}-%{version}/infobox
135 %doc /usr/src/examples/%{name}-%{version}/inputbox
136 %doc /usr/src/examples/%{name}-%{version}/menubox
137 %doc /usr/src/examples/%{name}-%{version}/msgbox
138 %doc /usr/src/examples/%{name}-%{version}/radiolist
139 %doc /usr/src/examples/%{name}-%{version}/textbox
140 %doc /usr/src/examples/%{name}-%{version}/yesno
141 %doc /usr/src/examples/%{name}-%{version}/README
142 %doc /usr/src/examples/%{name}-%{version}/Makefile
143 %doc %attr(755,root,root) /usr/src/examples/%{name}-%{version}/gauge
144
145 %attr(755,root,root) %{_libdir}/lib*.so
146 %{_includedir}/*
147 %{_mandir}/man3/*
148
149 %files static
150 %defattr(644,root,root,755)
151 %{_libdir}/lib*.a
152
153 %changelog
154 * Wed Apr 28 1999 Artur Frysiak <wiget@pld.org.pl>
155   [0.69-1]
156 - upgrade to 0.69
157 - changed source URL
158 - added libs, devel and static subpackage
159 - fixed coping samples
160
161 * Thu Apr 22 1999 Artur Frysiak <wiget@pld.org.pl>
162   [0.6-15]
163 - compiled on rpm 3
164 - gzipped docs
165 - samples moved to /usr/src/examples
166
167 * Sun Oct 18 1998 Marcin Korzonek <mkorz@shadow.eu.org>
168   [0.6-13]
169 - added pl translation,
170 - allow building from non root account,
171 - defined files permission,
172 - removed INSTALL and COPYING from docs,
173 - rewritten %install section.
174
175 * Thu May 7 1998 Michael Maher <mike@redhat.com> 
176 - Added Sean Reifschneider <jafo@tummy.com> patches for 
177   infinite loop problems.
178
179 * Fri Apr 24 1998 Prospector System <bugs@redhat.com>
180 - translations modified for de, fr, tr
181
182 * Wed Apr 15 1998 Erik Troan <ewt@redhat.com>
183 - built against new ncurses
184
185 * Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
186 - built against glibc
This page took 0.058824 seconds and 3 git commands to generate.