]> git.pld-linux.org Git - packages/dialog.git/blob - dialog.spec
86c80df1b247b2180769bfd797007b74ebb08d41
[packages/dialog.git] / dialog.spec
1 %define         ver   1.0
2 %define         sdate 20060221
3 Summary:        A program to build tty dialog boxes
4 Summary(de.UTF-8):      Ein Programm zum Erstellen von tty-Dialogfeldern
5 Summary(fr.UTF-8):      Programme pour construire des boîtes de dialogue en mode texte
6 Summary(pl.UTF-8):      Dialog tworzy okienkowy interfejs użytkownika na terminalu tekstowym
7 Summary(tr.UTF-8):      tty diyalog kutuları oluşturan bir program
8 Name:           dialog
9 Version:        %{ver}.%{sdate}
10 Release:        2
11 Epoch:          1
12 License:        LGPL v2.1
13 Group:          Applications/Terminal
14 Source0:        ftp://invisible-island.net/dialog/%{name}-%{ver}-%{sdate}.tgz
15 # Source0-md5:  acfd843163394e8bb17c841fdbe9c4a4
16 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
17 # Source1-md5:  932081790cd8aa857822bd2b0eafa5bb
18 Patch0:         %{name}-link.patch
19 Patch1:         %{name}-pl.po-update.patch
20 URL:            http://invisible-island.net/dialog/dialog.html
21 BuildRequires:  gettext-devel
22 BuildRequires:  ncurses-devel >= 5.4
23 BuildRequires:  libtool
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Dialog is a utility that allows you to build user interfaces in a TTY
28 (text mode only). You can call dialog from within a shell script to
29 ask the user questions or present with choices in a more user friendly
30 manner.
31
32 %description -l de.UTF-8
33 Dialog ist ein Dienstprogramm, das das Erstellen einer
34 Benutzeroberfläche in einem TTY ermöglicht (nur Textmodus). Sie können
35 dialog mit einem Shell-Script aufrufen, um dem Benutzer auf
36 benutzerfreundliche Weise Fragen zu stellen oder eine Auswahl
37 anzubieten. Unter %{_examplesdir}/%{name}-%{version} finden Sie
38 einige Beispiele.
39
40 %description -l fr.UTF-8
41 dialog est un utilitaire permettant de construire des interfaces
42 utilisateur en mode texte. On peut appeler dialog à partir d'un script
43 shell pour poser des questions à l'utilisateur ou lui proposer des
44 choix de façon conviviale. Voir %{_examplesdir}/%{name}-%{version}
45 pour quelques exemples.
46
47 %description -l pl.UTF-8
48 Dialog jest narzędziem umożliwiającym stworzenie przyjaznego
49 interfejsu użytkownika na terminalu pracującym w trybie tekstowym. Do
50 programu dołączone są przykładowe skrypty, ułatwiające rozpoczęcie
51 pracy.
52
53 %description -l tr.UTF-8
54 Dialog, metin ekran için kullanıcı arayüzleri oluşturmayı sağlayan bir
55 araçtır. Kullanıcıya seçenekleri göstermek veya sorular sormak için,
56 dialog programını bir kabuk programcığı içinden çağırabilirsiniz.
57 Örnekler için %{_examplesdir}/%{name}-%{version} dizinine bakınız.
58
59 %package devel
60 Summary:        Libraries and headers files for dialog
61 Summary(pl.UTF-8):      Biblioteki i pliki nagółwkowe dla dialog
62 Group:          Development/Libraries
63 Requires:       %{name} = %{epoch}:%{version}-%{release}
64 Requires:       ncurses-devel >= 5.4
65
66 %description devel
67 Libraries and header files for dialog.
68
69 %description devel -l pl.UTF-8
70 Biblioteki i pliki nagłówkowe dla dialog.
71
72 %package static
73 Summary:        Static dialog library
74 Summary(pl.UTF-8):      Statyczna biblioteka dialog
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
77
78 %description static
79 Static dialog library.
80
81 %description static -l pl.UTF-8
82 Statyczna biblioteka dialog.
83
84 %prep
85 %setup -q -n %{name}-%{ver}-%{sdate}
86 %patch0 -p1
87 %patch1 -p1
88
89 %build
90 %configure \
91         --with-libtool \
92         --with-ncursesw \
93         --enable-widec \
94         --enable-nls
95
96 %{__make}
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
101
102 %{__make} install \
103         DESTDIR=$RPM_BUILD_ROOT
104
105 cp -a samples/* dialog.pl $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
106
107 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
108
109 %find_lang %{name}
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post   -p /sbin/ldconfig
115 %postun -p /sbin/ldconfig
116
117 %files -f %{name}.lang
118 %defattr(644,root,root,755)
119 %doc CHANGES README
120 %attr(755,root,root) %{_bindir}/dialog
121 %attr(755,root,root) %{_libdir}/libdialog.so.*.*.*
122 %{_mandir}/man1/*
123 %lang(hu) %{_mandir}/hu/man1/*
124 %lang(pl) %{_mandir}/pl/man1/*
125
126 %files devel
127 %defattr(644,root,root,755)
128 %attr(755,root,root) %{_libdir}/libdialog.so
129 %{_libdir}/libdialog.la
130 %{_includedir}/*.h
131 %{_mandir}/man3/dialog.3*
132 %dir %{_examplesdir}/%{name}-%{version}
133 %{_examplesdir}/%{name}-%{version}/README
134 %{_examplesdir}/%{name}-%{version}/*.txt
135 %{_examplesdir}/%{name}-%{version}/*.??
136 %{_examplesdir}/%{name}-%{version}/install
137 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/[fgkmpry]*
138 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/copismall
139 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/ca*
140 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/checklist
141 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/checklist9
142 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/checklist[!9]*
143 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/in[fp]*
144 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/t[ai]*
145 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/tes*
146 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/textbox
147 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/textbox[0-9]
148 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/wheel
149 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/listing
150 %dir %{_examplesdir}/%{name}-%{version}/copifuncs
151 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/copifuncs/a*
152 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/copifuncs/com*
153 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/copifuncs/copi.[!t]*
154 %{_examplesdir}/%{name}-%{version}/copifuncs/copi.t*
155 %{_examplesdir}/%{name}-%{version}/copifuncs/ifpatch
156
157 %files static
158 %defattr(644,root,root,755)
159 %{_libdir}/libdialog.a
This page took 0.071026 seconds and 2 git commands to generate.