]> git.pld-linux.org Git - packages/diacanvas.git/blob - diacanvas.spec
- s/__FUNCTION__/__func__
[packages/diacanvas.git] / diacanvas.spec
1
2
3 %define src_name diacanvas2
4
5 Summary:        Library for easely creating diagrams
6 Summary(pl):    Biblioteka do prostego tworzenia diagramów
7 Name:           diacanvas
8 Version:        0.14.0
9 Release:        1
10 License:        GPL
11 Group:          X11/Libraries
12 Source0:        http://dl.sourceforge.net/diacanvas/%{src_name}-%{version}.tar.gz
13 # Source0-md5:  f00a9c023f51ffbaecc03f5f08d0d681
14 Patch0:         %{name}-no_check.patch
15 Patch1:         %{name}-text-stroke.patch
16 Patch2:         %{name}-func.patch
17 URL:            http://diacanvas.sourceforge.net/
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  libgnomeprintui-devel >= 2.2.0
21 BuildRequires:  libtool
22 # for canvas.defs
23 BuildRequires:  python-gnome-devel >= 2.0.0
24 BuildRequires:  python-pygtk-devel >= 1:2.0.0
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define pydefsdir %(pkg-config --variable=defsdir pygtk-2.0)
28
29 %description
30 Library for easy diagrams creation.
31
32 %description -l pl
33 Biblioteka do prostego tworzenia diagramów.
34
35 %package devel
36 Summary:        Diacanvas header files and development documentation
37 Summary(pl):    Pliki nag³ówkowe i dokumentacja biblioteki Diacanvas
38 Group:          X11/Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40
41 %description devel
42 Diacanvas header files and development documentation.
43
44 %description devel -l pl
45 Pliki nag³ówkowe i dokumentacja biblioteki Diacanvas.
46
47 %package static
48 Summary:        Diacanvas static libraries
49 Summary(pl):    Biblioteki statyczne Diacanvas
50 Group:          X11/Development/Libraries
51 Requires:       %{name}-devel = %{version}-%{release}
52
53 %description static
54 Diacanvas static libraries.
55
56 %description static -l pl
57 Biblioteki statyczne Diacanvas.
58
59 %package -n python-%{name}
60 Summary:        Diacanvas Python bindings
61 Summary(pl):    Wi±zania jêzyka Python do biblioteki Diacanvas
62 Group:          Libraries/Python
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       python-pygtk-gtk >= 1.99.16
65
66 %description -n python-%{name}
67 Diacanvas Python bindings.
68
69 %description -n python-%{name} -l pl
70 Wi±zania jêzyka Python do biblioteki Diacanvas.
71
72 %package -n python-%{name}-devel
73 Summary:        Diacanvas Python bindings development files
74 Summary(pl):    Pliki dla programistów wi±zañ jêzyka Python do biblioteki Diacanvas
75 Group:          Development/Languages/Python
76 Requires:       %{name} = %{version}-%{release}
77
78 %description -n python-%{name}-devel
79 Diacanvas Python bindings development files.
80
81 %description -n python-%{name}-devel -l pl
82 Pliki dla programistów wi±zañ jêzyka Python do biblioteki Diacanvas.
83
84 %prep
85 %setup -q -n %{src_name}-%{version}
86 %patch0 -p1
87 %patch1 -p1
88 %patch2 -p1
89
90 %build
91 glib-gettextize -f
92 %{__libtoolize}
93 %{__aclocal}
94 %{__autoconf}
95 %{__automake}
96 %configure \
97         --enable-static \
98         --enable-gnome-print \
99         --enable-python \
100         --with-html-dir=%{_gtkdocdir}
101
102 %{__make} \
103         pythondir=%{py_sitedir} \
104         pyexecdir=%{py_sitedir}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT \
111         pythondir=%{py_sitedir} \
112         pyexecdir=%{py_sitedir}
113
114 rm -f $RPM_BUILD_ROOT%{py_sitedir}/%{name}/*.{la,a}
115
116 %find_lang %{name}
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %post   -p /sbin/ldconfig
122 %postun -p /sbin/ldconfig
123
124 %files -f %{name}.lang
125 %defattr(644,root,root,755)
126 %doc README ChangeLog TODO NEWS AUTHORS
127 %attr(755,root,root) %{_libdir}/*.so.*.*.*
128
129 %files devel
130 %defattr(644,root,root,755)
131 %attr(755,root,root) %{_libdir}/*.so
132 %{_libdir}/*.la
133 %{_includedir}/diacanvas
134 %{_gtkdocdir}/%{src_name}
135 %{_pkgconfigdir}/*
136
137 %files static
138 %defattr(644,root,root,755)
139 %{_libdir}/*.a
140
141 %files -n python-%{name}
142 %defattr(644,root,root,755)
143 %dir %{py_sitedir}/%{name}
144 %attr(755,root,root) %{py_sitedir}/%{name}/*.so
145 %{py_sitedir}/%{name}/*.py[co]
146
147 %files -n python-%{name}-devel
148 %defattr(644,root,root,755)
149 %{pydefsdir}/*
This page took 0.110421 seconds and 3 git commands to generate.