]> git.pld-linux.org Git - packages/diacanvas.git/blob - diacanvas.spec
- ver. 0.14.3
[packages/diacanvas.git] / diacanvas.spec
1
2 %define         src_name        diacanvas2
3
4 Summary:        Library for easely creating diagrams
5 Summary(pl):    Biblioteka do prostego tworzenia diagramów
6 Name:           diacanvas
7 Version:        0.14.3
8 Release:        1
9 License:        GPL
10 Group:          X11/Libraries
11 Source0:        http://dl.sourceforge.net/diacanvas/%{src_name}-%{version}.tar.gz
12 # Source0-md5:  cc1dc41aff8084cb9e4514a0edbaf8b4
13 URL:            http://diacanvas.sourceforge.net/
14 BuildRequires:  libgnomeprintui-devel >= 2.2.0
15 BuildRequires:  libtool
16 BuildRequires:  pkgconfig
17 # for canvas.defs
18 BuildRequires:  python-gnome-devel >= 2.0.0
19 BuildRequires:  python-pygtk-devel >= 1:2.0.0
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         pydefsdir       %(pkg-config --variable=defsdir pygtk-2.0)
23
24 %description
25 Library for easy diagrams creation.
26
27 %description -l pl
28 Biblioteka do prostego tworzenia diagramów.
29
30 %package devel
31 Summary:        Diacanvas header files and development documentation
32 Summary(pl):    Pliki nag³ówkowe i dokumentacja biblioteki Diacanvas
33 Group:          X11/Development/Libraries
34 Requires:       %{name} = %{version}-%{release}
35
36 %description devel
37 Diacanvas header files and development documentation.
38
39 %description devel -l pl
40 Pliki nag³ówkowe i dokumentacja biblioteki Diacanvas.
41
42 %package static
43 Summary:        Diacanvas static libraries
44 Summary(pl):    Biblioteki statyczne Diacanvas
45 Group:          X11/Development/Libraries
46 Requires:       %{name}-devel = %{version}-%{release}
47
48 %description static
49 Diacanvas static libraries.
50
51 %description static -l pl
52 Biblioteki statyczne Diacanvas.
53
54 %package -n python-%{name}
55 Summary:        Diacanvas Python bindings
56 Summary(pl):    Wi±zania jêzyka Python do biblioteki Diacanvas
57 Group:          Libraries/Python
58 Requires:       %{name} = %{version}-%{release}
59 %pyrequires_eq  python-libs
60 Requires:       python-pygtk-gtk >= 1.99.16
61
62 %description -n python-%{name}
63 Diacanvas Python bindings.
64
65 %description -n python-%{name} -l pl
66 Wi±zania jêzyka Python do biblioteki Diacanvas.
67
68 %package -n python-%{name}-devel
69 Summary:        Diacanvas Python bindings development files
70 Summary(pl):    Pliki dla programistów wi±zañ jêzyka Python do biblioteki Diacanvas
71 Group:          Development/Languages/Python
72 Requires:       %{name} = %{version}-%{release}
73
74 %description -n python-%{name}-devel
75 Diacanvas Python bindings development files.
76
77 %description -n python-%{name}-devel -l pl
78 Pliki dla programistów wi±zañ jêzyka Python do biblioteki Diacanvas.
79
80 %prep
81 %setup -q -n %{src_name}-%{version}
82
83 %build
84 %configure \
85         --enable-static \
86         --enable-gnome-print \
87         --enable-python \
88         --enable-gtk-doc \
89         --with-html-dir=%{_gtkdocdir}
90
91 %{__make}
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95
96 %{__make} install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
100 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
101 %py_postclean
102 rm -f $RPM_BUILD_ROOT%{py_sitedir}/%{name}/*.{la,a}
103
104 %find_lang %{name}
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %post   -p /sbin/ldconfig
110 %postun -p /sbin/ldconfig
111
112 %files -f %{name}.lang
113 %defattr(644,root,root,755)
114 %doc README ChangeLog TODO NEWS AUTHORS
115 %attr(755,root,root) %{_libdir}/*.so.*.*.*
116
117 %files devel
118 %defattr(644,root,root,755)
119 %attr(755,root,root) %{_libdir}/*.so
120 %{_libdir}/*.la
121 %{_includedir}/diacanvas
122 %{_gtkdocdir}/%{src_name}
123 %{_pkgconfigdir}/*
124
125 %files static
126 %defattr(644,root,root,755)
127 %{_libdir}/*.a
128
129 %files -n python-%{name}
130 %defattr(644,root,root,755)
131 %dir %{py_sitedir}/%{name}
132 %attr(755,root,root) %{py_sitedir}/%{name}/*.so
133 %{py_sitedir}/%{name}/*.py[co]
134
135 %files -n python-%{name}-devel
136 %defattr(644,root,root,755)
137 %{pydefsdir}/*
This page took 0.09365 seconds and 3 git commands to generate.