]> git.pld-linux.org Git - packages/diacanvas.git/blob - diacanvas.spec
- converted to UTF-8
[packages/diacanvas.git] / diacanvas.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs     # disable gtk-doc
4 %bcond_without  static_libs # don't build static library
5
6 %define         src_name        diacanvas2
7
8 Summary:        Library for easely creating diagrams
9 Summary(pl.UTF-8):   Biblioteka do prostego tworzenia diagramów
10 Name:           diacanvas
11 Version:        0.14.4
12 Release:        1
13 License:        GPL
14 Group:          X11/Libraries
15 Source0:        http://dl.sourceforge.net/diacanvas/%{src_name}-%{version}.tar.gz
16 # Source0-md5:  b3db6c961de3023489a4d2419dab89bd
17 URL:            http://diacanvas.sourceforge.net/
18 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.0}
19 BuildRequires:  libgnomeprintui-devel >= 2.2.0
20 BuildRequires:  libtool
21 BuildRequires:  pkgconfig
22 # for canvas.defs
23 BuildRequires:  python-gnome-devel >= 2.0.0
24 BuildRequires:  python-pygtk-devel >= 1:2.0.0
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         pydefsdir       %(pkg-config --variable=defsdir pygtk-2.0)
28
29 %description
30 Library for easy diagrams creation.
31
32 %description -l pl.UTF-8
33 Biblioteka do prostego tworzenia diagramów.
34
35 %package devel
36 Summary:        Diacanvas header files and development documentation
37 Summary(pl.UTF-8):   Pliki nagłówkowe i dokumentacja biblioteki Diacanvas
38 Group:          X11/Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40
41 %description devel
42 Diacanvas header files and development documentation.
43
44 %description devel -l pl.UTF-8
45 Pliki nagłówkowe i dokumentacja biblioteki Diacanvas.
46
47 %package static
48 Summary:        Diacanvas static libraries
49 Summary(pl.UTF-8):   Biblioteki statyczne Diacanvas
50 Group:          X11/Development/Libraries
51 Requires:       %{name}-devel = %{version}-%{release}
52
53 %description static
54 Diacanvas static libraries.
55
56 %description static -l pl.UTF-8
57 Biblioteki statyczne Diacanvas.
58
59 %package apidocs
60 Summary:        Diacanvas API documentation
61 Summary(pl.UTF-8):   Dokumentacja API Diacanvas
62 Group:          Documentation
63 Requires:       gtk-doc-common
64
65 %description apidocs
66 Diacanvas API documentation.
67
68 %description apidocs -l pl.UTF-8
69 Dokumentacja API Diacanvas.
70
71 %package -n python-%{name}
72 Summary:        Diacanvas Python bindings
73 Summary(pl.UTF-8):   Wiązania języka Python do biblioteki Diacanvas
74 Group:          Libraries/Python
75 Requires:       %{name} = %{version}-%{release}
76 %pyrequires_eq  python-libs
77 Requires:       python-pygtk-gtk >= 1.99.16
78
79 %description -n python-%{name}
80 Diacanvas Python bindings.
81
82 %description -n python-%{name} -l pl.UTF-8
83 Wiązania języka Python do biblioteki Diacanvas.
84
85 %package -n python-%{name}-devel
86 Summary:        Diacanvas Python bindings development files
87 Summary(pl.UTF-8):   Pliki dla programistów wiązań języka Python do biblioteki Diacanvas
88 Group:          Development/Languages/Python
89 Requires:       %{name} = %{version}-%{release}
90
91 %description -n python-%{name}-devel
92 Diacanvas Python bindings development files.
93
94 %description -n python-%{name}-devel -l pl.UTF-8
95 Pliki dla programistów wiązań języka Python do biblioteki Diacanvas.
96
97 %prep
98 %setup -q -n %{src_name}-%{version}
99
100 %build
101 %configure \
102         --%{?with_static_libs:en}%{!?with_static_libs:dis}able-static \
103         --enable-gnome-print \
104         --enable-python \
105         --%{?with_apidocs:en}%{!?with_apidocs:dis}able-gtk-doc \
106         %{?with_apidocs:--with-html-dir=%{_gtkdocdir}}
107
108 %{__make}
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112
113 %{__make} install \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
117 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
118 %py_postclean
119 rm -f $RPM_BUILD_ROOT%{py_sitedir}/%{name}/*.{la,a}
120
121 %find_lang %{name}
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post   -p /sbin/ldconfig
127 %postun -p /sbin/ldconfig
128
129 %files -f %{name}.lang
130 %defattr(644,root,root,755)
131 %doc README ChangeLog TODO NEWS AUTHORS
132 %attr(755,root,root) %{_libdir}/*.so.*.*.*
133
134 %files devel
135 %defattr(644,root,root,755)
136 %attr(755,root,root) %{_libdir}/*.so
137 %{_libdir}/*.la
138 %{_includedir}/diacanvas
139 %{_pkgconfigdir}/*
140
141 %if %{with static_libs}
142 %files static
143 %defattr(644,root,root,755)
144 %{_libdir}/lib*.a
145 %endif
146
147 %if %{with apidocs}
148 %files apidocs
149 %defattr(644,root,root,755)
150 %{_gtkdocdir}/*
151 %endif
152
153 %files -n python-%{name}
154 %defattr(644,root,root,755)
155 %dir %{py_sitedir}/%{name}
156 %attr(755,root,root) %{py_sitedir}/%{name}/*.so
157 %{py_sitedir}/%{name}/*.py[co]
158
159 %files -n python-%{name}-devel
160 %defattr(644,root,root,755)
161 %{pydefsdir}/*
This page took 1.48777 seconds and 3 git commands to generate.