]> git.pld-linux.org Git - packages/dhcpv6.git/blob - dhcpv6.spec
- release 2
[packages/dhcpv6.git] / dhcpv6.spec
1 Summary:        DHCPv6 - DHCP server and client for IPv6
2 Summary(pl.UTF-8):      DHCPv6 - serwer i klient DHCP dla IPv6
3 Name:           dhcpv6
4 Version:        1.2.0
5 Release:        2
6 Epoch:          1
7 License:        GPL v2+
8 Group:          Networking/Daemons
9 Source0:        https://fedorahosted.org/releases/d/h/dhcpv6/%{name}-%{version}.tar.gz
10 # Source0-md5:  d537416b33002f56912b7f27477d8d35
11 Source1:        dhcp6s.init
12 Source2:        dhcp6c.init
13 URL:            https://fedorahosted.org/dhcpv6/
14 BuildRequires:  autoconf >= 2.61
15 BuildRequires:  automake
16 BuildRequires:  bison
17 BuildRequires:  flex
18 BuildRequires:  libnl-devel >= 1.1
19 BuildRequires:  libtool
20 BuildRequires:  pkgconfig
21 BuildRequires:  rpmbuild(macros) >= 1.268
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Implements the Dynamic Host Configuration Protocol (DHCP) for Internet
26 Protocol version 6 (IPv6) networks in accordance with RFC 3315:
27 Dynamic Host Configuration Protocol for IPv6 (DHCPv6).
28
29 %description -l pl.UTF-8
30 Ten pakiet jest implementacją protokołu Dynamic Host Configuration
31 Protocol (DHCP) dla sieci IPv6 zgodnie z RFC 3315: Dynamic Host
32 Configuration Protocol for IPv6 (DHCPv6).
33
34 %package client
35 Summary:        DHCPv6 client
36 Summary(pl.UTF-8):      Klient DHCPv6
37 Group:          Applications/Networking
38 Requires(post,preun):   /sbin/chkconfig
39 Requires:       rc-scripts
40
41 %description client
42 Provides the client for the DHCPv6 protocol (RFC 3315) to support
43 dynamic configuration of IPv6 addresses and parameters.
44
45 %description client -l pl.UTF-8
46 Ten pakiet dostarcza klienta protokołu DHCPv6 (RFC 3315) do obsługi
47 dynamicznej konfiguracji adresów i parametrów sieci iPv6.
48
49 %package relay
50 Summary:        DHCPv6 relay agent
51 Summary(pl.UTF-8):      Agent przekazujący DHCPv6
52 Group:          Applications/Networking
53 Requires(post,preun):   /sbin/chkconfig
54 Requires:       rc-scripts
55
56 %description relay
57 dhcp6r acts as DHCPv6 relay agent forwarding DHCPv6 messages from
58 clients to servers and vice versa.
59
60 %description relay -l pl.UTF-8
61 dhcp6r służy jako agent przekazujący komunikaty DHCPv6 od klientów do
62 serwerów i z powrotem.
63
64 %package server
65 Summary:        DHCPv6 server daemon
66 Summary(pl.UTF-8):      Demon serwera DHCPv6
67 Group:          Applications/Networking
68 Requires(post,preun):   /sbin/chkconfig
69 Requires:       rc-scripts
70
71 %description server
72 dhcp6s is an implementation of the DHCPv6 server.
73
74 %description server -l pl.UTF-8
75 dhcp6s to implementacja serwera DHCPv6.
76
77 %prep
78 %setup -q
79
80 %build
81 %{__libtoolize}
82 %{__aclocal} -I m4
83 %{__autoconf}
84 %{__automake}
85 %configure
86
87 %{__make}
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 install -d $RPM_BUILD_ROOT{%{_localstatedir}/lib/dhcpv6,/etc/{rc.d/init.d,sysconfig}}
92
93 %{__make} install \
94         INSTALL_USER=$(id -u) \
95         INSTALL_GROUP=$(id -g) \
96         DESTDIR=$RPM_BUILD_ROOT
97
98 install %{SOURCE1}      $RPM_BUILD_ROOT/etc/rc.d/init.d/dhcp6s
99 install %{SOURCE2}      $RPM_BUILD_ROOT/etc/rc.d/init.d/dhcp6c
100
101 mkdir -p $RPM_BUILD_ROOT/var/run/dhcpv6
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post client
107 /sbin/chkconfig --add dhcp6c
108 %service dhcp6c restart
109
110 %post relay
111 /sbin/chkconfig --add dhcp6r
112 %service dhcp6r restart
113
114 %post server
115 /sbin/chkconfig --add dhcp6s
116 %service dhcp6s restart
117
118 %preun client
119 if [ "$1" = "0" ]; then
120         %service dhcp6c stop
121         /sbin/chkconfig --del dhcp6c
122 fi
123
124 %preun relay
125 if [ "$1" = "0" ]; then
126         %service dhcp6r stop
127         /sbin/chkconfig --del dhcp6r
128 fi
129
130 %preun server
131 if [ "$1" = "0" ]; then
132         %service dhcp6s stop
133         /sbin/chkconfig --del dhcp6s
134 fi
135
136 %files client
137 %defattr(644,root,root,755)
138 %attr(755,root,root) %{_sbindir}/dhcp6c
139 %attr(754,root,root) /etc/rc.d/init.d/dhcp6c
140 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dhcp6c.conf
141 %{_mandir}/man8/dhcp6c.8*
142 %{_mandir}/man5/dhcp6c.conf.5*
143
144 %files relay
145 %defattr(644,root,root,755)
146 %attr(755,root,root) %{_sbindir}/dhcp6r
147 %attr(754,root,root) /etc/rc.d/init.d/dhcp6r
148 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/dhcp6r
149 %{_mandir}/man8/dhcp6r.8*
150
151 %files server
152 %defattr(644,root,root,755)
153 %doc AUTHORS README TODO
154 %attr(755,root,root) %{_sbindir}/dhcp6s
155 %attr(754,root,root) /etc/rc.d/init.d/dhcp6s
156 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/dhcp6s
157 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dhcp6s.conf
158 %{_mandir}/man8/dhcp6s.8*
159 %{_mandir}/man5/dhcp6s.conf.5*
160 %attr(750,root,root) %dir %{_localstatedir}/lib/dhcpv6
161 %attr(755,root,root) %dir %{_localstatedir}/run/dhcpv6
This page took 0.20432 seconds and 3 git commands to generate.