]> git.pld-linux.org Git - packages/dhcpv6.git/blob - dhcpv6.spec
28c5e7cced3e58414d77dcd8f94da55180a1a6ee
[packages/dhcpv6.git] / dhcpv6.spec
1 # TODO:
2 # - new .sysconfig files
3 # - test it
4 Summary:        DHCPv6 - DHCP server and client for IPv6
5 Summary(pl):    DHCPv6 - serwer i klient DHCP dla IPv6
6 Name:           dhcpv6
7 Version:        0.10
8 Release:        0.6
9 Epoch:          1
10 License:        GPL
11 Group:          Networking/Daemons
12 Source0:        http://dl.sourceforge.net/dhcpv6/dhcp-%{version}.tgz
13 # Source0-md5:  72b802d6c89e15e5cf6b0aecf46613f2
14 Source1:        dhcp6s.init
15 Source2:        dhcp6c.init
16 Patch0:         %{name}-initscripts.patch
17 Patch1:         %{name}-DESTDIR.patch
18 Patch2:         %{name}-Makefile.patch
19 URL:            http://dhcpv6.sourceforge.net/
20 BuildRequires:  bison
21 BuildRequires:  flex
22 Requires(post,preun):   /sbin/chkconfig
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Implements the Dynamic Host Configuration Protocol (DHCP) for Internet
27 Protocol version 6 (IPv6) networks in accordance with RFC 3315 :
28 Dynamic Host Configuration Protocol for IPv6 (DHCPv6). Consists of
29 dhcp6s(8), the server DHCP daemon. Install this if you want to support
30 dynamic configuration of IPv6 addresses and parameters on your IPv6
31 network. See man dhcp6s(8), dhcp6s.conf(5), and the documentation in
32 /usr/share/doc/dhcpv6* .
33
34 %description -l pl
35 Ten pakiet jest implementacj± protoko³u Dynamic Host Configuration
36 Protocol (DHCP) dla sieci IPv6 zgodnie z RFC 3315: Dynamic Host
37 Configuration Protocol for IPv6 (DHCPv6). Zawiera demona serwera DHCP
38 - dhcp6s(8). Nale¿y zainstalowaæ ten pakiet, je¶li potrzebujemy
39 obs³ugi dynamicznej konfiguracji adresów i parametrów sieci IPv6.
40 Wiêcej znajduje siê w manualach dhcp6s(8), dhcp6s.conf(5) oraz
41 dokumentacji w /usr/share/doc/dhcpv6* .
42
43 %package -n dhcpv6_client
44 Summary:        DHCPv6 client
45 Summary(pl):    Klient DHCPv6
46 Group:          Applications/Networking
47 Requires:       initscripts >= 7.73
48
49 %description -n dhcpv6_client
50 Provides the client for the DHCPv6 protocol (RFC 3315) to support
51 dynamic configuration of IPv6 addresses and parameters. See man
52 dhcp6c(8), dhcp6c.conf(5), and the documentation in
53 /usr/share/doc/dhcpv6_client* .
54
55 %description -n dhcpv6_client -l pl
56 Ten pakiet dostarcza klienta protoko³u DHCPv6 (RFC 3315) do obs³ugi
57 dynamicznej konfiguracji adresów i parametrów sieci iPv6. Wiêcej
58 znajduje siê w manualu dhcp6c(8), dhcp6c.conf(5) oraz dokumentacji w
59 /usr/share/doc/dhcpv6_client*
60
61 %prep
62 %setup -q -n dhcp-%{version}
63 %patch0 -p1
64 %patch1 -p1
65 %patch2 -p1
66
67 %build
68 %configure \
69         --prefix= \
70         --mandir=%{_mandir}
71
72 %{__make}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76 install -d $RPM_BUILD_ROOT{%{_localstatedir}/lib/dhcpv6,/etc/rc.d/init.d}
77
78 %{__make} install \
79         DESTDIR=$RPM_BUILD_ROOT
80
81 install dhcp6relay.8    $RPM_BUILD_ROOT%{_mandir}/man8
82 install %{SOURCE1}      $RPM_BUILD_ROOT/etc/rc.d/init.d/dhcp6s
83 install %{SOURCE2}      $RPM_BUILD_ROOT/etc/rc.d/init.d/dhcp6c
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %post
89 /sbin/chkconfig --add dhcp6s
90
91 %preun
92 if [ "$1" = "0" ]; then
93         /etc/rc.d/init.d/dhcp6s stop >/dev/null 2>&1
94         /sbin/chkconfig --del dhcp6s
95 fi
96
97 %postun
98 if [ "$1" -ge "1" ]; then
99         /etc/rc.d/init.d/dhcp6s condrestart >/dev/null 2>&1
100 fi
101
102 %files
103 %defattr(644,root,root,755)
104 %doc ReadMe docs/* 
105 %attr(755,root,root) %{_sbindir}/dhcp6s
106 %attr(754,root,root) /etc/rc.d/init.d/dhcp6s
107 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/dhcp6s
108 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dhcp6s.conf
109 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/server6_addr.conf
110 %attr(750,root,root) %dir %{_localstatedir}/lib/dhcpv6
111 %{_mandir}/man8/dhcp6s.8*
112 %{_mandir}/man8/dhcp6relay.8*
113 %{_mandir}/man5/dhcp6s.conf.5*
114
115
116 %files -n dhcpv6_client
117 %defattr(644,root,root,755)
118 %doc ReadMe dhcp6c.conf
119 %attr(755,root,root) %{_sbindir}/dhcp6c
120 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/dhcp6c
121 %attr(754,root,root) /etc/rc.d/init.d/dhcp6c
122 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/dhcp6c.conf
123 %{_mandir}/man8/dhcp6c.8*
124 %{_mandir}/man5/dhcp6c.conf.5*
This page took 0.053294 seconds and 2 git commands to generate.