]> git.pld-linux.org Git - packages/dhcp.git/commitdiff
- up to 4.0.2 DHCP_4_0 auto/th/dhcp-4_0_2-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 27 Apr 2010 10:40:42 +0000 (10:40 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    dhcp-arg-concat.patch -> 1.2
    dhcp-dhclient-anycast.patch -> 1.2
    dhcp-memory.patch -> 1.2
    dhcp-no-ipv6.patch -> 1.2
    dhcp-options.patch -> 1.5
    dhcp.spec -> 1.176

dhcp-arg-concat.patch [deleted file]
dhcp-dhclient-anycast.patch
dhcp-memory.patch
dhcp-no-ipv6.patch [deleted file]
dhcp-options.patch
dhcp.spec

diff --git a/dhcp-arg-concat.patch b/dhcp-arg-concat.patch
deleted file mode 100644 (file)
index 243c708..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- dhcp-3.1.0a1/common/print.c~       2006-08-01 00:19:51.000000000 +0200
-+++ dhcp-3.1.0a1/common/print.c        2006-10-26 14:05:03.000000000 +0200
-@@ -1130,6 +1130,7 @@
-               len = strlen (s);
-               strcpy (u, s);
-               u += len;
-+              s = va_arg (list, char *);
-       }
-       va_end (list);
-       
index 508f0aa81e935dc49ab491c231b1944f61b515f4..3a55c426e30fd7a5a94e06fbd8deb4b1c42b1839 100644 (file)
@@ -38,9 +38,9 @@ diff -up dhcp-4.0.0/includes/dhctoken.h.anycast dhcp-4.0.0/includes/dhctoken.h
 --- dhcp-4.0.0/includes/dhctoken.h.anycast     2007-12-29 06:44:46.000000000 -1000
 +++ dhcp-4.0.0/includes/dhctoken.h     2007-12-29 10:44:00.000000000 -1000
 @@ -346,7 +346,8 @@ enum dhcp_token {
-       WHITESPACE = 649,
        TOKEN_ALSO = 650,
        AFTER = 651,
+       CONFLICT_DONE = 660,
 -      BOOTP_BROADCAST_ALWAYS = 652
 +      BOOTP_BROADCAST_ALWAYS = 652,
 +      ANYCAST_MAC = 653
index c08a429108374489b080f208d402d9b3fb15bd92..04cfe17f04f72f457e124ff8311a0cb2e2052844 100644 (file)
@@ -1,18 +1,3 @@
-diff -up dhcp-3.0.6/minires/ns_name.c.memory dhcp-3.0.6/minires/ns_name.c
---- dhcp-3.0.6/minires/ns_name.c.memory        2004-06-10 13:59:40.000000000 -0400
-+++ dhcp-3.0.6/minires/ns_name.c       2007-07-10 11:43:29.000000000 -0400
-@@ -71,6 +71,11 @@ ns_name_ntop(const u_char *src, char *ds
-       dn = dst;
-       eom = dst + dstsiz;
-+      if (dn >= eom) {
-+              errno = EMSGSIZE;
-+              return (-1);
-+      }
-+
-       while ((n = *cp++) != 0) {
-               if ((n & NS_CMPRSFLGS) != 0) {
-                       /* Some kind of compression pointer. */
 diff -up dhcp-3.0.6/common/packet.c.memory dhcp-3.0.6/common/packet.c
 --- dhcp-3.0.6/common/packet.c.memory  2007-05-01 16:42:55.000000000 -0400
 +++ dhcp-3.0.6/common/packet.c 2007-07-10 11:43:29.000000000 -0400
diff --git a/dhcp-no-ipv6.patch b/dhcp-no-ipv6.patch
deleted file mode 100644 (file)
index 28952c9..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
---- a/common/discover.c~       2008-09-09 22:29:01.326643118 +0200
-+++ a/common/discover.c        2008-09-09 22:34:07.565778860 +0200
-@@ -421,6 +421,7 @@ begin_iface_scan(struct iface_conf_list 
-       }
- #ifdef DHCPv6
-+      if (local_family == AF_INET6) {
-       ifaces->fp6 = fopen("/proc/net/if_inet6", "r");
-       if (ifaces->fp6 == NULL) {
-               log_error("Error opening '/proc/net/if_inet6' to "
-@@ -431,6 +432,7 @@ begin_iface_scan(struct iface_conf_list 
-               ifaces->fp = NULL;
-               return 0;
-       }
-+      }
- #endif
-       return 1;
-@@ -700,9 +700,11 @@ next_iface(struct iface_info *info, int 
-               return 1;
-       }
- #ifdef DHCPv6
-+      if (local_family == AF_INET6) {
-       if (!(*err)) {
-               return next_iface6(info, err, ifaces);
-       }
-+      }
- #endif
-       return 0;
- }
-@@ -719,7 +719,8 @@ end_iface_scan(struct iface_conf_list *i
-       close(ifaces->sock);
-       ifaces->sock = -1;
- #ifdef DHCPv6
--      fclose(ifaces->fp6);
-+      if (local_family == AF_INET6)
-+              fclose(ifaces->fp6);
-       ifaces->fp6 = NULL;
- #endif
- }
index 019d99cbe0ec562eb8de3d4207910d66795c85d0..cda71dfc1184ab84011dcfb22c0ad020f071ebb0 100644 (file)
@@ -27,11 +27,11 @@ diff -up dhcp-4.0.0/includes/dhctoken.h.options dhcp-4.0.0/includes/dhctoken.h
 --- dhcp-4.0.0/includes/dhctoken.h.options     2007-10-31 09:13:33.000000000 -1000
 +++ dhcp-4.0.0/includes/dhctoken.h     2007-12-29 11:13:51.000000000 -1000
 @@ -345,7 +345,8 @@ enum dhcp_token {
-       RANGE6 = 648,
        WHITESPACE = 649,
        TOKEN_ALSO = 650,
--      AFTER = 651
-+      AFTER = 651,
+       AFTER = 651,
+-      CONFLICT_DONE = 660
++      CONFLICT_DONE = 660,
 +      BOOTP_BROADCAST_ALWAYS = 652
  };
  
index a25f01d8e72b03f8ea22984bf7fdcbf646bb8c54..a2c494827e45d0a225a5534969228c5f888972c3 100644 (file)
--- a/dhcp.spec
+++ b/dhcp.spec
@@ -12,13 +12,13 @@ Summary(pl.UTF-8):  Serwer DHCP
 Summary(pt_BR.UTF-8):  Servidor DHCP (Protocolo de configuração dinâmica de hosts)
 Name:          dhcp
 # 4.1.0a1 is on DEVEL
-Version:       4.0.1p1
-Release:       3
+Version:       4.0.2
+Release:       1
 Epoch:         4
 License:       MIT
 Group:         Networking/Daemons
 Source0:       ftp://ftp.isc.org/isc/dhcp/%{name}-%{version}.tar.gz
-# Source0-md5: 42bac85e1513e177c6bb2bf64d448dbe
+# Source0-md5: f8d35ade3727429b1ab74c26058bd6b1
 Source1:       %{name}.init
 Source2:       %{name}6.init
 Source3:       %{name}-relay.init
@@ -38,7 +38,6 @@ Patch0:               %{name}-release-by-ifup.patch
 Patch1:                %{name}-ldap.patch
 Patch2:                %{name}-3.0.3-x-option.patch
 Patch3:                %{name}-paths.patch
-Patch4:                %{name}-arg-concat.patch
 Patch5:                %{name}-timeouts.patch
 Patch6:                %{name}-options.patch
 Patch7:                %{name}-libdhcp4client.patch
@@ -55,7 +54,6 @@ Patch17:      %{name}-xen-checksum.patch
 Patch18:       %{name}-dhclient-anycast.patch
 Patch19:       %{name}-manpages.patch
 Patch20:       %{name}-NetworkManager-crash.patch
-Patch21:       %{name}-no-ipv6.patch
 URL:           http://www.isc.org/sw/dhcp/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -226,7 +224,6 @@ Statyczna biblioteka kliencka DHCP.
 # however, fedora doesn't have this patch anymore, so can drop?
 #%%patch2 -p1
 %patch3 -p1
-%patch4 -p1
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
@@ -243,7 +240,6 @@ Statyczna biblioteka kliencka DHCP.
 %patch18 -p1
 %patch19 -p1
 %patch20 -p1
-%patch21 -p1
 
 # Copy in documentation and example scripts for LDAP patch to dhcpd
 cp -a %{SOURCE11} README.ldap
This page took 0.11185 seconds and 4 git commands to generate.