]> git.pld-linux.org Git - packages/dgee.git/blob - dgee.spec
- apache compilation fixes
[packages/dgee.git] / dgee.spec
1 # TODO:
2 # - pnet incompatability, see -pnet.patch
3 #
4 # Conditional build:
5 %bcond_without  apache1         # disable building apache 1.3.x module
6 %bcond_without  apache2         # disable building apache 2.x module
7 #
8 %define         apxs1           /usr/sbin/apxs1
9 %define         apxs2           /usr/sbin/apxs
10 %define         subver          2
11 %define         base_version    0.1.6
12 Summary:        The DotGNU Execution Environment Core
13 Summary(pl):    Podstawa ¶rodowiska wykonawczego DotGNU
14 Name:           dgee
15 Version:        %{base_version}_%{subver}
16 Release:        2.2
17 License:        GPL
18 Group:          Networking/Daemons
19 Source0:        http://www.nfluid.com/download/src/%{name}-%{base_version}-%{subver}.tgz
20 # Source0-md5:  a2573a076832c4c7212479cabda15eff
21 Source1:        %{name}.init
22 Source2:        %{name}.logrotate
23 Source3:        %{name}-apache.conf
24 Patch0:         %{name}-DESTDIR.patch
25 Patch1:         %{name}-apache.patch
26 Patch2:         %{name}-dglib_fix_so.patch
27 Patch3:         %{name}-pythonvm.patch
28 Patch4:         %{name}-pic.patch
29 Patch5:         %{name}-nolibnsl.patch
30 Patch6:         %{name}-pnet.patch
31 URL:            http://www.dotgnu.org/dgee.html
32 %{?with_apache1:BuildRequires:  %{apxs1}}
33 %{?with_apache2:BuildRequires:  %{apxs2}}
34 %{?with_apache2:BuildRequires:  apache-devel}
35 %{?with_apache1:BuildRequires:  apache1-devel}
36 BuildRequires:  autoconf >= 2.13
37 BuildRequires:  automake
38 BuildRequires:  expat-devel
39 BuildRequires:  gc-devel
40 BuildRequires:  goldwater-devel >= 0.3.4
41 BuildRequires:  libffi-devel
42 BuildRequires:  phlib-devel >= 1.20
43 BuildRequires:  pnet-compiler-csharp
44 BuildRequires:  pnet-devel >= 0.6.0-2
45 BuildRequires:  pnetlib-base
46 BuildRequires:  rpmbuild(macros) >= 1.268
47 Requires(post): /sbin/ldconfig
48 Requires(post,preun):   /sbin/chkconfig
49 Requires(post,preun):   rc-scripts
50 Requires:       goldwater
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %description
54 The core DotGNU Execution Environment that provides the functionality
55 of accepting, validating and satisfying web service requests.
56
57 %description -l pl
58 Ten pakiet zawiera podstawê ¶rodowiska wykonawczego DotGNU (DotGNU
59 Execution Environment) dostarczaj±c± funkcjonalno¶æ przyjmowania,
60 sprawdzania poprawno¶ci i wykonywania ¿±dañ us³ug WWW.
61
62 %package -n apache1-mod_dgee
63 Summary:        DGEE DSO module for Apache 1.3.x
64 Group:          Networking/Daemons
65 Requires:       %{name} = %{version}-%{release}
66 Requires:       apache1(EAPI) >= 1.3.33-2
67 Requires:       apache1-mod_mime
68
69 %description -n apache1-mod_dgee
70 The DotGNU Execution Environment Core DSO module for Apache 1.3.x.
71
72 %package -n apache-mod_dgee
73 Summary:        DGEE DSO module for Apache 2.x
74 Group:          Networking/Daemons
75 Requires:       %{name} = %{version}-%{release}
76 Requires:       apache(modules-api) = %{apache_modules_api}
77 Requires:       apache-mod_mime
78
79 %description -n apache-mod_dgee
80 The DotGNU Execution Environment Core DSO module for Apache 2.x.
81
82 %prep
83 %setup -q -n %{name}-%{base_version}
84 %patch0 -p1
85 %patch1 -p1
86 %patch2 -p1
87 %patch3 -p1
88 %patch4 -p1
89 %patch5 -p1
90 %{?with_i_have_checked_this_patch_works_not_just_compiles:%patch6 -p1}
91
92 %build
93 %{__aclocal}
94 %{__autoconf}
95 %{__autoheader}
96 %{__automake}
97 CFLAGS="%{rpmcflags} -I/usr/include/python2.4"
98 export CFLAGS
99 %configure \
100         cflags=our \
101         --with-goldwater=%{_prefix} \
102         --with-pnet=%{_prefix} \
103         --with-repository=/var/lib/%{name} \
104         --with-username=http \
105         --with-usergroup=http \
106         --with-python \
107         %{?with_apache1:--with-apache=%{apxs1}} \
108         %{?with_apache2:--with-apache2=%{apxs2}}
109
110 %{__make} -j1
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114
115 %{__make} install \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 # Thise files should be installed by Makefile (I can't fix it):
119 install cslib/DotGNU/DGEE/DotGNU.DGEE.dll \
120         $RPM_BUILD_ROOT%{_libdir}/%{name}
121 install cslib/System/Web/Services/System.Web.Services.dll \
122         $RPM_BUILD_ROOT%{_libdir}/%{name}
123 install cslib/DotGNU/DGEE/Protocols/XmlRpc/XmlRpcService.exe \
124         $RPM_BUILD_ROOT%{_libdir}/%{name}
125
126 install -d $RPM_BUILD_ROOT/var/lib/%{name}/{index,data}
127 install -d $RPM_BUILD_ROOT/var/log/%{name}
128 touch $RPM_BUILD_ROOT/var/log/%{name}/{%{name}.log,stdout,stderr}
129 install -d $RPM_BUILD_ROOT/var/log/archiv/%{name}
130 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
131 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
132 install -d $RPM_BUILD_ROOT/etc/logrotate.d
133 install %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
134
135 %if %{with apache1}
136 install -Dp %{SOURCE3} $RPM_BUILD_ROOT/etc/apache/conf.d/40_mod_dgee.conf
137 %endif
138 %if %{with apache2}
139 install -Dp %{SOURCE3} $RPM_BUILD_ROOT/etc/httpd/httpd.conf/40_mod_dgee.conf
140 %endif
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %post
146 /sbin/ldconfig
147 /sbin/chkconfig --add dgee
148 %service dgee restart "goltwater and dgee services"
149
150 %preun
151 if [ "$1" = "0" ]; then
152         %service dgee stop
153         /sbin/chkconfig --del dgee
154 fi
155
156 %postun -p /sbin/ldconfig
157
158 %post -n apache1-mod_dgee
159 %service -q apache restart
160
161 %postun -n apache1-mod_dgee
162 if [ "$1" = 0 ]; then
163         %service -q apache restart
164 fi
165
166 %post -n apache-mod_dgee
167 %service -q httpd restart
168
169 %postun -n apache-mod_dgee
170 if [ "$1" = 0 ]; then
171         %service -q httpd restart
172 fi
173
174 %files
175 %defattr(644,root,root,755)
176 %doc BINARYINSTALL INSTALL QUICKSTART README
177 %attr(755,root,root) %{_bindir}/*
178 %attr(755,root,root) %{_libdir}/libdgee.so.*.*
179 %attr(755,root,root) %{_libdir}/libdgxml.so.*.*
180 %dir %{_libdir}/%{name}
181 %attr(755,root,root) %{_libdir}/%{name}/*
182 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}*
183 %{_datadir}/%{name}
184 /var/lib/%{name}
185 %attr(754,root,root) /etc/rc.d/init.d/%{name}
186 %attr(730,root,http) %dir /var/log/%{name}
187 %attr(660,root,http) /var/log/%{name}/*
188 %attr(750,root,root) %dir /var/log/archiv/%{name}
189 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/*
190
191 %if %{with apache1}
192 %files -n apache1-mod_dgee
193 %defattr(644,root,root,755)
194 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/apache/conf.d/*_mod_%{name}.conf
195 %attr(755,root,root) %{_libdir}/apache1/mod_%{name}.so
196 %endif
197
198 %if %{with apache2}
199 %files -n apache-mod_dgee
200 %defattr(644,root,root,755)
201 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/httpd/httpd.conf/*_mod_%{name}.conf
202 %attr(755,root,root) %{_libdir}/apache/mod_%{name}.so
203 %endif
This page took 0.087758 seconds and 3 git commands to generate.