]> git.pld-linux.org Git - packages/devtodo.git/commitdiff
- devtodo.sh and devtodo.csh profile scripts
authorPaweł Gołaszewski <blues@pld-linux.org>
Wed, 10 Sep 2008 09:44:25 +0000 (09:44 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    devtodo.csh -> 1.1
    devtodo.sh -> 1.1
    devtodo.spec -> 1.27

devtodo.csh [new file with mode: 0644]
devtodo.sh [new file with mode: 0644]
devtodo.spec

diff --git a/devtodo.csh b/devtodo.csh
new file mode 100644 (file)
index 0000000..b190012
--- /dev/null
@@ -0,0 +1,3 @@
+alias cwdcmd devtodo --timeout --summary
+devtodo --timeout --summary
+
diff --git a/devtodo.sh b/devtodo.sh
new file mode 100644 (file)
index 0000000..2a2b15a
--- /dev/null
@@ -0,0 +1,26 @@
+TODO_OPTIONS="--timeout --summary"
+
+cd()
+{
+       if builtin cd "$@"; then
+               devtodo ${TODO_OPTIONS}
+       fi
+}
+
+pushd()
+{
+       if builtin pushd "$@"; then
+               devtodo ${TODO_OPTIONS}
+       fi
+}
+
+popd()
+{
+       if builtin popd "$@"; then
+               devtodo ${TODO_OPTIONS}
+       fi
+}
+
+# Run todo initially upon login
+devtodo ${TODO_OPTIONS}
+
index 186cce869ef3eaecff05000316f4677a02c59c40..574957028c95d126a3113452dc9aabb85d49f8af 100644 (file)
@@ -8,6 +8,8 @@ Group:          Development/Tools
 #Source0Download: http://swapoff.org/DevTodo
 Source0:       http://swapoff.org/files/devtodo/%{name}-%{version}.tar.gz
 # Source0-md5: 4a6241437cb56f237f850bcd2233c3c4
+Source1:       %{name}.sh
+Source2:       %{name}.ch
 Patch0:                %{name}-stdlib_fix.patch
 URL:           http://swapoff.org/DevTodo
 BuildRequires: autoconf
@@ -54,6 +56,7 @@ katalogu.
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT/etc/profile.d
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
@@ -66,12 +69,16 @@ echo ".so devtodo.1" > $RPM_BUILD_ROOT%{_mandir}/man1/tdl.1
 echo ".so devtodo.1" > $RPM_BUILD_ROOT%{_mandir}/man1/tdr.1
 echo ".so devtodo.1" > $RPM_BUILD_ROOT%{_mandir}/man1/todo.1
 
+install %{SOURCE1} $RPM_BUILD_ROOT/etc/profile.d
+install %{SOURCE2} $RPM_BUILD_ROOT/etc/profile.d
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog NEWS QuickStart README doc/todorc.example doc/*sh
-%attr(755,root,root) %{_bindir}/*
+%config(noreplace,missingok) %verify(not md5 mtime size) /etc/profile.d/*
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
+%attr(755,root,root) %{_bindir}/*
 %{_mandir}/man1/*
This page took 0.061688 seconds and 4 git commands to generate.