]> git.pld-linux.org Git - packages/devsec.git/blob - devsec.spec
- packaged files - created subpackages.
[packages/devsec.git] / devsec.spec
1 # TODO:
2 # - use system libs: ffmpeg!!, mpeg4ip
3 # - requires webserver?
4 # - move cgi files to webappdir, move html files to own directory
5 # - add webapps configuration
6 # - move camera configs to /etc
7 #
8 # Conditional build:
9 Summary:        Devolution Security - video surveillance system for the Linux/X11 platform
10 Name:           devsec
11 Version:        3.0.6
12 Release:        0.2
13 License:        GPL v2
14 Group:          Applications/Multimedia
15 Source0:        http://dl.sourceforge.net/devsec/%{name}-%{version}.tar.gz
16 # Source0-md5:  539db08716f0237c8a8c06c25b368b4b
17 Patch0:         %{name}-no_extern.patch
18 URL:            http://devsec.sourceforge.net/
19 BuildRequires:  SDL-devel >= 1.2.7
20 BuildRequires:  faac-devel >= 1.18
21 # Should be required:
22 #BuildRequires: ffmpeg-devel
23 BuildRequires:  imlib-devel >= 1.9.14
24 BuildRequires:  lame-libs-devel >= 3.95
25 BuildRequires:  libcgi-devel
26 BuildRequires:  libogg-devel
27 BuildRequires:  libpng-devel
28 BuildRequires:  libtemplate-devel
29 BuildRequires:  libvorbis-devel
30 # Required for manuals from ffmpeg (to be removed):
31 BuildRequires:  perl-tools-pod
32 BuildRequires:  rpmbuild(macros) >= 1.268
33 Requires:       %{name}-libs = %{version}-%{release}
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         _webapps        /etc/webapps
37 %define         _webapp         %{name}
38 %define         _webappdir      %{_prefix}/lib/cgi-bin/%{_webapp}
39
40 %description
41 Devolution Security is a video surveillance system for the Linux/X11 platform.
42 Features:
43  - Up to 16 cameras
44  - Motion detection
45  - Record on motion detection
46  - Record up to 25 fps mpeg4 video
47  - Multicast live streams to local network
48  - Unicast to internet IP address
49  - Very configurable
50  - Themeable X11 interface
51  - Configurable helper buttons
52  - Web based interface
53
54 %package cgi
55 Summary:        cgi files for devsec
56 Group:          Applications/WWW
57 Requires:       %{name} = %{version}-%{release}
58 Requires:       webapps
59
60 %description cgi
61
62 %package libs
63 Summary:        libraries for devsec
64 Summary(pl):    Biblioteki do devsec
65 Group:          Libraries
66
67 %description libs
68 Libraries for Devolution Security.
69
70 %description libs -l pl
71 Biblioteki dla Devolution Security.
72
73 %package devel
74 Summary:        Developement files for devsec
75 Group:          Development/Libraries
76 Requires:       %{name}-libs = %{version}-%{release}
77
78 %description devel
79 Developement files for devsec.
80
81 %package static
82 Summary:        Static libraries for devsec
83 Summary(pl):    Statyczne biblioteki devsec
84 Group:          Development/Libraries
85 Requires:       %{name}-devel = %{version}-%{release}
86
87 %description static
88 Static library for devsec.
89
90 %description static -l pl
91 Statyczne biblioteki devsec.
92
93 %prep
94 %setup -q
95 %patch0 -p1
96
97 %build
98 %configure
99 %{__make} \
100         CC="%{__cc}"
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104 install -d $RPM_BUILD_ROOT{%{_webapps}/%{_webapp},%{_webappdir}}
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post   libs -p /sbin/ldconfig
113 %postun libs -p /sbin/ldconfig
114
115 %files
116 %defattr(644,root,root,755)
117 %doc AUTHORS CONSUMER_KEYS ChangeLog README
118 #%%dir %{_sysconfdir}
119 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
120 #%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
121 %attr(755,root,root) %{_bindir}/*
122 %dir %{_libdir}/dtk
123 %dir %{_libdir}/dtk/config
124 %dir %{_libdir}/dtk/config/%{name}
125 %config(noreplace) %verify(not md5 mtime size) %{_libdir}/dtk/config/%{name}/*.conf
126 %dir %{_libdir}/dtk/config/%{name}/messages
127 %{_libdir}/dtk/config/%{name}/messages/*.ulaw
128 %dir %{_libdir}/dtk/config/%{name}/mp4live
129 %config(noreplace) %verify(not md5 mtime size) %{_libdir}/dtk/config/%{name}/mp4live/*.conf
130 %dir %{_libdir}/dtk/skins
131 %{_libdir}/dtk/skins/*.la
132 %{_libdir}/dtk/skins/*.so
133 %dir %{_pixmapsdir}/%{name}
134 %{_pixmapsdir}/%{name}/*.png
135 %{_pixmapsdir}/%{name}/*.yuv
136
137 %files cgi
138 %defattr(644,root,root,755)
139 %attr(755,root,root) /home/httpd/cgi-bin/index.cgi
140 /home/httpd/cgi-bin/templates
141 /home/httpd/html/*.css
142 /home/httpd/html/*.html
143 %dir /home/httpd/html/images
144 /home/httpd/html/images/*.jpg
145 /home/httpd/html/images/*.png
146
147 %files libs
148 %defattr(644,root,root,755)
149 %attr(755,root,root) %{_libdir}/lib*.so.*.*
150
151 %files devel
152 %defattr(644,root,root,755)
153 %{_libdir}/*.la
154 %{_includedir}/*.h
155
156 %files static
157 %defattr(644,root,root,755)
158 %{_libdir}/lib*.a
This page took 0.551951 seconds and 3 git commands to generate.