]> git.pld-linux.org Git - packages/devscripts.git/blobdiff - devscripts.spec
rebuild with python 3.10
[packages/devscripts.git] / devscripts.spec
index d018c4578992cb26fc7253942c8da08e18a92c3b..7ecea24e71cf8108e7fe04bd663d3ef8400f12a6 100644 (file)
@@ -1,15 +1,14 @@
 # TODO
 # - bash-completions subpackage
 # - some junk installed to root: "/devscripts.*"
-%include       /usr/lib/rpm/macros.perl
 Summary:       Scripts for Debian Package maintainers
 Name:          devscripts
-Version:       2.15.7
-Release:       1
+Version:       2.18.6
+Release:       6
 License:       GPL v2+
 Group:         Development
 Source0:       http://ftp.debian.org/debian/pool/main/d/devscripts/%{name}_%{version}.tar.xz
-# Source0-md5: 1655e2c91e42cd48393c65726bc3faa9
+# Source0-md5: 999be6ee14d60fade4d173283152dd2e
 Patch0:                %{name}_docbook.patch
 Patch1:                %{name}_install-layout.patch
 Patch2:                %{name}_install-man.patch
@@ -22,6 +21,7 @@ BuildRequires:        libxslt
 BuildRequires: libxslt-progs
 BuildRequires: perl-DB_File
 BuildRequires: perl-File-DesktopEntry
+BuildRequires: perl-TimeDate
 BuildRequires: perl-base
 BuildRequires: perl-libwww
 BuildRequires: perl-modules
@@ -31,6 +31,7 @@ BuildRequires:        python3-devel
 BuildRequires: python3-setuptools
 BuildRequires: rpm-perlprov >= 4.1-13
 BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.673
 BuildRequires: tar >= 1:1.22
 BuildRequires: xz
 # man for manpage-alert
@@ -47,9 +48,7 @@ Scripts to make the life of a Debian Package maintainer easier.
 %package -n checkbashisms
 Summary:       Check shell scripts for common bash-specific contructs
 Group:         Development
-%if "%{_rpmversion}" >= "5"
 BuildArch:     noarch
-%endif
 
 %description -n checkbashisms
 checkbashisms checks whether a /bin/sh script contains any common
@@ -70,6 +69,9 @@ bash-specific contructs.
 %{__sed} -i -e 's/libwww-perl/perl-libwww/g' scripts/*.pl
 %{__sed} -i -e 's/libdigest-md5-perl/perl-Digest-MD5/g' scripts/*.pl
 
+# python paths
+%{__sed} -i -e 's#setup.py install #setup.py install --prefix=%{_prefix} --install-purelib=%{py3_sitescriptdir} --install-platlib=%{py3_sitedir} #g' scripts/Makefile
+
 %build
 # LIBDIR determines where libvfork gets installed, see scripts/Makefile for LIBDIR
 %{__make} \
@@ -79,6 +81,7 @@ bash-specific contructs.
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_bindir}
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT \
        LIBDIR=%{_libdir}/%{name}
@@ -106,14 +109,17 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/dcontrol
 %attr(755,root,root) %{_bindir}/dd-list
 %attr(755,root,root) %{_bindir}/deb-reversion
+%attr(755,root,root) %{_bindir}/debc
 %attr(755,root,root) %{_bindir}/debchange
 %attr(755,root,root) %{_bindir}/debcheckout
 %attr(755,root,root) %{_bindir}/debclean
 %attr(755,root,root) %{_bindir}/debcommit
 %attr(755,root,root) %{_bindir}/debdiff
+%attr(755,root,root) %{_bindir}/debdiff-apply
 %attr(755,root,root) %{_bindir}/debi
 %attr(755,root,root) %{_bindir}/debpkg
 %attr(755,root,root) %{_bindir}/debrelease
+%attr(755,root,root) %{_bindir}/debrepro
 %attr(755,root,root) %{_bindir}/debrsign
 %attr(755,root,root) %{_bindir}/debsign
 %attr(755,root,root) %{_bindir}/debsnap
@@ -128,9 +134,11 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/dscverify
 %attr(755,root,root) %{_bindir}/edit-patch
 %attr(755,root,root) %{_bindir}/getbuildlog
+%attr(755,root,root) %{_bindir}/git-deborig
 %attr(755,root,root) %{_bindir}/grep-excuses
-%attr(755,root,root) %{_bindir}/licensecheck
+%attr(755,root,root) %{_bindir}/hardening-check
 %attr(755,root,root) %{_bindir}/list-unreleased
+%attr(755,root,root) %{_bindir}/ltnu
 %attr(755,root,root) %{_bindir}/manpage-alert
 %attr(755,root,root) %{_bindir}/mass-bug
 %attr(755,root,root) %{_bindir}/mergechanges
@@ -142,6 +150,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/plotchangelog
 %attr(755,root,root) %{_bindir}/pts-subscribe
 %attr(755,root,root) %{_bindir}/rc-alert
+%attr(755,root,root) %{_bindir}/reproducible-check
 %attr(755,root,root) %{_bindir}/rmadison
 %attr(755,root,root) %{_bindir}/sadt
 %attr(755,root,root) %{_bindir}/suspicious-source
@@ -177,10 +186,12 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/debcheckout.1*
 %{_mandir}/man1/debclean.1*
 %{_mandir}/man1/debcommit.1*
+%{_mandir}/man1/debdiff-apply.1*
 %{_mandir}/man1/debdiff.1*
 %{_mandir}/man1/debi.1*
 %{_mandir}/man1/debpkg.1*
 %{_mandir}/man1/debrelease.1*
+%{_mandir}/man1/debrepro.1*
 %{_mandir}/man1/debrsign.1*
 %{_mandir}/man1/debsign.1*
 %{_mandir}/man1/debsnap.1*
@@ -196,9 +207,11 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/dscverify.1*
 %{_mandir}/man1/edit-patch.1*
 %{_mandir}/man1/getbuildlog.1*
+%{_mandir}/man1/git-deborig.1*
 %{_mandir}/man1/grep-excuses.1*
-%{_mandir}/man1/licensecheck.1*
+%{_mandir}/man1/hardening-check.1*
 %{_mandir}/man1/list-unreleased.1*
+%{_mandir}/man1/ltnu.1*
 %{_mandir}/man1/manpage-alert.1*
 %{_mandir}/man1/mass-bug.1*
 %{_mandir}/man1/mergechanges.1*
@@ -210,6 +223,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/plotchangelog.1*
 %{_mandir}/man1/pts-subscribe.1*
 %{_mandir}/man1/rc-alert.1*
+%{_mandir}/man1/reproducible-check.1*
 %{_mandir}/man1/rmadison.1*
 %{_mandir}/man1/sadt.1*
 %{_mandir}/man1/suspicious-source.1*
@@ -229,6 +243,44 @@ rm -rf $RPM_BUILD_ROOT
 %{py3_sitescriptdir}/%{name}*.egg-info
 %{_datadir}/%{name}
 %{perl_vendorlib}/Devscripts
+%{bash_compdir}/bts
+%{bash_compdir}/build-rdeps
+%{bash_compdir}/chdist
+%{bash_compdir}/checkbashisms
+%{bash_compdir}/dch
+%{bash_compdir}/dcontrol
+%{bash_compdir}/dd-list
+%{bash_compdir}/debc
+%{bash_compdir}/debchange
+%{bash_compdir}/debcheckout
+%{bash_compdir}/debdiff
+%{bash_compdir}/debi
+%{bash_compdir}/debsign
+%{bash_compdir}/debsnap
+%{bash_compdir}/debuild
+%{bash_compdir}/dget
+%{bash_compdir}/dscextract
+%{bash_compdir}/dscverify
+%{bash_compdir}/getbuildlog
+%{bash_compdir}/grep-excuses
+%{bash_compdir}/list-unreleased
+%{bash_compdir}/mass-bug
+%{bash_compdir}/mk-build-deps
+%{bash_compdir}/mk-origtargz
+%{bash_compdir}/pkgnames
+%{bash_compdir}/plotchangelog
+%{bash_compdir}/pts-subscribe
+%{bash_compdir}/pts-unsubscribe
+%{bash_compdir}/rc-alert
+%{bash_compdir}/rmadison
+%{bash_compdir}/transition-check
+%{bash_compdir}/uscan
+%{bash_compdir}/uupdate
+%{bash_compdir}/what-patch
+%{bash_compdir}/who-uploads
+%{bash_compdir}/whodepends
+%{bash_compdir}/wnpp-alert
+%{bash_compdir}/wnpp-check
 
 %files -n checkbashisms
 %defattr(644,root,root,755)
This page took 0.082259 seconds and 4 git commands to generate.