]> git.pld-linux.org Git - packages/devscripts.git/blame - devscripts.spec
- updated BRs
[packages/devscripts.git] / devscripts.spec
CommitLineData
697e766e
ER
1# TODO
2# - bash-completions subpackage
c46be4b9 3# - some junk installed to root: "/devscripts.*"
bbee6e63
ER
4%include /usr/lib/rpm/macros.perl
5Summary: Scripts for Debian Package maintainers
6Name: devscripts
c46be4b9 7Version: 2.15.7
475438a0 8Release: 6
bbee6e63
ER
9License: GPL v2+
10Group: Development
11Source0: http://ftp.debian.org/debian/pool/main/d/devscripts/%{name}_%{version}.tar.xz
c46be4b9 12# Source0-md5: 1655e2c91e42cd48393c65726bc3faa9
bbee6e63 13Patch0: %{name}_docbook.patch
bbee6e63 14Patch1: %{name}_install-layout.patch
bbee6e63 15Patch2: %{name}_install-man.patch
697e766e 16URL: https://packages.debian.org/unstable/admin/devscripts
b6e96f67 17BuildRequires: docbook-dtd42-xml
bbee6e63
ER
18BuildRequires: docbook-style-xsl
19BuildRequires: dpkg
b6e96f67 20BuildRequires: gettext-tools
bbee6e63 21BuildRequires: libxslt
b6e96f67 22BuildRequires: libxslt-progs
bbee6e63 23BuildRequires: perl-DB_File
0304270c 24BuildRequires: perl-TimeDate
bbee6e63 25BuildRequires: perl-File-DesktopEntry
bbee6e63
ER
26BuildRequires: perl-base
27BuildRequires: perl-libwww
28BuildRequires: perl-modules
b6e96f67 29BuildRequires: pkgconfig
bbee6e63
ER
30BuildRequires: po4a
31BuildRequires: python3-devel
32BuildRequires: python3-setuptools
33BuildRequires: rpm-perlprov >= 4.1-13
b6e96f67 34BuildRequires: rpm-pythonprov
bbee6e63
ER
35BuildRequires: tar >= 1:1.22
36BuildRequires: xz
37# man for manpage-alert
38Requires: %{_bindir}/man
39Requires: checkbashisms = %{version}-%{release}
40#Requires: dpkg-dev
409c9e24 41#Requires: sensible-utils
bbee6e63
ER
42Conflicts: rpmdevtools < 8.4
43BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45%description
46Scripts to make the life of a Debian Package maintainer easier.
47
48%package -n checkbashisms
49Summary: Check shell scripts for common bash-specific contructs
3843500c
ER
50Group: Development
51%if "%{_rpmversion}" >= "5"
52BuildArch: noarch
53%endif
bbee6e63
ER
54
55%description -n checkbashisms
56checkbashisms checks whether a /bin/sh script contains any common
57bash-specific contructs.
58
59%prep
60%setup -q
61%patch0 -p1
62%patch1 -p1
63%patch2 -p1
64
409c9e24
ER
65# PLD package names
66# grep -r 'you must have the.*package installed' .
67%{__sed} -i -e 's/liburi-perl/perl-URI/g' scripts/*.pl
68%{__sed} -i -e 's/liblwp-protocol-https-perl/perl-LWP-Protocol-https/g' scripts/*.pl
69%{__sed} -i -e 's/libtimedate-perl/perl-TimeDate/g' scripts/*.pl
70%{__sed} -i -e 's/libfile-desktopentry-perl/perl-File-DesktopEntry/g' scripts/*.pl
71%{__sed} -i -e 's/libwww-perl/perl-libwww/g' scripts/*.pl
72%{__sed} -i -e 's/libdigest-md5-perl/perl-Digest-MD5/g' scripts/*.pl
73
a2e2d5c7
AM
74# python paths
75%{__sed} -i -e 's#setup.py install #setup.py install --prefix=%{_prefix} --install-purelib=%{py3_sitescriptdir} --install-platlib=%{py3_sitedir} #g' scripts/Makefile
76
bbee6e63
ER
77%build
78# LIBDIR determines where libvfork gets installed, see scripts/Makefile for LIBDIR
79%{__make} \
80 LIBDIR=%{_libdir}/%{name} \
81 CFLAGS="$RPM_OPT_FLAGS" \
82 LDFLAGS="$RPM_LD_FLAGS"
83
84%install
85rm -rf $RPM_BUILD_ROOT
a2e2d5c7
AM
86
87install -d $RPM_BUILD_ROOT%{_bindir}
88
697e766e
ER
89%{__make} install \
90 DESTDIR=$RPM_BUILD_ROOT \
bbee6e63
ER
91 LIBDIR=%{_libdir}/%{name}
92
93# Install docs through %doc
3843500c 94rm -r $RPM_BUILD_ROOT%{_docdir}
bbee6e63
ER
95
96%clean
97rm -rf $RPM_BUILD_ROOT
98
99%files
100%defattr(644,root,root,755)
495db905
ER
101%doc README
102%attr(755,root,root) %{_bindir}/add-patch
103%attr(755,root,root) %{_bindir}/annotate-output
104%attr(755,root,root) %{_bindir}/archpath
105%attr(755,root,root) %{_bindir}/bts
106%attr(755,root,root) %{_bindir}/build-rdeps
107%attr(755,root,root) %{_bindir}/chdist
108%attr(755,root,root) %{_bindir}/cowpoke
109%attr(755,root,root) %{_bindir}/cvs-debi
110%attr(755,root,root) %{_bindir}/cvs-debrelease
111%attr(755,root,root) %{_bindir}/cvs-debuild
112%attr(755,root,root) %{_bindir}/dcmd
113%attr(755,root,root) %{_bindir}/dcontrol
114%attr(755,root,root) %{_bindir}/dd-list
115%attr(755,root,root) %{_bindir}/deb-reversion
116%attr(755,root,root) %{_bindir}/debchange
117%attr(755,root,root) %{_bindir}/debcheckout
118%attr(755,root,root) %{_bindir}/debclean
119%attr(755,root,root) %{_bindir}/debcommit
120%attr(755,root,root) %{_bindir}/debdiff
121%attr(755,root,root) %{_bindir}/debi
122%attr(755,root,root) %{_bindir}/debpkg
123%attr(755,root,root) %{_bindir}/debrelease
124%attr(755,root,root) %{_bindir}/debrsign
125%attr(755,root,root) %{_bindir}/debsign
126%attr(755,root,root) %{_bindir}/debsnap
127%attr(755,root,root) %{_bindir}/debuild
128%attr(755,root,root) %{_bindir}/dep3changelog
129%attr(755,root,root) %{_bindir}/desktop2menu
130%attr(755,root,root) %{_bindir}/dget
131%attr(755,root,root) %{_bindir}/diff2patches
132%attr(755,root,root) %{_bindir}/dpkg-depcheck
133%attr(755,root,root) %{_bindir}/dpkg-genbuilddeps
134%attr(755,root,root) %{_bindir}/dscextract
135%attr(755,root,root) %{_bindir}/dscverify
136%attr(755,root,root) %{_bindir}/edit-patch
137%attr(755,root,root) %{_bindir}/getbuildlog
138%attr(755,root,root) %{_bindir}/grep-excuses
139%attr(755,root,root) %{_bindir}/licensecheck
140%attr(755,root,root) %{_bindir}/list-unreleased
141%attr(755,root,root) %{_bindir}/manpage-alert
142%attr(755,root,root) %{_bindir}/mass-bug
143%attr(755,root,root) %{_bindir}/mergechanges
144%attr(755,root,root) %{_bindir}/mk-build-deps
145%attr(755,root,root) %{_bindir}/mk-origtargz
146%attr(755,root,root) %{_bindir}/namecheck
147%attr(755,root,root) %{_bindir}/nmudiff
148%attr(755,root,root) %{_bindir}/origtargz
149%attr(755,root,root) %{_bindir}/plotchangelog
150%attr(755,root,root) %{_bindir}/pts-subscribe
151%attr(755,root,root) %{_bindir}/rc-alert
152%attr(755,root,root) %{_bindir}/rmadison
153%attr(755,root,root) %{_bindir}/sadt
154%attr(755,root,root) %{_bindir}/suspicious-source
155%attr(755,root,root) %{_bindir}/svnpath
156%attr(755,root,root) %{_bindir}/tagpending
157%attr(755,root,root) %{_bindir}/transition-check
158%attr(755,root,root) %{_bindir}/uscan
159%attr(755,root,root) %{_bindir}/uupdate
160%attr(755,root,root) %{_bindir}/what-patch
161%attr(755,root,root) %{_bindir}/who-permits-upload
162%attr(755,root,root) %{_bindir}/who-uploads
163%attr(755,root,root) %{_bindir}/whodepends
164%attr(755,root,root) %{_bindir}/wnpp-alert
165%attr(755,root,root) %{_bindir}/wnpp-check
166%attr(755,root,root) %{_bindir}/wrap-and-sort
167%{_mandir}/man1/add-patch.1
168%{_mandir}/man1/annotate-output.1*
169%{_mandir}/man1/archpath.1*
170%{_mandir}/man1/bts.1*
171%{_mandir}/man1/build-rdeps.1*
172%{_mandir}/man1/chdist.1*
173%{_mandir}/man1/cowpoke.1*
174%{_mandir}/man1/cvs-debc.1*
175%{_mandir}/man1/cvs-debi.1*
176%{_mandir}/man1/cvs-debrelease.1*
177%{_mandir}/man1/cvs-debuild.1*
178%{_mandir}/man1/dcmd.1*
179%{_mandir}/man1/dcontrol.1*
180%{_mandir}/man1/dd-list.1*
181%{_mandir}/man1/deb-reversion.1*
182%{_mandir}/man1/debc.1*
183%{_mandir}/man1/debchange.1*
184%{_mandir}/man1/debcheckout.1*
185%{_mandir}/man1/debclean.1*
186%{_mandir}/man1/debcommit.1*
187%{_mandir}/man1/debdiff.1*
188%{_mandir}/man1/debi.1*
189%{_mandir}/man1/debpkg.1*
190%{_mandir}/man1/debrelease.1*
191%{_mandir}/man1/debrsign.1*
192%{_mandir}/man1/debsign.1*
193%{_mandir}/man1/debsnap.1*
194%{_mandir}/man1/debuild.1*
195%{_mandir}/man1/dep3changelog.1*
196%{_mandir}/man1/desktop2menu.1*
197%{_mandir}/man1/devscripts.1*
198%{_mandir}/man1/dget.1*
199%{_mandir}/man1/diff2patches.1*
200%{_mandir}/man1/dpkg-depcheck.1*
201%{_mandir}/man1/dpkg-genbuilddeps.1*
202%{_mandir}/man1/dscextract.1*
203%{_mandir}/man1/dscverify.1*
204%{_mandir}/man1/edit-patch.1*
205%{_mandir}/man1/getbuildlog.1*
206%{_mandir}/man1/grep-excuses.1*
207%{_mandir}/man1/licensecheck.1*
208%{_mandir}/man1/list-unreleased.1*
209%{_mandir}/man1/manpage-alert.1*
210%{_mandir}/man1/mass-bug.1*
211%{_mandir}/man1/mergechanges.1*
212%{_mandir}/man1/mk-build-deps.1*
213%{_mandir}/man1/mk-origtargz.1*
214%{_mandir}/man1/namecheck.1*
215%{_mandir}/man1/nmudiff.1*
216%{_mandir}/man1/origtargz.1*
217%{_mandir}/man1/plotchangelog.1*
218%{_mandir}/man1/pts-subscribe.1*
219%{_mandir}/man1/rc-alert.1*
220%{_mandir}/man1/rmadison.1*
221%{_mandir}/man1/sadt.1*
222%{_mandir}/man1/suspicious-source.1*
223%{_mandir}/man1/svnpath.1*
224%{_mandir}/man1/tagpending.1*
225%{_mandir}/man1/transition-check.1*
226%{_mandir}/man1/uscan.1*
227%{_mandir}/man1/uupdate.1*
228%{_mandir}/man1/what-patch.1*
229%{_mandir}/man1/who-permits-upload.1*
230%{_mandir}/man1/who-uploads.1*
231%{_mandir}/man1/whodepends.1*
232%{_mandir}/man1/wnpp-alert.1*
233%{_mandir}/man1/wnpp-check.1*
234%{_mandir}/man1/wrap-and-sort.1*
bbee6e63
ER
235%{py3_sitescriptdir}/%{name}
236%{py3_sitescriptdir}/%{name}*.egg-info
237%{_datadir}/%{name}
c46be4b9 238%{perl_vendorlib}/Devscripts
bbee6e63
ER
239
240%files -n checkbashisms
241%defattr(644,root,root,755)
242%attr(755,root,root) %{_bindir}/checkbashisms
243%{_mandir}/man1/checkbashisms.1*
This page took 0.109009 seconds and 4 git commands to generate.