]> git.pld-linux.org Git - packages/device-mapper.git/blob - device-mapper.spec
- added selinux bcond; rel 2; STBR
[packages/device-mapper.git] / device-mapper.spec
1 #
2 # Conditional build:
3 %bcond_without  selinux         # build without SELinux support
4 #
5 Summary:        Userspace support for the device-mapper
6 Summary(pl):    Wsparcie dla mapowania urz±dzeñ w przestrzeni u¿ytkownika
7 Name:           device-mapper
8 Version:        1.00.19
9 Release:        2
10 License:        GPL
11 Group:          Applications/System
12 Source0:        ftp://sources.redhat.com/pub/dm/%{name}.%{version}.tgz
13 # Source0-md5:  a7a97c469f22e3ec2cdcb5aae5603f3f
14 URL:            http://sources.redhat.com/dm/
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 %{?with_selinux:BuildRequires:  libselinux-devel >= 1.10}
18 %{?with_selinux:Requires:       libselinux >= 1.10}
19 Conflicts:      dev < 2.9.0-8
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _sbindir        /sbin
23
24 %description
25 The goal of this driver is to support volume management.
26 The driver enables the definition of new block devices composed of
27 ranges of sectors of existing devices. This can be used to define
28 disk partitions - or logical volumes. This light-weight kernel
29 component can support user-space tools for logical volume management.
30
31 %description -l pl
32 Celem tego sterownika jest obs³uga zarz±dzania wolumenami.
33 Sterownik w³±cza definiowanie nowych urz±dzeñ blokowych z³o¿onych z
34 przedzia³ów sektorów na istniej±cych urz±dzeniach. Mo¿e to byæ
35 wykorzystane do definiowania partycji na dysku lub logicznych
36 wolumenów. Ten lekki sk³adnik j±dra mo¿e wspieraæ dzia³aj±ce w
37 przestrzeni u¿ytkownika narzêdzia do zarz±dzania logicznymi
38 wolumenami.
39
40 %package devel
41 Summary:        Header files and development documentation for %{name}
42 Summary(pl):    Pliki nag³ówkowe i dokumentacja do %{name}
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45
46 %description devel
47 Header files and development documentation for %{name}.
48
49 %description devel -l pl
50 Pliki nag³ówkowe i dokumentacja do %{name}.
51
52 %package static
53 Summary:        Static devmapper library
54 Summary(pl):    Statyczna biblioteka devmapper
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 Static devmapper library.
60
61 %description static -l pl
62 Statyczna biblioteka devmapper.
63
64 %prep
65 %setup -q -n %{name}.%{version}
66
67 %build
68 cp -f /usr/share/automake/config.sub autoconf
69 %{__aclocal}
70 %{__autoconf}
71 %configure \
72         SELINUX=%{?with_selinux:yes}%{!?with_selinux:no} \
73         --with-optimisation="%{rpmcflags}" \
74         --with-user=%(id -u) \
75         --with-group=%(id -g) \
76         --with-interface=ioctl
77 %{__make}
78
79 ar cru libdevmapper.a lib/ioctl/*.o lib/*.o
80 ranlib libdevmapper.a
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 install -d $RPM_BUILD_ROOT{/%{_lib},%{_libdir}/%{name}}
85
86 %{__make} install \
87         DESTDIR=$RPM_BUILD_ROOT
88
89 SONAME=$(basename $(ls -1 $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*))
90 ln -sf /%{_lib}/${SONAME} $RPM_BUILD_ROOT%{_libdir}/libdevmapper.so
91 mv -f $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.* $RPM_BUILD_ROOT/%{_lib}
92 cp -f scripts/* $RPM_BUILD_ROOT%{_libdir}/%{name}
93
94 install libdevmapper.a $RPM_BUILD_ROOT%{_libdir}
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post   -p /sbin/ldconfig
100 %postun -p /sbin/ldconfig
101
102 %files
103 %defattr(644,root,root,755)
104 %doc INTRO INSTALL README
105 %attr(755,root,root) %{_sbindir}/*
106 %attr(755,root,root) /%{_lib}/lib*.so.*.*
107 %dir %{_libdir}/%{name}
108 %attr(755,root,root) %{_libdir}/%{name}/*
109 %{_mandir}/man8/*
110
111 %files devel
112 %defattr(644,root,root,755)
113 %attr(755,root,root) %{_libdir}/libdevmapper.so
114 %{_includedir}/*.h
115
116 %files static
117 %defattr(644,root,root,755)
118 %{_libdir}/lib*.a
This page took 0.334879 seconds and 3 git commands to generate.