]> git.pld-linux.org Git - packages/dev.git/commitdiff
zmieniony dev
authorcieciwa <cieciwa@pld-linux.org>
Mon, 26 Apr 1999 14:46:45 +0000 (14:46 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
dodane:
 watchdog, framebuffer, console
usuniete:
cua[0-3]

Changed files:
    dev.spec -> 1.8

dev.spec

index 278a8a5d4bc6f007ce3c2ebf1ffae1d7f016a02e..b3f24f9e200c37a3e8198f48814f739ffd86b202 100644 (file)
--- a/dev.spec
+++ b/dev.spec
@@ -4,14 +4,15 @@ Summary(de):  /dev-Eintr
 Summary(pl):   Pliki specjalne /dev/*
 Summary(tr):   /dev dizini
 Name:          dev
-Version:       2.5.9
-Release:       4
+Version:       2.7.3
+Release:       1
 #######                From ftp.redhat.com/rawhide
-Source:                %{name}-%{version}.cpio
+Source:                %{name}-%{version}.tar.gz
 Copyright:     public domain
 Group:         Base
 Buildroot:     /tmp/%{name}-%{version}-root
 Autoreqprov:   no
+Prereq:                shadow-utils
 
 %description
 Unix and unix like systems (including Linux) use file system entries
@@ -54,13 +55,23 @@ rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT
 BUILD_DIR=`pwd`
 
-# unpack in build root
-( cd $RPM_BUILD_ROOT
-  cpio -iumd < %{SOURCE0}
-)
+#add group for floppy and console
+/usr/sbin/groupadd -g 19 -r -f floppy >/dev/null
+/usr/sbin/groupadd -g 20 -f -r console >/dev/null
 
 # do some cleanup in build root
 cd $RPM_BUILD_ROOT
+tar xpSzf $RPM_SOURCE_DIR/%{name}-%{version}.tar.gz
+
+# tar doesn't save some permissions unless the p option is used
+# this code protects against dev package updaters forgetting to
+# use the p option when unpacking the souce tarball.
+for dev in dev/zero dev/null dev/tty dev/ttyp0 ; do
+  if [ ! $(ls -l $dev | awk '{print $1}') = crw-rw-rw- ] ; then
+    echo bad permissions on device $dev 1>&2
+    exit 1
+  fi
+done
 
 %ifarch sparc
 # SPARC specific devices
@@ -79,69 +90,36 @@ rm -f dev/gscd dev/sbpcd0 dev/atibm dev/inportbm dev/logibm dev/psaux
 
 %endif
 
+%ifarch m68k                                                                    
+# m68k specific devices                                                         
+mknod amigamouse c 10 4                                                         
+mknod atarimouse c 10 5                                                         
+mknod apollomouse c 10 7                                                        
+ln -s amigamouse mouse                                                          
+mknod fdhd0 b 2 4                                                               
+mknod fdhd1 b 2 5                                                               
+mknod fb0 c 29 0                                                                
+mknod fb1 c 29 32                                                               
+mknod fb0current c 29 0                                                         
+mknod fb1current c 29 32                                                        
+mknod kbd c 11 0                                                                
+ln -s fb0 fb                                                                    
+chmod 666 fb*                                                                   
+                                                                                
+# remove devices that will *never* exist on a m68k                              
+rm -f hd* aztcd mcd sbpcd1 cdu31a sbpcd2 scd3                                   
+rm -f sjcd cdu535 sbpcd3 sonycd cm206cd sbpcd                                   
+rm -f gscd sbpcd0 atibm inportbm logibm psaux                                   
+                                                                                
+%endif
+
 chmod 660 dev/lp*
 chgrp daemon dev/lp*
 
-for I in 9 10 11 12; do
-       mknod dev/tty$I c 4 $I
-       chown root:tty dev/tty$I
-       chmod 600 dev/tty$I
-done
-
 cd dev
 
 chgrp floppy fd?*
 
-ln -s ram0 ramdisk
-ln -s ../proc/self/fd fd
-
-mknod pda  b 45 0
-mknod pda1 b 45 1
-mknod pda2 b 45 2
-mknod pda3 b 45 3
-mknod pda4 b 45 4
-
-mknod pdb  b 45 16
-mknod pdb1 b 45 17
-mknod pdb2 b 45 18
-mknod pdb3 b 45 19
-mknod pdb4 b 45 20
-
-mknod pdc  b 45 32
-mknod pdc1 b 45 33
-mknod pdc2 b 45 34
-mknod pdc3 b 45 35
-mknod pdc4 b 45 36
-
-mknod pdd  b 45 48
-mknod pdd1 b 45 49
-mknod pdd2 b 45 50
-mknod pdd3 b 45 51
-mknod pdd4 b 45 52
-
-mknod pcd0 b 46 0
-mknod pcd1 b 46 1
-mknod pcd2 b 46 2
-mknod pcd3 b 46 3
-
-mknod pf0 b 47 0
-mknod pf1 b 47 1
-mknod pf2 b 47 2
-mknod pf3 b 47 3
-
-mknod pt0  c 96 0
-mknod pt1  c 96 1
-mknod pt2  c 96 2
-mknod pt3  c 96 3
-
-chmod 0660      pd[a-d]* pcd[0-3] pf[0-3] pt[0-3]
-chown root:disk pd[a-d]* pcd[0-3] pf[0-3] pt[0-3]
-
-# unix98 pty support 
-mknod ptmx c 5 2
-chmod 666 ptmx; chown root.tty ptmx
-install -d -m 755 pts
-
 # framebuffer support
 mknod fb0 b 29 0
 mknod fb1 b 29 32
@@ -167,8 +145,28 @@ mknod watchdog c 10 130
 # route 
 mknod route c 36 0
 
+%pre
+/usr/sbin/groupadd -g 19 -r -f floppy
+/usr/sbin/groupadd -g 20 -r -f console
+
+%post
+if [ -f /etc/fstab ] ; then
+  # add /dev/pts to fstab if fstab exists (install2 does it during install)
+  if grep 'devpts' /etc/fstab >/dev/null 2>&1 ; then : ; else
+    # note that we do not disallow comments; we wish to allow people
+    # to comment it out if they so desire.
+    TMP=$(mktemp /tmp/fstab.XXXXXX)
+    sed '/\/proc/a\
+none                    /dev/pts                devpts  mode=0622       0 0
+        ' < /etc/fstab > $TMP && mv -f $TMP /etc/fstab || { echo "failed to add devpts filesystem to /etc/fstab" 1>&2 ; exit 1 ; }
+    rm -f $TMP
+  fi
+fi
+
+%postun
+
 %clean 
-rm -rf $RPM_BUILD_ROOT
+#rm -rf $RPM_BUILD_ROOT
 
 %files 
 %defattr(644,root,root,755)
@@ -190,6 +188,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(664,root,root) /dev/cm206cd
 %attr(600,root,root) /dev/console
 %attr(666,root,root) /dev/cui*
+%attr(600,root,root) /dev/cum*
 
 #d#
 %attr(662,root,sys) /dev/dsp
@@ -200,6 +199,8 @@ rm -rf $RPM_BUILD_ROOT
 #f#
 %attr(644,root,  root) /dev/fb*
 %attr(664,root,floppy) /dev/fd*
+%attr(-,root,root) /dev/ftape
+%attr(-,root,root) /dev/full
 
 #g#
 %attr(664,root,root) /dev/gscd
@@ -209,8 +210,10 @@ rm -rf $RPM_BUILD_ROOT
 %attr(660,root,disk) /dev/ht0
 
 #i#
+%attr(664,root,root) /dev/ida/*
 %attr(664,root,root) /dev/inportbm
 %attr(600,root,root) /dev/ippp*
+%attr(600,root,root) /dev/isctl
 %attr(600,root,root) /dev/isdnctrl*
 %attr(444,root,root) /dev/isdninfo
 
@@ -220,7 +223,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(640,root,kmem) /dev/kmem
 
 #l#
-%attr(666,root,root) /dev/log
+#%attr(666,root,root) /dev/log
 %attr(664,root,root) /dev/logibm
 %attr(660,root,disk) /dev/loop*
 
@@ -234,11 +237,14 @@ rm -rf $RPM_BUILD_ROOT
 %attr(666,root, sys) /dev/mixer1
 
 #n#
+%attr(660,root,root) /dev/nb*
 %attr(660,root,disk) /dev/nht0
 %attr(660,root,disk) /dev/nrft*
 %attr(660,root,disk) /dev/nst*
 %attr(666,root,root) /dev/null
 
+%attr(-,root,root) /dev/nftape
+
 #o#
 %attr(664,root,root) /dev/optcd
 
@@ -274,10 +280,13 @@ rm -rf $RPM_BUILD_ROOT
 %attr(660,root,disk) /dev/ram8
 %attr(660,root,disk) /dev/ram9
 
+%attr(-,root,root) /dev/ramdisk
+
 %attr(644,root,root) /dev/random
 %attr(660,root,disk) /dev/rft*
 %attr(644,root,root) /dev/route
 %attr(664,root,root) /dev/rtc
+%attr(600,root,root) /dev/rd/*
 
 #s#
 %attr(640,root,disk) /dev/sbpc*
@@ -322,6 +331,8 @@ rm -rf $RPM_BUILD_ROOT
 
 %attr(666,root,root) /dev/ttyI*
 
+%attr(600,root,root) /dev/ttyM*
+
 %attr(644,root,root) /dev/ttyS*
 
 %attr(666,root, tty) /dev/ttya*
@@ -359,57 +370,9 @@ rm -rf $RPM_BUILD_ROOT
 %attr(666,root,root) /dev/zero
 
 %changelog
-* Thu Apr 22 1999 Wojciech "Sas" Ciêciwa <cieciwa@alpha.zarz.agh.edu.pl>
-  [2.5.9-4]
-- /dev/log moved to sysklog package.
-
-* Sat Dec 12 1998 Sergiusz Paw³owicz <ser@hyperreal.art.pl>
-  [2.5.9-1d]
-- added polish translation to spec (regards to PLD Team),
-- added handles to Unix98 pty support,
-- added handles to framebuffer support,
-- revised spec file, adding group 'floppy' removed.
-- removed initctl -- SysVinit provides it.
-- rewrote spec && major changes. 
-
-* Fri May 08 1998 Michael K. Johnson <johnsonm@redhat.com>
-- added paride devices
-
-* Tue May 05 1998 Erik Troan <ewt@redhat.com>
-- uses a filelist
-- ghosts /dev/log
-
-* Fri May 01 1998 Cristian Gafton <gafton@redhat.com>
-- fixed groupadd call in the %install
-
-* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
-- translations modified for de
-
-* Thu Apr 23 1998 Prospector System <bugs@redhat.com>
-- translations modified for fr, tr
-
-* Thu Apr 23 1998 Erik Troan <ewt@redhat.com>
-- fixed preinstall script
-
-* Tue Apr 21 1998 Erik Troan <ewt@redhat.com>
-- updated groupadd to work with upgrades where the floppy group already exists
-
-* Mon Nov 10 1997 Michael K. Johnson <johnsonm@redhat.com>
-- Added more ramdisk entries
-
-* Wed Oct 29 1997 Michael K. Johnson <johnsonm@redhat.com>
-- Added fd and ramdisk symlinks
-
-* Fri Oct 24 1997 Michael K. Johnson <johnsonm@redhat.com>
-- Added floppy group for floppies; made them group-writable.
-
-* Tue Jul 08 1997 Erik Troan <ewt@redhat.com>
-- added bpcd device
-
-* Thu Apr 10 1997 Erik Troan <ewt@redhat.com>
-- Added ftape devices
-
-* Tue Mar 25 1997 Erik Troan <ewt@redhat.com>
-- Fixed stdin, stdout devices.
-- Moved rtc to cpio archive
-- Added ISDN devices
+* Mon Apr 26 1999 Wojciech "Sas" Ciêciwa <cieciwa@alpha.zarz.agh.edu.pl>
+  [2.7.3-1]
+- upgrade to 2.7.3,
+- added pts update,
+- added route, watchdog, framebuffer, console device,
+- removed /dev/log, /dev/cua[0-3].
This page took 0.147663 seconds and 4 git commands to generate.