]> git.pld-linux.org Git - packages/depot_tools.git/blob - depot_tools.spec
823c76c025f4e634c8112dbe474d88db64786c96
[packages/depot_tools.git] / depot_tools.spec
1 %define         snap    20130619
2 %define         rel             0.10
3 Summary:        A package of scripts called used to manage checkouts and code reviews
4 Name:           depot_tools
5 Version:        0.1
6 Release:        0.%{snap}.%{rel}
7 License:        BSD
8 Group:          Development/Tools
9 Source0:        https://src.chromium.org/svn/trunk/tools/depot_tools.zip?/%{name}-svn%{snap}.zip
10 # Source0-md5:  6cf6483d6da8d15848cbaa8857aae3ae
11 Patch0: adjust-path.patch
12 URL:            http://dev.chromium.org/developers/how-tos/depottools
13 BuildRequires:  unzip
14 Requires:       python
15 BuildArch:      noarch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Chromium uses a package of scripts, the depot_tools, to manage
20 interaction with the Chromium source code repository and the Chromium
21 development process. It contains the following utilities:
22
23 - gclient: Meta-checkout tool managing both subversion and git
24   checkouts. It is similar to repo tool except that it works on Linux,
25   OS X, and Windows and supports both svn and git. On the other hand,
26   gclient doesn't integrate any code review functionality.
27 - gcl: Rietveld code review tool for subversion. The gcl tool runs
28   presubmit scripts.
29 - git-cl: Rietveld code review tool for git. The git-cl tool runs
30   presubmit scripts.
31 - hammer: (Obsolete) Wrapper script for building Chromium with the
32   SCons software construction tool.
33 - drover: Quickly revert svn commits.
34 - cpplint.py: Checks for C++ style compliance.
35 - presubmit_support.py: Runs PRESUBMIT.py presubmit checks.
36 - repo: The repo tool.
37 - trychange.py: Try server tool. It is wrapped by gcl try and git-try.
38 - git-try: Try change tool for git users
39 - wtf: Displays the active git branches in a chromium os checkout.
40 - weekly: Displays the log of checkins for a particular developer
41   since a particular date for git checkouts.
42 - git-gs: Wrapper for git grep with relevant source types.
43 - zsh-goodies: Completion for zsh users.
44
45 %prep
46 %setup -qc
47 mv depot_tools/* .
48 rm -r depot_tools
49 %patch0 -p1
50
51 cat > py-wrap.sh <<'EOF'
52 #!/bin/sh
53 exec %{__python} -B %{_datadir}/%{name}/$(basename "$0").py "$@"
54 EOF
55 chmod +x *.sh
56 ln -s git_cl.py git-cl.py
57
58 # python 2.4 components
59 rm -r third_party/pymox
60
61 # screw binaries and shipped dependencies and things useless to this platform
62 rm ninja*
63 find -type f '(' -name '*.exe' -o -name '*.bat' ')' | xargs rm -v
64 rm create-ntfs-junction.c
65
66 # tests
67 rm -r testing_support
68 rm -r tests
69
70 # other junk
71 rm -r bootstrap
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 install -d $RPM_BUILD_ROOT{%{_datadir}/%{name},%{_bindir}}
76 cp -a . $RPM_BUILD_ROOT%{_datadir}/%{name}
77 # already in %doc
78 rm $RPM_BUILD_ROOT%{_datadir}/%{name}/{LICENSE,README*}
79 rm $RPM_BUILD_ROOT%{_datadir}/%{name}/{OWNERS,WATCHLISTS}
80
81 for a in gclient gcl git-cl fetch; do
82         ln -s %{_datadir}/%{name}/py-wrap.sh $RPM_BUILD_ROOT%{_bindir}/$a
83 done
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %files
89 %defattr(644,root,root,755)
90 %doc LICENSE README README.gclient
91 %attr(755,root,root) %{_bindir}/gcl
92 %attr(755,root,root) %{_bindir}/gclient
93 %attr(755,root,root) %{_bindir}/git-cl
94 %attr(755,root,root) %{_bindir}/fetch
95 %dir %{_datadir}/%{name}
96 %attr(755,root,root) %{_datadir}/%{name}/apply_issue
97 %attr(755,root,root) %{_datadir}/%{name}/cbuildbot
98 %attr(755,root,root) %{_datadir}/%{name}/chrome_set_ver
99 %attr(755,root,root) %{_datadir}/%{name}/codereview.settings
100 %attr(755,root,root) %{_datadir}/%{name}/create-chromium-git-src
101 %attr(755,root,root) %{_datadir}/%{name}/cros
102 %attr(755,root,root) %{_datadir}/%{name}/cros_sdk
103 %attr(755,root,root) %{_datadir}/%{name}/crup-runner.sh
104 %attr(755,root,root) %{_datadir}/%{name}/download_from_google_storage
105 %attr(755,root,root) %{_datadir}/%{name}/drover
106 %attr(755,root,root) %{_datadir}/%{name}/fetch
107 %attr(755,root,root) %{_datadir}/%{name}/gcl
108 %attr(755,root,root) %{_datadir}/%{name}/gclient
109 %attr(755,root,root) %{_datadir}/%{name}/git-cl
110 %attr(755,root,root) %{_datadir}/%{name}/git-cl-upload-hook
111 %attr(755,root,root) %{_datadir}/%{name}/git-crsync
112 %attr(755,root,root) %{_datadir}/%{name}/git-crup
113 %attr(755,root,root) %{_datadir}/%{name}/git-gs
114 %attr(755,root,root) %{_datadir}/%{name}/git-lkgr
115 %attr(755,root,root) %{_datadir}/%{name}/git-runhooks
116 %attr(755,root,root) %{_datadir}/%{name}/git-try
117 %attr(755,root,root) %{_datadir}/%{name}/hammer
118 %attr(755,root,root) %{_datadir}/%{name}/py-wrap.sh
119 %attr(755,root,root) %{_datadir}/%{name}/pylint
120 %attr(755,root,root) %{_datadir}/%{name}/pylintrc
121 %attr(755,root,root) %{_datadir}/%{name}/repo
122 %attr(755,root,root) %{_datadir}/%{name}/update_depot_tools
123 %attr(755,root,root) %{_datadir}/%{name}/weekly
124 %attr(755,root,root) %{_datadir}/%{name}/wtf
125
126 %{_datadir}/%{name}/*.py
127 %{_datadir}/%{name}/profile.xml
128 %{_datadir}/%{name}/git-templates/
129 %{_datadir}/%{name}/git_utils/
130 %{_datadir}/%{name}/recipes/
131 %{_datadir}/%{name}/support/
132 %{_datadir}/%{name}/third_party/
133 %{_datadir}/%{name}/zsh-goodies/
This page took 0.065556 seconds and 3 git commands to generate.