]> git.pld-linux.org Git - packages/denemo.git/blob - denemo.spec
4626a5d400516132f62b233a19bfa0275165d33b
[packages/denemo.git] / denemo.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa    # without ALSA support
4 %bcond_with     gtk1    # use GTK+ 1.2 instead of GTK+ 2
5 #
6 Summary:        Gtk frontend for GNU lilypond
7 Summary(pl):    Frontend Gtk na GNU lilypond
8 Name:           denemo
9 Version:        0.7.2a
10 Release:        2
11 License:        GPL
12 Group:          X11/Applications/Sound
13 Source0:        http://dl.sourceforge.net/denemo/%{name}-%{version}.tar.gz
14 # Source0-md5:  2d57e4d660e13eb6e476104c788046af
15 Patch0:         %{name}-opt.patch
16 Patch1:         %{name}-po.patch
17 URL:            http://denemo.sourceforge.net/
18 %{?with_alsa:BuildRequires:     alsa-lib-devel >= 0.9.0}
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 %{?with_gtk1:BuildRequires:     gtk+-devel >= 1.2.0}
22 %{!?with_gtk1:BuildRequires:    gtk+2-devel >= 2.0.0}
23 BuildRequires:  libtool
24 BuildRequires:  libxml2-devel >= 2.0.0
25 #BuildRequires: niffsdk-devel
26 %{!?with_gtk1:BuildRequires:    pkgconfig}
27 Requires:       TiMidity++
28 Requires:       lilypond
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _noautocompressdoc      *.ly
32
33 %description
34 Denemo is a graphical music notation program written in C with gtk+.
35
36 It is intended to be used in conjunction with GNU Lilypond
37 (http://www.cs.uu.nl/hanwen/lilypond/), but is adaptable to other
38 computer-music-related purposes as well.
39
40 %description -l pl
41 Denemo to program do graficznej notacji muzycznej u¿ywaj±cy gtk+.
42
43 Jest przeznaczony do u¿ywania z GNU Lilypond
44 (http://www.cs.uu.nl/hanwen/lilypond/), ale mo¿e byæ zaadaptowany do
45 innych celów zwi±zanych z muzyk±.
46
47 %package devel
48 Summary:        Header files for denemo plugins development
49 Summary(pl):    Pliki nag³ówkowe do tworzenia wtyczek dla denemo
50 Group:          Development/Libraries
51 # doesn't require base
52
53 %description devel
54 Header files for denemo plugins development.
55
56 %description devel -l pl
57 Pliki nag³ówkowe do tworzenia wtyczek dla denemo.
58
59 %prep
60 %setup -q
61 %patch0 -p1
62 %patch1 -p1
63
64 %build
65 %{!?with_alsa:echo 'AC_DEFUN([AM_PATH_ALSA],[$3])' >> acinclude.m4}
66 %{__libtoolize}
67 %{__aclocal}
68 %{__autoconf}
69 %{__autoheader}
70 %{__automake}
71 CFLAGS="%{rpmcflags} %{?debug:-DDEBUG}"
72 %configure \
73         --disable-static \
74         %{!?with_gtk1:--enable-gtk2} \
75         --with-plugins=analysis
76 # ,niff - but it's incomplete (no interface between niff and denemo)
77
78 %{__make}
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82
83 %{__make} install \
84         DESTDIR=$RPM_BUILD_ROOT
85
86 %find_lang %{name}
87
88 # no *.la for modules - shut up check-files
89 rm -f $RPM_BUILD_ROOT%{_libdir}/denemo/*.la
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %files -f %{name}.lang
95 %defattr(644,root,root,755)
96 %doc AUTHORS DESIGN GOALS NEWS README TODO examples/*.ly
97 %attr(755,root,root) %{_bindir}/*
98 %{_datadir}/%{name}
99 %dir %{_libdir}/denemo
100 %attr(755,root,root) %{_libdir}/denemo/libanalyse.so*
101
102 %files devel
103 %defattr(644,root,root,755)
104 %{_includedir}/denemo
This page took 0.137617 seconds and 3 git commands to generate.