]> git.pld-linux.org Git - packages/democracy.git/blob - democracy.spec
- fix amd64 build, pass CC
[packages/democracy.git] / democracy.spec
1 Summary:        Internet television application
2 Name:           democracy
3 Version:        0.9.2.2
4 Release:        0.1
5 License:        GPL
6 Group:          Applications/Multimedia
7 Source0:        ftp://ftp.osuosl.org/pub/pculture.org/democracy/src/Democracy-%{version}.tar.gz
8 # Source0-md5:  0b92aa3efb2a93e7c066152137fcf9fa
9 Patch0:         %{name}-lib64.patch
10 URL:            http://www.getdemocracy.com/
11 BuildRequires:  boost-python-devel
12 BuildRequires:  libfame
13 BuildRequires:  mozilla-firefox-devel
14 BuildRequires:  python-Pyrex
15 BuildRequires:  python-devel >= 1:2.4
16 BuildRequires:  python-pygtk-devel
17 BuildRequires:  xine-lib-devel
18 Requires:       python-dbus
19 %pyrequires_eq  python
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Democracy Player (also known as Democracy and DTV) is an Internet
24 television application developed by the Participatory Culture
25 Foundation (PCF). It can automatically download videos from RSS-based
26 "channels", as well as managing and playing the videos collected from
27 these channels.
28
29 Democracy Player integrates an RSS aggregator, a BitTorrent client,
30 and VLC media player (or Xine Media Player under GNU/Linux).
31
32 %prep
33 %setup -q -n Democracy-%{version}
34 %if "%{_lib}" != "lib"
35 %patch0 -p1
36 %endif
37
38 mv platform/gtk-x11/README README.gtk-x11
39
40 %build
41 cd platform/gtk-x11
42
43 CC="%{__cc}" \
44 CFLAGS="%{rpmcflags}" \
45 %{__python} setup.py build
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 cd platform/gtk-x11
51 %{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
52 cd ../..
53
54 %py_postclean $RPM_BUILD_ROOT%{py_sitedir}/democracy
55
56 %find_lang democracyplayer
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files -f democracyplayer.lang
62 %defattr(644,root,root,755)
63 %doc CREDITS README README.gtk-x11
64 %attr(755,root,root) %{_bindir}/democracyplayer
65
66 %dir %{py_sitedir}/democracy
67 %{py_sitedir}/democracy/*.py[co]
68 %dir %{py_sitedir}/democracy/BitTorrent
69 %{py_sitedir}/democracy/BitTorrent/*.py[co]
70 %dir %{py_sitedir}/democracy/compiled_templates
71 %{py_sitedir}/democracy/compiled_templates/*.py[co]
72 %dir %{py_sitedir}/democracy/compiled_templates/unittest
73 %{py_sitedir}/democracy/compiled_templates/unittest/*.py[co]
74 %dir %{py_sitedir}/democracy/dl_daemon
75 %{py_sitedir}/democracy/dl_daemon/*.py[co]
76 %dir %{py_sitedir}/democracy/dl_daemon/private
77 %{py_sitedir}/democracy/dl_daemon/private/*.py[co]
78 %dir %{py_sitedir}/democracy/frontend_implementation
79 %{py_sitedir}/democracy/frontend_implementation/*.py[co]
80 %dir %{py_sitedir}/democracy/test
81 %{py_sitedir}/democracy/test/*.py[co]
82 %attr(755,root,root) %{py_sitedir}/democracy/MozillaBrowser.so
83 %attr(755,root,root) %{py_sitedir}/democracy/database.so
84 %attr(755,root,root) %{py_sitedir}/democracy/fasttypes.so
85 %attr(755,root,root) %{py_sitedir}/democracy/sorts.so
86 %attr(755,root,root) %{py_sitedir}/democracy/xine.so
87 %attr(755,root,root) %{py_sitedir}/democracy/xlibhelper.so
88
89 %{_desktopdir}/democracyplayer.desktop
90 %{_datadir}/democracy
91 %{_mandir}/man1/democracyplayer.1*
92 %{_datadir}/mime/packages/democracy.xml
93 %{_pixmapsdir}/democracyplayer-*.png
This page took 0.086192 seconds and 3 git commands to generate.