]> git.pld-linux.org Git - packages/democracy.git/blob - democracy.spec
- tabs
[packages/democracy.git] / democracy.spec
1 # TODO
2 # - make /usr/lib64/python2.4/site-packages/democracy/MozillaBrowser.so
3 #   to be linked with RPATH /usr/lib64/xulrunner. actually to fix as setuputils
4 #   passes -R which is not accepted by compiler (should be -Wl,-rpath,/usr/lib64/xulrunner).
5 #   until then start program with 'LD_LIBRARY_PATH=/usr/lib64/xulrunner democracy'
6 Summary:        Internet television application
7 Name:           democracy
8 Version:        0.9.2.2
9 Release:        0.2
10 License:        GPL
11 Group:          Applications/Multimedia
12 Source0:        ftp://ftp.osuosl.org/pub/pculture.org/democracy/src/Democracy-%{version}.tar.gz
13 # Source0-md5:  0b92aa3efb2a93e7c066152137fcf9fa
14 Patch0:         %{name}-lib64.patch
15 URL:            http://www.getdemocracy.com/
16 BuildRequires:  boost-python-devel
17 BuildRequires:  libfame
18 BuildRequires:  python-Pyrex
19 BuildRequires:  python-devel >= 1:2.4
20 BuildRequires:  python-pygtk-devel
21 BuildRequires:  xine-lib-devel
22 BuildRequires:  xulrunner-devel
23 Requires:       gstreamer-imagesink-x
24 Requires:       python-dbus
25 Requires:       python-gnome-extras-mozilla
26 Requires:       python-gnome-vfs
27 Requires:       python-gstreamer
28 Requires:       python-pygtk-glade
29 Requires:       shared-mime-info
30 %pyrequires_eq  python
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Democracy Player (also known as Democracy and DTV) is an Internet
35 television application developed by the Participatory Culture
36 Foundation (PCF). It can automatically download videos from RSS-based
37 "channels", as well as managing and playing the videos collected from
38 these channels.
39
40 Democracy Player integrates an RSS aggregator, a BitTorrent client,
41 and VLC media player (or Xine Media Player under GNU/Linux).
42
43 %prep
44 %setup -q -n Democracy-%{version}
45 %if "%{_lib}" != "lib"
46 %patch0 -p1
47 %endif
48
49 mv platform/gtk-x11/README README.gtk-x11
50
51 %build
52 cd platform/gtk-x11
53
54 CC="%{__cc}" \
55 CFLAGS="%{rpmcflags}" \
56 %{__python} setup.py build
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 cd platform/gtk-x11
62 %{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
63 cd ../..
64
65 %py_postclean $RPM_BUILD_ROOT%{py_sitedir}/democracy
66
67 %find_lang democracyplayer
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files -f democracyplayer.lang
73 %defattr(644,root,root,755)
74 %doc CREDITS README README.gtk-x11
75 %attr(755,root,root) %{_bindir}/democracyplayer
76
77 %dir %{py_sitedir}/democracy
78 %{py_sitedir}/democracy/*.py[co]
79 %dir %{py_sitedir}/democracy/BitTorrent
80 %{py_sitedir}/democracy/BitTorrent/*.py[co]
81 %dir %{py_sitedir}/democracy/compiled_templates
82 %{py_sitedir}/democracy/compiled_templates/*.py[co]
83 %dir %{py_sitedir}/democracy/compiled_templates/unittest
84 %{py_sitedir}/democracy/compiled_templates/unittest/*.py[co]
85 %dir %{py_sitedir}/democracy/dl_daemon
86 %{py_sitedir}/democracy/dl_daemon/*.py[co]
87 %dir %{py_sitedir}/democracy/dl_daemon/private
88 %{py_sitedir}/democracy/dl_daemon/private/*.py[co]
89 %dir %{py_sitedir}/democracy/frontend_implementation
90 %{py_sitedir}/democracy/frontend_implementation/*.py[co]
91 %dir %{py_sitedir}/democracy/test
92 %{py_sitedir}/democracy/test/*.py[co]
93 %attr(755,root,root) %{py_sitedir}/democracy/MozillaBrowser.so
94 %attr(755,root,root) %{py_sitedir}/democracy/database.so
95 %attr(755,root,root) %{py_sitedir}/democracy/fasttypes.so
96 %attr(755,root,root) %{py_sitedir}/democracy/sorts.so
97 %attr(755,root,root) %{py_sitedir}/democracy/xine.so
98 %attr(755,root,root) %{py_sitedir}/democracy/xlibhelper.so
99
100 %{_desktopdir}/democracyplayer.desktop
101 %{_datadir}/democracy
102 %{_mandir}/man1/democracyplayer.1*
103 %{_datadir}/mime/packages/democracy.xml
104 %{_pixmapsdir}/democracyplayer-*.png
This page took 0.112469 seconds and 3 git commands to generate.