]> git.pld-linux.org Git - packages/demarc.git/blob - demarc.spec
use %service
[packages/demarc.git] / demarc.spec
1 # TODO
2 # - integrate pld webapps framework
3 %define ver     1.05
4 %define subver  RC1
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        Network monitoring program
7 Summary(pl.UTF-8):      Program do monitorowania sieci
8 Name:           demarc
9 Version:        %{ver}.%{subver}
10 Release:        4
11 License:        http://www.demarc.org/license/ (Free for non-commercial use)
12 Group:          Networking
13 Source0:        http://www.demarc.org/downloads/demarc-105/%{name}-%{ver}-%{subver}.tar.gz
14 # Source0-md5:  adf1550b8e7a4936c4b37ac214704f27
15 Source1:        %{name}-apache.conf
16 Source2:        %{name}.init
17 Source3:        %{name}.cron
18 Patch0:         %{name}-config.patch
19 Patch1:         %{name}-whois-fix.patch
20 URL:            http://www.demarc.org/
21 BuildRequires:  perl-Apache-DBI
22 BuildRequires:  perl-CGI
23 BuildRequires:  perl-DBI
24 BuildRequires:  perl-Digest-MD5
25 BuildRequires:  perl-Msql-Mysql-modules
26 BuildRequires:  perl-devel >= 1:5.6
27 BuildRequires:  rpm-perlprov >= 4.1-13
28 BuildRequires:  rpmbuild(macros) >= 1.228
29 Requires(post,preun):   /sbin/chkconfig
30 Requires:       crondaemon
31 Requires:       rc-scripts
32 Requires:       webserver = apache
33 BuildArch:      noarch
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         _bindir         %{_sbindir}
37
38 %description
39 DEMARC is an all-inclusive network monitoring program that allows you
40 to monitor an entire network of servers from one powerful web
41 interface.
42
43 Instead of having one program perform file integrity checks, another
44 program monitoring the connectivity and health of your network, and
45 yet another monitoring your network for intrusion detection attempts,
46 DEMARC combines all three services into one powerful client/server
47 program. Not only can you monitor the status of the different machines
48 in your network, but you can also respond to changes in your network
49 all from one centralized location.
50
51 %description -l pl.UTF-8
52 DEMARC to kompletny system monitorowania sieci pozwalający monitorować
53 całą sieć serwerów z jednego interfejsu WWW.
54
55 Zamiast posiadać jeden program sprawdzający integralność plików, inny
56 program monitorujący połączenia i stan Twojej sieci, i jeszcze jeden
57 program monitorujący sieć w celach detekcji intruzów wystarczy DEMARC
58 łączący w sobie te trzy usługi w jednym programie klient/serwer. Nie
59 tylko możesz monitorować stan różnych maszyn w Twojej sieci ale także
60 możesz reagować na zmiany z jednej centralnej lokalizacji.
61
62 %package client
63 Summary:        Network monitoring program - client
64 Summary(pl.UTF-8):      Program do monitorowania sieci - klient
65 Group:          Networking
66 Requires:       snort(mysql) >= 1.8.1
67
68 %description client
69 DEMARC is an all-inclusive network monitoring program that allows you
70 to monitor an entire network of servers from one powerful web
71 interface.
72
73 This is client program which should be installed on all monitored
74 servers.
75
76 %description client -l pl.UTF-8
77 DEMARC to kompletny system monitorowania sieci pozwalający monitorować
78 całą sieć serwerów z jednego interfejsu WWW.
79
80 To jest program kliencki, który powinien być zainstalowany na
81 wszystkich monitorowanych serwerach.
82
83 %prep
84 %setup -q -n %{name}-%{ver}-%{subver}
85 %patch0 -p1
86 %patch1 -p1
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,demarcd,httpd} \
91         $RPM_BUILD_ROOT{%{_sbindir},%{_datadir}/demarc/{images,cgi}} \
92         $RPM_BUILD_ROOT%{_var}/lib/demarcd
93
94 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/%{name}.conf
95 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/demarcd
96 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}
97 install -p bin/demarcd $RPM_BUILD_ROOT%{_sbindir}
98 cp -p conf/* $RPM_BUILD_ROOT%{_sysconfdir}/demarcd
99 cp -a cgi images $RPM_BUILD_ROOT%{_datadir}/demarc
100 cp -p install/{c*,d*,p*} $RPM_BUILD_ROOT%{_datadir}/demarc
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %post
106 echo 'Remember to add "Include demarc.conf" to httpd.conf.'
107
108 %post client
109 if [ "$1" = "1" ] ; then
110         touch /var/log/demarcd && chmod 750 /var/log/demarcd
111 fi
112 /sbin/chkconfig --add demarcd
113 %service demarcd restart
114 %banner -e -o %{name} <<EOF
115
116 Run "%{_sbindir}/demarcd -I" to install new snort sensor and then
117 run "service demarcd start" to start demarcd daemon.
118
119 Note that in most cases there is no need to start "snort" as
120 separate daemon, so turn it off using "chkconfig snort off".
121 EOF
122
123 %preun client
124 if [ "$1" = "0" ] ; then
125         %service demarcd stop
126         /sbin/chkconfig --del demarcd
127 fi
128
129 %files
130 %defattr(644,root,root,755)
131 %doc install/{CHAN*,INS*,LIC*}
132 %dir %{_datadir}/demarc
133 %{_datadir}/demarc/create_mysql_demarc
134 %{_datadir}/demarc/db_patch_queries
135 %attr(755,root,root) %{_datadir}/demarc/*.pl
136
137 %dir %{_datadir}/demarc/cgi
138 %{_datadir}/demarc/cgi/StaticServices.pm
139 %attr(640,root,http) %{_datadir}/demarc/cgi/DEMARC_config.pm
140 %attr(755,root,root) %{_datadir}/demarc/cgi/demarc
141
142 %dir %{_datadir}/demarc/cgi/templates
143 %{_datadir}/demarc/cgi/templates/*
144
145 %dir %{_datadir}/demarc/images
146 %{_datadir}/demarc/images/*
147
148 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd/demarc.conf
149
150 %files client
151 %defattr(644,root,root,755)
152 %attr(754,root,root) /etc/rc.d/init.d/demarcd
153 %attr(755,root,root) %{_sbindir}/demarcd
154 %attr(750,root,root) %dir %{_sysconfdir}/demarcd
155 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/demarcd/*.conf
156 %attr(750,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/demarcd/*.cmds
157 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}
158 %attr(750,root,root) %{_var}/lib/demarcd
This page took 0.091336 seconds and 3 git commands to generate.