]> git.pld-linux.org Git - packages/demarc.git/blob - demarc.spec
1da82f9eae30ba60dc908d9fe17adc4806dd1526
[packages/demarc.git] / demarc.spec
1 # TODO
2 # - integrate pld webapps framework
3 # - use pld %service
4 %define ver     1.05
5 %define subver  RC1
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        Network monitoring program
8 Summary(pl.UTF-8):      Program do monitorowania sieci
9 Name:           demarc
10 Version:        %{ver}.%{subver}
11 Release:        4
12 License:        http://www.demarc.org/license/ (Free for non-commercial use)
13 Group:          Networking
14 Source0:        http://www.demarc.org/downloads/demarc-105/%{name}-%{ver}-%{subver}.tar.gz
15 # Source0-md5:  adf1550b8e7a4936c4b37ac214704f27
16 Source1:        %{name}-apache.conf
17 Source2:        %{name}.init
18 Source3:        %{name}.cron
19 Patch0:         %{name}-config.patch
20 Patch1:         %{name}-whois-fix.patch
21 URL:            http://www.demarc.org/
22 BuildRequires:  perl-Apache-DBI
23 BuildRequires:  perl-CGI
24 BuildRequires:  perl-DBI
25 BuildRequires:  perl-Digest-MD5
26 BuildRequires:  perl-Msql-Mysql-modules
27 BuildRequires:  perl-devel >= 1:5.6
28 BuildRequires:  rpm-perlprov >= 4.1-13
29 Requires(post,preun):   /sbin/chkconfig
30 Requires:       crondaemon
31 Requires:       rc-scripts
32 Requires:       webserver = apache
33 BuildArch:      noarch
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         _bindir         %{_sbindir}
37
38 %description
39 DEMARC is an all-inclusive network monitoring program that allows you
40 to monitor an entire network of servers from one powerful web
41 interface.
42
43 Instead of having one program perform file integrity checks, another
44 program monitoring the connectivity and health of your network, and
45 yet another monitoring your network for intrusion detection attempts,
46 DEMARC combines all three services into one powerful client/server
47 program. Not only can you monitor the status of the different machines
48 in your network, but you can also respond to changes in your network
49 all from one centralized location.
50
51 %description -l pl.UTF-8
52 DEMARC to kompletny system monitorowania sieci pozwalający monitorować
53 całą sieć serwerów z jednego interfejsu WWW.
54
55 Zamiast posiadać jeden program sprawdzający integralność plików, inny
56 program monitorujący połączenia i stan Twojej sieci, i jeszcze jeden
57 program monitorujący sieć w celach detekcji intruzów wystarczy DEMARC
58 łączący w sobie te trzy usługi w jednym programie klient/serwer. Nie
59 tylko możesz monitorować stan różnych maszyn w Twojej sieci ale także
60 możesz reagować na zmiany z jednej centralnej lokalizacji.
61
62 %package client
63 Summary:        Network monitoring program - client
64 Summary(pl.UTF-8):      Program do monitorowania sieci - klient
65 Group:          Networking
66 Requires:       snort(mysql) >= 1.8.1
67
68 %description client
69 DEMARC is an all-inclusive network monitoring program that allows you
70 to monitor an entire network of servers from one powerful web
71 interface.
72
73 This is client program which should be installed on all monitored
74 servers.
75
76 %description client -l pl.UTF-8
77 DEMARC to kompletny system monitorowania sieci pozwalający monitorować
78 całą sieć serwerów z jednego interfejsu WWW.
79
80 To jest program kliencki, który powinien być zainstalowany na
81 wszystkich monitorowanych serwerach.
82
83 %prep
84 %setup -q -n %{name}-%{ver}-%{subver}
85 %patch0 -p1
86 %patch1 -p1
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,demarcd,httpd} \
91         $RPM_BUILD_ROOT{%{_sbindir},%{_datadir}/demarc/{images,cgi}} \
92         $RPM_BUILD_ROOT%{_var}/lib/demarcd
93
94 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/%{name}.conf
95 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/demarcd
96 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}
97 install -p bin/demarcd $RPM_BUILD_ROOT%{_sbindir}
98 cp -p conf/* $RPM_BUILD_ROOT%{_sysconfdir}/demarcd
99 cp -a cgi images $RPM_BUILD_ROOT%{_datadir}/demarc
100 cp -p install/{c*,d*,p*} $RPM_BUILD_ROOT%{_datadir}/demarc
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %post
106 echo 'Remember to add "Include demarc.conf" to httpd.conf.'
107
108 %post client
109 if [ "$1" = "1" ] ; then
110         touch /var/log/demarcd && chmod 750 /var/log/demarcd
111 fi
112 /sbin/chkconfig --add demarcd
113 if [ -f /var/lock/subsys/demarcd ]; then
114         /etc/rc.d/init.d/demarcd restart 1>&2
115 else
116         echo "Run \"%{_sbindir}/demarcd -I\" to install new snort sensor and then"
117         echo "run \"/etc/rc.d/init.d/demarcd start\" to start demarcd daemon."
118         echo "Note that in most cases there is no need to start \"snort\" as"
119         echo "separate daemon, so turn it off using \"/sbin/chkconfig snort off\"."
120 fi
121
122
123 %preun client
124 if [ "$1" = "0" ] ; then
125         if [ -f /var/lock/subsys/demarcd ]; then
126                 /etc/rc.d/init.d/demarcd stop 1>&2
127         fi
128         /sbin/chkconfig --del demarcd
129 fi
130
131 %files
132 %defattr(644,root,root,755)
133 %doc install/{CHAN*,INS*,LIC*}
134 %dir %{_datadir}/demarc
135 %{_datadir}/demarc/create_mysql_demarc
136 %{_datadir}/demarc/db_patch_queries
137 %attr(755,root,root) %{_datadir}/demarc/*.pl
138
139 %dir %{_datadir}/demarc/cgi
140 %{_datadir}/demarc/cgi/StaticServices.pm
141 %attr(640,root,http) %{_datadir}/demarc/cgi/DEMARC_config.pm
142 %attr(755,root,root) %{_datadir}/demarc/cgi/demarc
143
144 %dir %{_datadir}/demarc/cgi/templates
145 %{_datadir}/demarc/cgi/templates/*
146
147 %dir %{_datadir}/demarc/images
148 %{_datadir}/demarc/images/*
149
150 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd/demarc.conf
151
152 %files client
153 %defattr(644,root,root,755)
154 %attr(754,root,root) /etc/rc.d/init.d/demarcd
155 %attr(755,root,root) %{_sbindir}/demarcd
156 %attr(750,root,root) %dir %{_sysconfdir}/demarcd
157 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/demarcd/*.conf
158 %attr(750,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/demarcd/*.cmds
159 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}
160 %attr(750,root,root) %{_var}/lib/demarcd
This page took 0.052326 seconds and 2 git commands to generate.