]> git.pld-linux.org Git - packages/deluge.git/blob - deluge.spec
4efac22d03f295bb4fb3bfb6fc228c18a886d0aa
[packages/deluge.git] / deluge.spec
1 Summary:        A Python BitTorrent client with support for UPnP and DHT
2 Summary(pl.UTF-8):      Klient BitTorrenta napisany w Pythonie ze wspraciem dla UPnP i DHT
3 Name:           deluge
4 Version:        0.5.5
5 Release:        1
6 License:        GPL
7 Group:          X11/Applications/Networking
8 Source0:        http://download.deluge-torrent.org/tarball/%{version}/%{name}-%{version}.tar.gz
9 # Source0-md5:  76c1f8110aef4131d2bc83a7da957c6a
10 #Source1:       %{name}-fixed-setup.py
11 Patch0:         %{name}-pld.patch
12 Patch1:         %{name}-pyc.patch
13 URL:            http://deluge-torrent.org/
14 BuildRequires:  boost-program_options-devel
15 BuildRequires:  boost-regex-devel
16 BuildRequires:  desktop-file-utils
17 BuildRequires:  libtool
18 BuildRequires:  python-devel >= 1:2.5
19 BuildRequires:  rb_libtorrent-devel
20 BuildRequires:  rpm-pythonprov
21 Requires:       /bin/sh
22 Requires:       python-dbus
23 Requires:       python-pygtk-glade
24 Requires:       python-pyxdg
25 Requires:       rb_libtorrent
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Deluge is a new BitTorrent client, created using Python and GTK+. It
30 is intended to bring a native, full-featured client to Linux GTK+
31 desktop environments such as GNOME and XFCE. It supports features such
32 as DHT (Distributed Hash Tables) and UPnP (Universal Plug-n-Play) that
33 allow one to more easily share BitTorrent data even from behind a
34 router with virtually zero configuration of port-forwarding.
35
36 %description -l pl.UTF-8
37 Deluge to nowy klient BitTorrenta stworzony przy użyciu Pythona i
38 GTK+. Jego celem jest dostarczenie natywnego, w pełni funkcjonalnego
39 klienta dla środowisk GTK+ pod Linuksem, takich jak GNOME czy XFCE.
40 Obsługuje m.in. DHT (Distributed Hash Tables) i UPnP (Universal
41 Plug-n-Play), co pozwala łatwiej współdzielić dane BitTorrenta nawet
42 zza routera praktycznie bez konfiguracji przekierowywania portów.
43
44 %prep
45 %setup -q
46 %patch0 -p1
47 %patch1 -p1
48
49 %build
50 ## We forcibly don't store the installation directory during the build, so
51 ## we need to ensure that it is properly inserted into the code as required.
52 %{__sed} -i -e "s:INSTALL_PREFIX = '@datadir@':INSTALL_PREFIX = '%{_usr}':" \
53         src/common.py
54 %ifarch %{x8664} ppc64 sparc64
55         CFLAGS="%{rpmcflags} -DAMD64" %{__python} setup.py build
56 %else
57         CFLAGS="%{rpmcflags}" %{__python} setup.py build
58 %endif
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 %{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
63
64 ## ...then strip the unneeded shebang lines from some of the plugins...
65 # this seems, wrong, we don't pkg the .py
66 # and if we do chmod -x on files should not fill autodeps
67 #sed -i 1d $RPM_BUILD_ROOT%{py_sitedir}/%{name}/{delugegtk.py,delugeplugins.py}
68
69 %find_lang %{name}
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %files -f %{name}.lang
75 %defattr(644,root,root,755)
76 %doc LICENSE
77 %attr(755,root,root) %{_bindir}/%{name}
78 %dir %{py_sitedir}/%{name}
79 %{py_sitedir}/%{name}/*.py[co]
80 %attr(755,root,root) %{py_sitedir}/%{name}/*.so
81 %{py_sitedir}/%{name}-%{version}-py*.egg-info
82 %{_desktopdir}/%{name}.desktop
83 %{_pixmapsdir}/%{name}.png
84 %{_datadir}/%{name}
This page took 0.570942 seconds and 2 git commands to generate.