]> git.pld-linux.org Git - packages/deluge.git/blob - deluge.spec
- rel.2
[packages/deluge.git] / deluge.spec
1 Summary:        A Python BitTorrent client with support for UPnP and DHT
2 Summary(pl.UTF-8):      Klient BitTorrenta napisany w Pythonie ze wspraciem dla UPnP i DHT
3 Name:           deluge
4 Version:        0.5.8.1
5 Release:        2
6 License:        GPL v2+
7 Group:          X11/Applications/Networking
8 Source0:        http://download.deluge-torrent.org/tarball/%{version}/%{name}-%{version}.tar.gz
9 # Source0-md5:  19c1ac3ba6910f52b5918b56526e74a0
10 #Source1:       %{name}-fixed-setup.py
11 Patch0:         %{name}-pld.patch
12 URL:            http://deluge-torrent.org/
13 BuildRequires:  boost-array-devel
14 BuildRequires:  boost-date_time-devel
15 BuildRequires:  boost-filesystem-devel
16 BuildRequires:  boost-program_options-devel
17 BuildRequires:  boost-regex-devel
18 BuildRequires:  desktop-file-utils
19 BuildRequires:  libtool
20 BuildRequires:  python-devel >= 1:2.5
21 BuildRequires:  rb_libtorrent-devel
22 BuildRequires:  rpm-pythonprov
23 BuildRequires:  rpmbuild(macros) >= 1.311
24 Requires(post,postun):  gtk+2
25 Requires(post,postun):  hicolor-icon-theme
26 Requires:       /bin/sh
27 Requires:       hicolor-icon-theme
28 Requires:       python-dbus
29 Requires:       python-gnome-extras-mozilla
30 Requires:       python-pygtk-glade
31 Requires:       python-pyxdg
32 Requires:       rb_libtorrent
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Deluge is a new BitTorrent client, created using Python and GTK+. It
37 is intended to bring a native, full-featured client to Linux GTK+
38 desktop environments such as GNOME and XFCE. It supports features such
39 as DHT (Distributed Hash Tables) and UPnP (Universal Plug-n-Play) that
40 allow one to more easily share BitTorrent data even from behind a
41 router with virtually zero configuration of port-forwarding.
42
43 %description -l pl.UTF-8
44 Deluge to nowy klient BitTorrenta stworzony przy użyciu Pythona i
45 GTK+. Jego celem jest dostarczenie natywnego, w pełni funkcjonalnego
46 klienta dla środowisk GTK+ pod Linuksem, takich jak GNOME czy XFCE.
47 Obsługuje m.in. DHT (Distributed Hash Tables) i UPnP (Universal
48 Plug-n-Play), co pozwala łatwiej współdzielić dane BitTorrenta nawet
49 zza routera praktycznie bez konfiguracji przekierowywania portów.
50
51 %prep
52 %setup -q -n %{name}-torrent-%{version}
53 %patch0 -p1
54
55 %build
56 ## We forcibly don't store the installation directory during the build, so
57 ## we need to ensure that it is properly inserted into the code as required.
58 %{__sed} -i -e "s:INSTALL_PREFIX = '@datadir@':INSTALL_PREFIX = '%{_usr}':" \
59         src/common.py
60 %ifarch %{x8664} ppc64 sparc64
61         CFLAGS="%{rpmcflags} -DAMD64" %{__python} setup.py build
62 %else
63         CFLAGS="%{rpmcflags}" %{__python} setup.py build
64 %endif
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 %{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
69
70 ## ...then strip the unneeded shebang lines from some of the plugins...
71 # this seems, wrong, we don't pkg the .py
72 # and if we do chmod -x on files should not fill autodeps
73 #sed -i 1d $RPM_BUILD_ROOT%{py_sitedir}/%{name}/{delugegtk.py,delugeplugins.py}
74
75 %find_lang %{name}
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post
81 %update_icon_cache hicolor
82
83 %postun
84 %update_icon_cache hicolor
85
86 %files -f %{name}.lang
87 %defattr(644,root,root,755)
88 %doc LICENSE
89 %attr(755,root,root) %{_bindir}/%{name}
90 %dir %{py_sitedir}/%{name}
91 %{py_sitedir}/%{name}/*.py[co]
92 %attr(755,root,root) %{py_sitedir}/%{name}/*.so
93 %{py_sitedir}/%{name}-%{version}-py*.egg-info
94 %{_desktopdir}/%{name}.desktop
95 %{_pixmapsdir}/%{name}.png
96 %{_iconsdir}/hicolor/16x16/apps/deluge.png
97 %{_iconsdir}/hicolor/22x22/apps/deluge.png
98 %{_iconsdir}/hicolor/24x24/apps/deluge.png
99 %{_iconsdir}/hicolor/32x32/apps/deluge.png
100 %{_iconsdir}/hicolor/36x36/apps/deluge.png
101 %{_iconsdir}/hicolor/48x48/apps/deluge.png
102 %{_iconsdir}/hicolor/64x64/apps/deluge.png
103 %{_iconsdir}/hicolor/72x72/apps/deluge.png
104 %{_iconsdir}/hicolor/96x96/apps/deluge.png
105 %{_iconsdir}/hicolor/128x128/apps/deluge.png
106 %{_iconsdir}/hicolor/192x192/apps/deluge.png
107 %{_iconsdir}/hicolor/256x256/apps/deluge.png
108 %{_datadir}/%{name}
This page took 0.036028 seconds and 3 git commands to generate.